Author Topic: Backup/Restore seems largely non-functional  (Read 8829 times)

Offline Palamedes

  • Newbie
  • *
  • Posts: 36
  • Karma: +5/-0
    • View Profile
    • RandomStringOfWords
Backup/Restore seems largely non-functional
« on: March 07, 2012, 02:38:14 PM »
Create two installs of AbanteCart Cart.  One will be your development or staging install, and one will be the production install.

Add a bunch of stuff to the develop install; categories, merchants, products, images etc..

Back up that "developer" install and restore it to the other "production" fresh install.  This should (and needs to) 100% work allowing you to migrate test on one machine and update to another production install.  It doesn't.

No media is backed up at all and should be -- copy/pasting the images directory structure over doesn't work either or rather only partially works.
Categories and Merchant (brand) listings on the page don't update likely due to some template caching issue.
Etc..

This area needs a lot of love.
~Pal

Offline abantecart

  • Administrator
  • Hero Member
  • *****
  • Posts: 3970
  • Karma: +243/-9
    • View Profile
    • Ideal Open Source Ecommerce Solution
Re: Backup/Restore seems largely non-functional
« Reply #1 on: March 07, 2012, 04:00:42 PM »
I agree with you. Backup and restore should work clean.

We will check and improve this ASAP.
We need your help to build better free open source eCommerce platform for everyone.
See how you can help

Offline Palamedes

  • Newbie
  • *
  • Posts: 36
  • Karma: +5/-0
    • View Profile
    • RandomStringOfWords
Re: Backup/Restore seems largely non-functional
« Reply #2 on: March 07, 2012, 04:25:33 PM »
It looks like if you delete everything out of system/cache after a restore that fixes a bunch of issues.

Not sure about media though.. That one might be more tricky..   I copied the images from one install to the mirror install and half the images still don't work which I find.. strange..
~Pal

Offline Basara

  • Administrator
  • Hero Member
  • *****
  • Posts: 3776
  • Karma: +184/-0
    • View Profile
Re: Backup/Restore seems largely non-functional
« Reply #3 on: March 08, 2012, 02:45:41 AM »
It looks like if you delete everything out of system/cache after a restore that fixes a bunch of issues.

Not sure about media though.. That one might be more tricky..   I copied the images from one install to the mirror install and half the images still don't work which I find.. strange..

Did You try to clear AbanteCart cache in admin front?
http://www.abantecart.com/ecommerce-documentation/57-user-manual/admin-user-manual/system/cache

I can confirm only issue with images files, we will fix it. Others like categories/products/manufacturers/layouts are successfully restored (if clear abantecart cache after import)
“Chuck Norris is so amazing.”
― Mother Teresa

Offline Nimitz1061

  • Full Member
  • ***
  • Posts: 190
  • Karma: +21/-0
  • No matter where you go, there you are...
    • View Profile
Re: Backup/Restore seems largely non-functional
« Reply #4 on: June 27, 2012, 07:49:35 AM »
This begs the question of why the cache is not cleared automatically during the import process.  Perhaps this is a change which should be considered...

David

Offline abolabo

  • core-developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 1747
  • Karma: +238/-10
  • web for all, all for web!
    • View Profile
    • AbanteCart
Re: Backup/Restore seems largely non-functional
« Reply #5 on: June 28, 2012, 06:21:05 AM »
we added cache cleaning in v1.0.3.
thank you
“No one is useless in this world who lightens the burdens of another.”
― Charles Dickens

Offline Nimitz1061

  • Full Member
  • ***
  • Posts: 190
  • Karma: +21/-0
  • No matter where you go, there you are...
    • View Profile
Re: Backup/Restore seems largely non-functional
« Reply #6 on: June 29, 2012, 12:43:43 PM »
Excellent!

David