Author Topic: mutlistore home page won't show  (Read 5135 times)

Offline llegrand

  • Hero Member
  • *****
  • Posts: 1504
  • Karma: +396/-3
    • View Profile
mutlistore home page won't show
« on: October 24, 2013, 12:52:02 PM »
I am running version 1.1.7.   I have used the Create New Store link.   On the admin panel it does show there are two stores,  default and demo. 

Both are subdomains on the same domain:  store.mydomain.net  (default)  and demo.mydomain.net
Categories and Products has the demo store showing in the select box for Stores:

The admin panel when the demo store is selected has the correct link http://demo.mydomain.net/

However,  when I try to use http://demo.mydomain.net/  I do not see a shopping cart.

I am either missing some essential instruction from the documentation on how to hook the demo store to the Master (default) store,  or there is an issue.

Additionally,  there are NO files within the mydomain.net/demo  folder.  Are there suppose to be something within the multistore files?

ALSO:  is there a way for enable a new multi-store to place a check in the categories and products that are in the Master (default) store.  Having to go thru one by one is quite time consuming as it seems to require 2 two-screen function to get to the correct place to click on the store selection.

Thank you for your help.




Offline Basara

  • Administrator
  • Hero Member
  • *****
  • Posts: 4441
  • Karma: +207/-0
    • View Profile
Re: mutlistore home page won't show
« Reply #1 on: October 25, 2013, 01:34:14 AM »
I am running version 1.1.7.   I have used the Create New Store link.   On the admin panel it does show there are two stores,  default and demo. 

Both are subdomains on the same domain:  store.mydomain.net  (default)  and demo.mydomain.net
Categories and Products has the demo store showing in the select box for Stores:

The admin panel when the demo store is selected has the correct link http://demo.mydomain.net/

However,  when I try to use http://demo.mydomain.net/  I do not see a shopping cart.

Hello. Please make sure that the second domain (subdomain) is routed to the correct folder, please read multistore manual



I am either missing some essential instruction from the documentation on how to hook the demo store to the Master (default) store,  or there is an issue.

What do you mean "hook demo to master store?"

Additionally,  there are NO files within the mydomain.net/demo  folder.  Are there suppose to be something within the multistore files?

if You need to create multistore you DON’T NEED to install cart again or anything do with files. Please read doc I think your route subdomain to wrong path
“Chuck Norris is so amazing.”
― Mother Teresa

Offline llegrand

  • Hero Member
  • *****
  • Posts: 1504
  • Karma: +396/-3
    • View Profile
Re: mutlistore home page won't show
« Reply #2 on: October 25, 2013, 10:10:54 AM »
Please give precise instructions on the ' make sure that the second domain (subdomain) is routed to the correct folder,'

The Manual  (which I have read multiple times)  says 'make sure there is no redirection setup for new subdomain/domain'  and there is not any setup.

The input on the new store on Store URL  is shown as http://demo.mydomain.net/

You are saying to make sure to link the subdomain to the path where the default store was installed to
Where is this linking needing to be enabled and what url do I use?



Offline llegrand

  • Hero Member
  • *****
  • Posts: 1504
  • Karma: +396/-3
    • View Profile
Re: mutlistore home page won't show
« Reply #3 on: October 26, 2013, 10:46:04 AM »
continuing on -  I have pointed the subdomain  demo.mydomain.net   to the default store at store.mydomain.net.

Now when I use the url demo.mydomain.net I get the default store.  This is not the result I want.

Searching the board,  I've only found one other post who had the same issue.  And the answer was to read the documentation.  Which hasn't been enough help for me.

So again I ask - 

Master (default store)  is store.domain.net

subdomain  for mutlistore is demo.domain.net

Create New Store has been run.   

What/where does one set up the second domain routing to correct folder?   What is the correct folder?

With more detailed instructions this could be a very simple process.  Perhaps some fuller examples within the instructions would be useful for all.

Thank you  - I look forward to getting complete instructions on this feature.

Offline abantecart

  • Administrator
  • Hero Member
  • *****
  • Posts: 4164
  • Karma: +252/-9
    • View Profile
    • Ideal Open Source Ecommerce Solution
Re: mutlistore home page won't show
« Reply #4 on: October 26, 2013, 06:08:32 PM »
Make sure you have correct URL settings for each store with the same domains/sub-domains that you have set up.

The steps are:

1. Set up domains/sub-domains to point to same server abantecart is installed at
2. Set up apache server (web server) to process all above domains to point to the same AbnateCart directory
3. Create and set up each store with above domains.

Hope this helps

We need your help to build better free open source eCommerce platform for everyone.
See how you can help

Offline llegrand

  • Hero Member
  • *****
  • Posts: 1504
  • Karma: +396/-3
    • View Profile
Re: mutlistore home page won't show
« Reply #5 on: October 26, 2013, 09:37:23 PM »
I believe I have followed those steps.

Here's what's in the domain.

Default store where files are setup is shop.xxxxx  (see pic for precisely what's setup)

Also screen shots of the settings on default and settings on multistore

I don't see where any of this is different than what you have instructed.  But my results remain the same!?!?






Offline abantecart

  • Administrator
  • Hero Member
  • *****
  • Posts: 4164
  • Karma: +252/-9
    • View Profile
    • Ideal Open Source Ecommerce Solution
Re: mutlistore home page won't show
« Reply #6 on: October 26, 2013, 11:32:52 PM »
Check your document root. It needs to be the same, pointing to AbanteCart directory.
We need your help to build better free open source eCommerce platform for everyone.
See how you can help

Offline llegrand

  • Hero Member
  • *****
  • Posts: 1504
  • Karma: +396/-3
    • View Profile
Re: mutlistore home page won't show
« Reply #7 on: October 27, 2013, 01:04:22 AM »
I am not entirely sure what the document root is. But here's what I think you're asking.

Are you saying I should place demo within shop?
And if so,  do I change the entry on the subdomain demo?  and to what?




Offline llegrand

  • Hero Member
  • *****
  • Posts: 1504
  • Karma: +396/-3
    • View Profile
Re: mutlistore home page won't show
« Reply #8 on: October 27, 2013, 02:23:21 PM »
Perhaps it would be faster and easier,  if you just told me what needed to be where.

Let's assume these parmeters:

default (master store)  is setup at store.maindomain.com

multistore is setup at demo.maindomain.com

Cpanel is on the server.

So there are two subdomains on the same domain.

multstore subdomain (demo.maindomain.com)  needs to point where?  And that is input where?

Within the cart admin,  one uses Create New Store.  What goes in Store URL: Include the full URL to your store.
Is this the URL to the multistore http://demo.maindomain.com/
or to the master store http://store.maindomain.com/

This doesn't seem like to should be so difficult - but knowing what really needs to be where and what it needs to say,  would be most useful.




Offline Basara

  • Administrator
  • Hero Member
  • *****
  • Posts: 4441
  • Karma: +207/-0
    • View Profile
Re: mutlistore home page won't show
« Reply #9 on: October 28, 2013, 03:07:06 AM »
Hello. Please make sure that the second domain (subdomain) is routed to the correct folder, please read multistore manual

Please read again manual. There is short Cpanel example for subdomain configure with screenshots.
Just copy text for You "Note: very important - Document Root value should be same with main domain! If you have AbanteCart installed in some folder for example /public_html/somefolder/mycartfolder/ subdomain Root should be the same."
“Chuck Norris is so amazing.”
― Mother Teresa

Offline Basara

  • Administrator
  • Hero Member
  • *****
  • Posts: 4441
  • Karma: +207/-0
    • View Profile
Re: mutlistore home page won't show
« Reply #10 on: October 28, 2013, 03:09:13 AM »
Forgot to mention. Domains/subdomains configuration is Not AbanteCart related  ;)
Please contact with your hosting provider.
“Chuck Norris is so amazing.”
― Mother Teresa

 

Powered by SMFPacks Social Login Mod