Author Topic: Cant run install?  (Read 9416 times)

Offline bama

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
    • View Profile
Cant run install?
« on: April 01, 2012, 02:59:48 PM »
Uploaded the "public_h" folder on my web host site, made the root directory the public_h folder.  When I try to access the site and run the install I get this 500 Internal Server Error:

0
Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, cgiadmin@ yourhostingaccount.coX and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

I'm just typing in my website name in fire fox.

Offline Basara

  • Administrator
  • Hero Member
  • *****
  • Posts: 4137
  • Karma: +202/-0
    • View Profile
Re: Cant run install?
« Reply #1 on: April 02, 2012, 04:41:16 AM »
Hello.

Try to contact with your hosting provider.
Maybe your root directory is still www or htdocs or something else.
“Chuck Norris is so amazing.”
― Mother Teresa

Offline Dunweb

  • Newbie
  • *
  • Posts: 6
  • Karma: +1/-0
    • View Profile
Re: Cant run install?
« Reply #2 on: May 24, 2012, 11:05:48 PM »
Just a note on this:

The download (v1.01) contains a php.ini file that may conflict with your server php.ini file if you install the store into a sub-directory.  I use Godaddy and had this problem today.  I removed the php.ini from the sub-directory and had no additional issues.


Chris

Offline abantecart

  • Administrator
  • Hero Member
  • *****
  • Posts: 4150
  • Karma: +251/-9
    • View Profile
    • Ideal Open Source Ecommerce Solution
Re: Cant run install?
« Reply #3 on: May 25, 2012, 08:07:26 AM »
Good point Chris.

We need to add this check in the installation process somehow.
Do you have more details of the conflict?

Thanks
« Last Edit: May 25, 2012, 08:09:43 AM by abantecart »
We need your help to build better free open source eCommerce platform for everyone.
See how you can help

Offline abolabo

  • core-developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 1773
  • Karma: +246/-11
  • web for all, all for web!
    • View Profile
    • AbanteCart
Re: Cant run install?
« Reply #4 on: May 25, 2012, 08:21:11 AM »
Just a note on this:

The download (v1.01) contains a php.ini file that may conflict with your server php.ini file if you install the store into a sub-directory.  I use Godaddy and had this problem today.  I removed the php.ini from the sub-directory and had no additional issues.


Chris

Hello.
Could you post last lines from your server-log (i mean apache log-file)?
Thanks.
“No one is useless in this world who lightens the burdens of another.”
― Charles Dickens

Offline Dunweb

  • Newbie
  • *
  • Posts: 6
  • Karma: +1/-0
    • View Profile
Re: Cant run install?
« Reply #5 on: May 25, 2012, 09:24:02 AM »
Just a note on this:

The download (v1.01) contains a php.ini file that may conflict with your server php.ini file if you install the store into a sub-directory.  I use Godaddy and had this problem today.  I removed the php.ini from the sub-directory and had no additional issues.


Chris

Hello.
Could you post last lines from your server-log (i mean apache log-file)?
Thanks.


Unfortunately, I do not have logging enabled on this hosting account as there are more than 40 websites currently on my account.  What were you hoping to find in the log ?


Chris

Offline abantecart

  • Administrator
  • Hero Member
  • *****
  • Posts: 4150
  • Karma: +251/-9
    • View Profile
    • Ideal Open Source Ecommerce Solution
Re: Cant run install?
« Reply #6 on: May 25, 2012, 09:35:28 AM »
We need to see what error apache produce on the conflict with php.ini
Can you add this file just for 1 min to see the error log?
We need your help to build better free open source eCommerce platform for everyone.
See how you can help

Offline Dunweb

  • Newbie
  • *
  • Posts: 6
  • Karma: +1/-0
    • View Profile
Re: Cant run install?
« Reply #7 on: May 25, 2012, 09:38:11 AM »
We need to see what error apache produce on the conflict with php.ini
Can you add this file just for 1 min to see the error log?

Oh ok, I understand now.  However, like I said.  That hosting account does not have logging enabled.  With Godaddy you have to enable it if you want it and then it is only active for 48 hours maximum.  Sorry about that. 

I installed it to work on templates for it.  So far, I like it and think Abantecart will become very popular with basic cart users.


Chris

Offline abantecart

  • Administrator
  • Hero Member
  • *****
  • Posts: 4150
  • Karma: +251/-9
    • View Profile
    • Ideal Open Source Ecommerce Solution
Re: Cant run install?
« Reply #8 on: May 25, 2012, 09:42:31 AM »
Thank you. We will nail this problem some other way. :)

let us know if you need help with template creation. just create new topic. FYI. Templates can be as extensions, there is free extension as example.   
We need your help to build better free open source eCommerce platform for everyone.
See how you can help

Offline Dunweb

  • Newbie
  • *
  • Posts: 6
  • Karma: +1/-0
    • View Profile
Re: Cant run install?
« Reply #9 on: May 25, 2012, 09:56:16 AM »
Thank you. We will nail this problem some other way. :)

let us know if you need help with template creation. just create new topic. FYI. Templates can be as extensions, there is free extension as example.

Thanks for the tips, I will create a new topic as I am confused about the extension option.

Chris

 

Powered by SMFPacks Social Login Mod