Author Topic: Language issue - site sometimes does not load default language & menus are blank  (Read 4608 times)

Offline mrchrisbarnes

  • Newbie
  • *
  • Posts: 8
  • Karma: +2/-0
    • View Profile
Hi, I have an issue where on some computers when you load my abantecart website pages it seems to not load the default language & you get blank tabs & menu's throghout the site. It seems to be fine on some machines but not others. Also it seems to happen on some machines on & off. I tried some of my friends computers & it does not load properly, as described but on others it loads fine. It appears to be an issue with loading the language selected for the site. I have tried turning off all the languages but one & it still does it randomly. I have loaded another site & (fresh install) & get the same random effect. Could this be a PHP version or server config issue. I have all ticks in the initial setup as required.

does it with IE8 & Firefox, so assume it must be a config or code issue.
I have even experienced the same with Abantecart demo site.
Any ideas? I have attached a picture of what I am experiencing.

Running Abantecart 1.0 on a windows VPS with PHP 5.2.17, MySql 5.1.48, Microsoft IIS 7.5
« Last Edit: April 07, 2012, 05:41:50 AM by mrchrisbarnes »

Offline abolabo

  • core-developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 1760
  • Karma: +244/-11
  • web for all, all for web!
    • View Profile
    • AbanteCart
hello.
please post all cookies info after your wrong page load.
Also try to replicate this with disabled firewall or antivirus.
please post memory_limit directive value from yours php.ini
If you have ability please attach session file from temp directory of php (with session_id as name)
“No one is useless in this world who lightens the burdens of another.”
― Charles Dickens

Offline Basara

  • Administrator
  • Hero Member
  • *****
  • Posts: 3942
  • Karma: +201/-0
    • View Profile
hello.
please post all cookies info after your wrong page load.
Also try to replicate this with disabled firewall or antivirus.
please post memory_limit directive value from yours php.ini
If you have ability please attach session file from temp directory of php (with session_id as name)

Hi.
I remember I saw this issue only once on my PC (Windows 7 x64)
I saw it only in FireFox 11.0 browser  - so I reinstall my FireFox and this fix issue.


Note: the clearing of FireFox cache doesn't solve the problem. Also I try to clear Session, Domain & Path cookies with web developer addon for firefox - not help. Even with disabled browser addons I see it.
« Last Edit: April 09, 2012, 01:38:09 AM by Basara »
“Chuck Norris is so amazing.”
― Mother Teresa

Offline abantecart

  • Administrator
  • Hero Member
  • *****
  • Posts: 4137
  • Karma: +250/-9
    • View Profile
    • Ideal Open Source Ecommerce Solution
Can you please provide Steps to Replicate this issues on the demo?

We will nail it down.

Thank you.
We need your help to build better free open source eCommerce platform for everyone.
See how you can help

Offline eCommerce Core

  • Administrator
  • Hero Member
  • *****
  • Posts: 1600
  • Karma: +93/-1
    • View Profile
This issue was identified and addressed in next release.

Couse of the issue is the language setting in FF. You most likely you had Accept-Language: en-gb
 
“If you’re in the luckiest one per cent of humanity, you owe it to the rest of humanity to think about the other 99 per cent.”
― Warren Buffett

 

Powered by SMFPacks Social Login Mod