Author Topic: seo url notworking  (Read 8234 times)

Offline ali

  • Newbie
  • *
  • Posts: 13
  • Karma: +0/-0
    • View Profile
seo url notworking
« on: December 19, 2013, 07:53:40 AM »
Hello all,

I found out that the SEO URL is not working when I enable it. i had changed  the .htaccess.txt to .htaccess . Now when I click any link for example categories or products, only page '404 not found' will appear.

Help me please.

Offline abolabo

  • core-developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 1783
  • Karma: +248/-11
  • web for all, all for web!
    • View Profile
    • AbanteCart
Re: seo url notworking
« Reply #1 on: December 19, 2013, 08:01:27 AM »
please use forum search.
i see a lot of answers in results  for you.
“No one is useless in this world who lightens the burdens of another.”
― Charles Dickens

Offline ali

  • Newbie
  • *
  • Posts: 13
  • Karma: +0/-0
    • View Profile
Re: seo url notworking
« Reply #2 on: December 19, 2013, 08:05:56 AM »
thanks for ur reply .. i read all answers still its not working ,,  pls help me out

Offline ali

  • Newbie
  • *
  • Posts: 13
  • Karma: +0/-0
    • View Profile
Re: seo url notworking
« Reply #3 on: December 19, 2013, 08:08:40 AM »
if possible can u let me know step by step procedure how to setup seo in abantecart ....

Offline abolabo

  • core-developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 1783
  • Karma: +248/-11
  • web for all, all for web!
    • View Profile
    • AbanteCart
Re: seo url notworking
« Reply #4 on: December 19, 2013, 09:35:32 AM »
1. be sure that your server supports url rewriting (for ex. mod_rewrite for apache)
2. rename file .htaccess.txt to .htaccess
3. change directive rewriteBase if you have cart installed not in root of domain.
4. go to abantecart settings page and turn seo-support to on.
“No one is useless in this world who lightens the burdens of another.”
― Charles Dickens

Offline alikhan

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
    • View Profile
Re: seo url notworking
« Reply #5 on: December 21, 2013, 06:53:22 PM »
still not working after trying all ways ...


i tried this also

hi,
I search in Google for my answer and I find someone who explain with full détails (but it' s for a other opensource ecommerce solution but it's work very well)  I will give you if you have this problem :

3 steps to setup SEO URLs in Abantecart :

Step 1. : Enable the SEO URLs from the Admin section.

Go to System -> Server -> Use SEO URL’s

Step 2. : Rename the .htaccess.txt to .htaccess (Remove the .txt file extension)

folder: admin
          catalog
          dowload
          image
          install
          system
          .htaccess.txt
          config.php
          error_log
          index.php
          php.ini

** if like me you have 3 time htaccess = (1) .htaccess   (2) .htacess.   and  (3)  .htacces.txt   
I erase .htaccess.txt (3)  after I rename  (1) .htaccess. and finally rename (2) .htaccess

Step 3. : Fill in the SEO Keyword for all the Categories and Products.

SEO Keyword is unique. No duplicate is allowed.
SEO Keyword no space in between each word.
Go to Catalog -> Products -> Data -> Seo Keyword


Done ! Refresh your store shopping cart website to view the result.

If you are still having a problem on it, please check that Is your Abantecart installed into the Subfolder or subdirectory of your domain name ?

For example , http//www.your_domain_name.com

Your store is under [store] folder ,  http//www.your_domain_name.com/store

In this case , you have to do a minor modification on the .htaccess file located in the AbanteCart folder.

Open .htaccess, go to the Line 20

# SEO URL Settings
RewriteEngine On
RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)\?*$ index.php?_route_=$1 [L,QSA]
[Solution] : Edit RewriteBase / to RewriteBase /store/

Source Code after editing

# SEO URL Settings
RewriteEngine On
RewriteBase /store/
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)\?*$ index.php?_route_=$1 [L,QSA]

Done ! Refresh your Abantecart from the browser again, SEO URLs should be working correctly.

Enjoy !

Thank's Abantecart to reply to my question  ;)


still not working pls help me

Offline abantecart

  • Administrator
  • Hero Member
  • *****
  • Posts: 4153
  • Karma: +251/-9
    • View Profile
    • Ideal Open Source Ecommerce Solution
Re: seo url notworking
« Reply #6 on: December 22, 2013, 12:45:38 PM »
RewriteBase /

Is this correct in your case? Do you have AbanteCart installed in web root directory?
We need your help to build better free open source eCommerce platform for everyone.
See how you can help

Offline ali

  • Newbie
  • *
  • Posts: 13
  • Karma: +0/-0
    • View Profile
Re: seo url notworking
« Reply #7 on: December 24, 2013, 06:26:16 AM »
i tried both ways  . still 404 not available. 

Offline ali

  • Newbie
  • *
  • Posts: 13
  • Karma: +0/-0
    • View Profile
Re: seo url notworking
« Reply #8 on: December 24, 2013, 06:35:16 AM »
my files are in Web Root (public_html/www) directory .   

Offline eCommerce Core

  • Administrator
  • Hero Member
  • *****
  • Posts: 1600
  • Karma: +93/-1
    • View Profile
Re: seo url notworking
« Reply #9 on: December 24, 2013, 07:23:17 AM »
You can not try both. It has to be one way, depending on how your site is set up. What is your site URL to abantecart?
“If you’re in the luckiest one per cent of humanity, you owe it to the rest of humanity to think about the other 99 per cent.”
― Warren Buffett

Offline abantecart

  • Administrator
  • Hero Member
  • *****
  • Posts: 4153
  • Karma: +251/-9
    • View Profile
    • Ideal Open Source Ecommerce Solution
Re: seo url notworking
« Reply #10 on: December 26, 2013, 07:56:13 AM »
Since you have abantecart on the root of the domain, you do not need to change anything in original .htaccesss file

https://github.com/abantecart/abantecart-src/blob/master/public_html/.htaccess.txt

Just rename to .htaccess  and enable in the admin.
We need your help to build better free open source eCommerce platform for everyone.
See how you can help

Offline keanu_reeves

  • Newbie
  • *
  • Posts: 16
  • Karma: +1/-0
    • View Profile
Re: seo url notworking
« Reply #11 on: May 28, 2014, 10:44:22 PM »
Can we somehow automate step 3? without editing url_aliases

Step 3. : Fill in the SEO Keyword for all the Categories and Products.

SEO Keyword is unique. No duplicate is allowed.
SEO Keyword no space in between each word.
Go to Catalog -> Products -> Data -> Seo Keyword

Offline Basara

  • Administrator
  • Hero Member
  • *****
  • Posts: 4407
  • Karma: +205/-0
    • View Profile
Re: seo url notworking
« Reply #12 on: May 29, 2014, 02:00:32 AM »
Can we somehow automate step 3? without editing url_aliases

Hello. When You create product or category SEO Keyword value automatically generated from product name
“Chuck Norris is so amazing.”
― Mother Teresa

 

Powered by SMFPacks Social Login Mod