Author Topic: Backward compatible with the low version  (Read 9109 times)

Offline xiphorix

  • Newbie
  • *
  • Posts: 7
  • Karma: +1/-0
    • View Profile
Backward compatible with the low version
« on: August 04, 2012, 02:23:27 AM »
Hi, I have download the Chinest_simple language and German language package from algozone.com, but install them is error, the language package fits abantecart version is V1.01, So I think if you can backward compatible with the low version language package to the lastest version? Thanks

Offline abantecart

  • Administrator
  • Hero Member
  • *****
  • Posts: 4151
  • Karma: +251/-9
    • View Profile
    • Ideal Open Source Ecommerce Solution
Re: Backward compatible with the low version
« Reply #1 on: August 04, 2012, 10:03:33 PM »
What version of AbanteCart do you install to? Please indicate the error you get.
We need your help to build better free open source eCommerce platform for everyone.
See how you can help

Offline xiphorix

  • Newbie
  • *
  • Posts: 7
  • Karma: +1/-0
    • View Profile
Re: Backward compatible with the low version
« Reply #2 on: August 05, 2012, 04:07:10 AM »
I install the lastest V1.04.
The error show:
UPGRADE NOTE: Do not edit or add to this file if you wish to upgrade AbanteCart to newer versions in the future. If you wish to customize AbanteCart for your needs please refer to< your website> for more information. ------------------------------------------------------------------------------
« Last Edit: August 06, 2012, 08:09:55 AM by abantecart »

Offline xiphorix

  • Newbie
  • *
  • Posts: 7
  • Karma: +1/-0
    • View Profile
Re: Backward compatible with the low version
« Reply #3 on: August 05, 2012, 04:34:07 AM »
I found the languge package in web/download/temp, and unzip it, copy the file to the language folder, install them in system_localization_language. I complete them and found the simplified_chinese.xml or german.xml can't load, so that some bottom have no display text.

Offline xiphorix

  • Newbie
  • *
  • Posts: 7
  • Karma: +1/-0
    • View Profile
Re: Backward compatible with the low version
« Reply #4 on: August 05, 2012, 04:42:37 AM »
I notce the waring, and examine them, the notice is great, but the link is language translate, can't solve the problem; and I try to translate some words, a few time the compute became very slow.

Offline abantecart

  • Administrator
  • Hero Member
  • *****
  • Posts: 4151
  • Karma: +251/-9
    • View Profile
    • Ideal Open Source Ecommerce Solution
Re: Backward compatible with the low version
« Reply #5 on: August 06, 2012, 08:17:35 AM »
Quote
I found the languge package in web/download/temp, and unzip it, copy the file to the language folder, install them in system_localization_language. I

Language extension suppose to go to [cart dir]/extensions/ directory. If you want to make language provided in extension working under core system language folder, this will require some setting up. Unfortunately, we do not have steps for this.
We recommend using extension approach provided.

We need your help to build better free open source eCommerce platform for everyone.
See how you can help

Offline xiphorix

  • Newbie
  • *
  • Posts: 7
  • Karma: +1/-0
    • View Profile
Re: Backward compatible with the low version
« Reply #6 on: August 07, 2012, 12:31:12 AM »
Well, I copy files to /extensions/ directory, then I can't vist Dashboard.

Offline abolabo

  • core-developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 1774
  • Karma: +246/-11
  • web for all, all for web!
    • View Profile
    • AbanteCart
Re: Backward compatible with the low version
« Reply #7 on: August 07, 2012, 05:56:14 AM »
Well, I copy files to /extensions/ directory, then I can't vist Dashboard.

please post file system/logs/error.txt
“No one is useless in this world who lightens the burdens of another.”
― Charles Dickens

Offline xiphorix

  • Newbie
  • *
  • Posts: 7
  • Karma: +1/-0
    • View Profile
Re: Backward compatible with the low version
« Reply #8 on: August 08, 2012, 12:34:46 AM »
2012-08-08 11:48:13 - App Error:  Error: Could not load config for <b>ac_simplified_chinese_language_v1.0</b>! in G:\XIPHORIX\Documents\My Web Sites\abantecart\core\engine\extensions.php on line 816
2012-08-08 12:17:00 - App Error:  Error: Could not load config for <b>ac_simplified_chinese_language_v1.0</b>! in G:\XIPHORIX\Documents\My Web Sites\abantecart\core\engine\extensions.php on line 816
2012-08-08 12:17:21 - App Error:  Error: Could not load config for <b>ac_simplified_chinese_language_v1.0</b>! in G:\XIPHORIX\Documents\My Web Sites\abantecart\core\engine\extensions.php on line 816
2012-08-08 12:17:56 - App Error:  Error: Could not load config for <b>ac_simplified_chinese_language_v1.0</b>! in G:\XIPHORIX\Documents\My Web Sites\abantecart\core\engine\extensions.php on line 816
2012-08-08 12:18:07 - App Error:  Error: Could not load config for <b>ac_simplified_chinese_language_v1.0</b>! in G:\XIPHORIX\Documents\My Web Sites\abantecart\core\engine\extensions.php on line 816
2012-08-08 12:18:07 - database error:  Error: Duplicate entry 'ac_simplified_chinese_language_v' for key 'extension_key'<br />Error No: 1062<br />INSERT INTO extensions
                    SET `type` = 'extensions',
                      `key` = 'ac_simplified_chinese_language_v1.0',
                      `category` = '',
                      `status` = '0',
                      `priority` = '',
                      `version` = '',
                      `license_key` = '',
                      `create_date` = NOW() in <b>G:\XIPHORIX\Documents\My Web Sites\abantecart\core\database\mysql.php</b> on line <b>86</b>
2012-08-08 12:18:25 - App Error:  Error: Could not load config for <b>ac_simplified_chinese_language_v1.0</b>! in G:\XIPHORIX\Documents\My Web Sites\abantecart\core\engine\extensions.php on line 816
2012-08-08 12:18:35 - App Error:  Error: Could not load config for <b>ac_simplified_chinese_language_v1.0</b>! in G:\XIPHORIX\Documents\My Web Sites\abantecart\core\engine\extensions.php on line 816
2012-08-08 12:18:35 - database error:  Error: Duplicate entry 'ac_simplified_chinese_language_v' for key 'extension_key'<br />Error No: 1062<br />INSERT INTO extensions
                    SET `type` = 'extensions',
                      `key` = 'ac_simplified_chinese_language_v1.0',
                      `category` = '',
                      `status` = '0',
                      `priority` = '',
                      `version` = '',
                      `license_key` = '',
                      `create_date` = NOW() in <b>G:\XIPHORIX\Documents\My Web Sites\abantecart\core\database\mysql.php</b> on line <b>86</b>


If I delete the language package in /extensions/ directory, the system is OK

Offline abolabo

  • core-developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 1774
  • Karma: +246/-11
  • web for all, all for web!
    • View Profile
    • AbanteCart
Re: Backward compatible with the low version
« Reply #9 on: August 08, 2012, 06:52:43 AM »
try to
1. delete directory from extension.
2. open control panel ->all extensions and delete this extension from list
3. open menu->system-Localisations->languages  and delete chinese language

then install package again
“No one is useless in this world who lightens the burdens of another.”
― Charles Dickens

Offline abantecart

  • Administrator
  • Hero Member
  • *****
  • Posts: 4151
  • Karma: +251/-9
    • View Profile
    • Ideal Open Source Ecommerce Solution
Re: Backward compatible with the low version
« Reply #10 on: August 09, 2012, 08:24:06 AM »
All this happen probably because of manual install and missing files.
Install process is pretty simple actually. Dump extension directory in to extensions/  and follow install in the admin. You will see new extension in the list

To make it even simpler, use extension store (marketplace) to install extension with provided key. Many extensions are free there. Just copy/paste the key and AbanteCart will do all the work of downloading and installing extension for you.

I am sorry you have to go through this.
We need your help to build better free open source eCommerce platform for everyone.
See how you can help

Offline xiphorix

  • Newbie
  • *
  • Posts: 7
  • Karma: +1/-0
    • View Profile
Re: Backward compatible with the low version
« Reply #11 on: August 09, 2012, 10:39:26 AM »
Thank you for your reply. The syetem is great, hope you the next version!!

 

Powered by SMFPacks Social Login Mod