Please help us to make AbanteCart Ideal Open Source Ecommerce Solution for everyone.

Support AbanteCart eCommerce

Author Topic: Strange Issue With Paypal Pro API Solution  (Read 6147 times)

Offline flyn

  • Full Member
  • ***
  • Posts: 142
  • Karma: +8/-0
    • View Profile
Strange Issue With Paypal Pro API Solution
« on: July 01, 2014, 11:21:14 AM »
Since I launched our mobile site on Jun 19th we have had a total of 20 orders so far. I have setup successfully PayPal and PayPal Pro.

Our plant manager was saying that about 15 of these orders there are no automatic shipping labels created in PayPal. She has to do them manually and if we start to get a lot of orders this will be a big issue to do them all manually.

I investigated further and saw what is happening inside PayPal. For the orders that a label was done automatically it shows in payment type instant. I will assume that is for PayPal standard where they go to PayPal and finish payment.

For the one's that don't have a label created automatically it is always the same payment type: (Website Payments Pro API Solution)

Also see attached file here and you will notice it says no shipping address on file. On the correct orders it does show an address.

What is going on here?

All orders have gone thru and completed. The only issue is no shipping address and thus manual shipping labels have to be created.

I looked at extension and all is well. Is it the consumer not filling something in? Perhaps something can be added to cart to make them aware to fill in the address in the correct sections?

Any help is appreciated..


Offline llegrand

  • Hero Member
  • *****
  • Posts: 1462
  • Karma: +382/-2
    • View Profile
Re: Strange Issue With Paypal Pro API Solution
« Reply #1 on: July 01, 2014, 02:52:32 PM »
Hey Victor,  I've had this happen on other selling sites.  The issue is how the set up is constructed for address handling.
Here's the PayPal docs on the options :

https://developer.paypal.com/docs/classic/paypal-payments-standard/integration-guide/Appx_BillingShippingAddress/#id08A9BM00A5Z__BAAHAIIB

Here's more info on passing the address thru - which is the option I believe you want  and hopefully the extension can be configured to automatically pass the info thru.
https://developer.paypal.com/docs/classic/paypal-payments-standard/integration-guide/formbasics/#id08A6F0SJ04Y

Lee


Offline flyn

  • Full Member
  • ***
  • Posts: 142
  • Karma: +8/-0
    • View Profile
Re: Strange Issue With Paypal Pro API Solution
« Reply #2 on: July 01, 2014, 04:09:25 PM »
Thanks Lee but this wont help as my problem is with PayPal Pro not standard.

Offline Basara

  • Administrator
  • Hero Member
  • *****
  • Posts: 4274
  • Karma: +202/-0
    • View Profile
Re: Strange Issue With Paypal Pro API Solution
« Reply #3 on: July 02, 2014, 05:56:00 AM »
I looked at extension and all is well. Is it the consumer not filling something in? Perhaps something can be added to cart to make them aware to fill in the address in the correct sections?

Hello.

Can You please provide shipping address example and what shipping methods used for this orders? We will try to replicate issue
“Chuck Norris is so amazing.”
― Mother Teresa

Offline flyn

  • Full Member
  • ***
  • Posts: 142
  • Karma: +8/-0
    • View Profile
Re: Strange Issue With Paypal Pro API Solution
« Reply #4 on: August 14, 2014, 08:31:34 AM »
370 Ivy Lane
Lawrenceville, GA 30045

Hygienics uses weight based shipping and the shipping method was standard US shipping. Based on the weight we assign a shipping cost to the product(s).

We dont use any Fedex, UPS, DHL etc.. shipping extensions.

Again this issue only occurs with Paypal Pro where they stay at our site to complete a transaction. If they use Paypal Standard which takes them to Paypal and after they complete the transaction there they come back to our success page everything turns out fine.

I wonder if anyone using Paypal Pro also has run into this issue and was able to resolve it?

Offline abolabo

  • core-developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 1780
  • Karma: +247/-11
  • web for all, all for web!
    • View Profile
    • AbanteCart
Re: Strange Issue With Paypal Pro API Solution
« Reply #5 on: January 28, 2015, 02:33:15 PM »
is described issue still present?
Did you checked is your products have "required shipping" mark? I dogged into code and see checks for it.
“No one is useless in this world who lightens the burdens of another.”
― Charles Dickens

 

Powered by SMFPacks Social Login Mod