Author Topic: Admin Backend Site now showing error Forbidden on all media.  (Read 8073 times)

Offline dls2004

  • Newbie
  • *
  • Posts: 15
  • Karma: +7/-1
    • View Profile
Hi All,

I have a problem, today I logged into the backend of my Abantecart V1.1.9. And when I went to products and added a new product and went to the media tab page it displays error Forbidden in red. And i cannot add / edit media for the product.

I went to a previously loaded product, clicked the media tab and this also shows error Forbidden for all media.

I cleared all cache data and this did not resolve the issue.

I checked permissions on the cache folder and these are write and read.

Any idea's why abantecart would suddenly throw this error message.

Help appreciated.

Barry M

Offline Basara

  • Administrator
  • Hero Member
  • *****
  • Posts: 4575
  • Karma: +223/-0
    • View Profile
Re: Admin Backend Site now showing error Forbidden on all media.
« Reply #1 on: July 31, 2014, 04:08:19 AM »
Hello.

Do you have any errors warning in AbanteCart error log just after you see forbidden?
“Chuck Norris is so amazing.”
― Mother Teresa

Offline dls2004

  • Newbie
  • *
  • Posts: 15
  • Karma: +7/-1
    • View Profile
Re: Admin Backend Site now showing error Forbidden on all media.
« Reply #2 on: July 31, 2014, 04:18:46 AM »
Hi Basara,

Here is the error log of today's work.

2014-07-31 7:51:22 - method not exist:  AbanteCart core v.1.1.9 Error: controller method not exist Controllerresponsesproductproduct::main! in /home/dls2004/public_html/store/core/engine/dispatcher.php on line 315
2014-07-31 7:51:36 - method not exist:  AbanteCart core v.1.1.9 Error: controller method not exist Controllerresponsesproductproduct::main! in /home/dls2004/public_html/store/core/engine/dispatcher.php on line 315
2014-07-31 7:54:49 - warning:  AbanteCart core v.1.1.9 Invalid argument supplied for foreach() in <b>/home/dls2004/public_html/store/admin/controller/responses/common/zone.php</b> on line <b>57</b>



Any help would be gratefully appreciated.

The site was fine up until today.

I even tried a clean install of v1.1.9 in new directory with a new MySQL database instance and the error still occurs.

got me stumped?




Offline dls2004

  • Newbie
  • *
  • Posts: 15
  • Karma: +7/-1
    • View Profile
Re: Admin Backend Site now showing error Forbidden on all media.
« Reply #3 on: August 01, 2014, 01:50:09 AM »
Update 01/08/2014.

My hosting service providers reckons they have not made any changes to PHP or MySQL.

I did a clean install of abantecart V1.1.9 in a different sub directory using sample data provided with the clean install.

And I still get the red error Forbidden on all images, media, pdf and video files.

when I attempt to configure resource manager, by clicking on common/resource_library

I get the error as shown below.

I have no idea how to fix this and can only guess my host provider has flicked a switch to which has caused this problem.

I have no way to fix it so am about ready to abandon abantecart as I do not wish to change hosting provider just to resolve this problem.

 

Offline abolabo

  • core-developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 1815
  • Karma: +264/-11
  • web for all, all for web!
    • View Profile
    • AbanteCart
Re: Admin Backend Site now showing error Forbidden on all media.
« Reply #4 on: August 01, 2014, 03:54:00 AM »
is directory "resources" writable?
“No one is useless in this world who lightens the burdens of another.”
― Charles Dickens

Offline dls2004

  • Newbie
  • *
  • Posts: 15
  • Karma: +7/-1
    • View Profile
Re: Admin Backend Site now showing error Forbidden on all media.
« Reply #5 on: August 01, 2014, 05:17:34 AM »
Yes directory resources is writable, has permissions set as 775.

Offline abolabo

  • core-developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 1815
  • Karma: +264/-11
  • web for all, all for web!
    • View Profile
    • AbanteCart
Re: Admin Backend Site now showing error Forbidden on all media.
« Reply #6 on: August 01, 2014, 05:40:19 AM »
check error log of apache (httpd) server in hosting provider CPanel. Probably it's a server misconfiguration.
“No one is useless in this world who lightens the burdens of another.”
― Charles Dickens

Offline dls2004

  • Newbie
  • *
  • Posts: 15
  • Karma: +7/-1
    • View Profile
Re: Admin Backend Site now showing error Forbidden on all media.
« Reply #7 on: August 01, 2014, 07:23:21 PM »
Where would I find the apache (httpd) server error logs in cPanel?

Offline abolabo

  • core-developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 1815
  • Karma: +264/-11
  • web for all, all for web!
    • View Profile
    • AbanteCart
Re: Admin Backend Site now showing error Forbidden on all media.
« Reply #8 on: August 02, 2014, 03:19:14 PM »
Where would I find the apache (httpd) server error logs in cPanel?

you should to ask this question to hosting provider support team...
“No one is useless in this world who lightens the burdens of another.”
― Charles Dickens

Offline dls2004

  • Newbie
  • *
  • Posts: 15
  • Karma: +7/-1
    • View Profile
Re: Admin Backend Site now showing error Forbidden on all media.
« Reply #9 on: August 02, 2014, 07:39:04 PM »
OK thanks will do.

I agree most likely a server configuration error as the problem didn't exist previously and started on 30/07/2014.

Will keep you posted on the outcome.

Update: Problem resolved, looks like the php settings did not get correctly set in cPanel.

Reset PHP settings and made some changes in PHP settings and the media became visible again in the backend. I suspect it was the memory_limit being set to low at 2M.

« Last Edit: August 07, 2014, 07:53:34 PM by dls2004 »

Offline shaun31

  • Newbie
  • *
  • Posts: 2
  • Karma: +1/-0
    • View Profile
Re: Admin Backend Site now showing error Forbidden on all media.
« Reply #10 on: August 14, 2014, 07:41:54 AM »
i have had the same problem recently and contact host company and here is the outcome

While checking the server logs, I find that the domain has trigerred mod-security rules:
==============================
[Wed Aug 13 22:36:01.825014 2014] [:error] [pid 13483] [client 217.147.80.30] ModSecurity: Access denied with code 403 (phase 2). Pattern match "(?i:\\\\b(?:t(?:able_name\\\\b|extpos[^a-zA-Z0-9_]{1,}\\\\()|(?:a(?:ll_objects|tt(?:rel|typ)id)|column_(?:id|name)|mb_users|object_(?:id|(?:nam|typ)e)|pg_(?:attribute|class)|rownum|s(?:ubstr(?:ing){0,1}|ys(?:c(?:at|o(?:lumn|nstraint)s)|dba|ibm|(?:filegroup|o ..." at ARGS_NAMES:object_name. [file "/var/cpanel/cwaf/rules/cwaf_02.conf"] [line "289"] [id "211540"] [msg "COMODO WAF: Blind SQL Injection Attack"] [data "Matched Data: object_name found within ARGS_NAMES:object_name: object_name"] [severity "CRITICAL"] [hostname "website domain here"] [uri "/shop/index.php"] [unique_id "U@vaQdmTUB4AADSrpOoAAAAC"]
=============================

I have disabled mod-securty for your domain now.

i hope this helps anyone which the same problem

Offline DanFronckowiak

  • Newbie
  • *
  • Posts: 11
  • Karma: +1/-0
    • View Profile
Re: Admin Backend Site now showing error Forbidden on all media.
« Reply #11 on: August 14, 2014, 12:55:54 PM »
I was having a similar problem.

I researched and couldn't find much in the way of a solution, so I just went into the database, and used the resource tables to add them manually.

Once I did that, the blue button came back and I was able to add images through the Admin panel.

It's good to know that a quick setting change by the host can fix it. Thanks! :)

Offline shaun31

  • Newbie
  • *
  • Posts: 2
  • Karma: +1/-0
    • View Profile
Re: Admin Backend Site now showing error Forbidden on all media.
« Reply #12 on: August 14, 2014, 01:43:27 PM »
it was driving me loopy - i thought i was going to lose all my hard work when i had nearly finished the site - i just hope it saves other people time

Offline kenshin1985

  • Newbie
  • *
  • Posts: 1
  • Karma: +1/-0
    • View Profile
Re: Admin Backend Site now showing error Forbidden on all media.
« Reply #13 on: November 21, 2014, 01:43:59 PM »
Thanks alot, this posts helped me alot. mod-security was enabled and blocked everything.
contacted helpdesk and they disabled it. works like a miracle!

 

Powered by SMFPacks Social Login Mod