Author Topic: I think there may be a bug for product images  (Read 2353 times)

Offline flyn

  • Full Member
  • ***
  • Posts: 142
  • Karma: +8/-0
    • View Profile
I think there may be a bug for product images
« on: August 18, 2014, 02:43:52 PM »
Hello. I posted this in another section before but I will ask here again. We are on version 1.1.9 of the cart using HTML5 template which I have modified to our needs.

Here is an example: http://www.hygienics.com/mens-underwear/water-resistant-boxer-brief

If you go there click on the thumbnails and as you click on each one you will notice the main-bigimage never stays in place. It keeps moving down and down more.

Why does this occur? I have made the images all the same size 380px x 380px. It is annoying because there is a large gap between the first picture and the thumbnails below.

If that gap did not exist everything would move up more and I could even modify .css file to move up a little closer the tabs/description section.

Please if anyone has an answer let me know.

Thank you


Offline llegrand

  • Hero Member
  • *****
  • Posts: 1470
  • Karma: +382/-2
    • View Profile
Re: I think there may be a bug for product images
« Reply #1 on: August 18, 2014, 05:15:45 PM »
Victor,  I do think it is something you've introduced by your code changes in some way.
Here's a link to one of my sites that has 3 images -  and I don't have the issue you are seeing.

http://countrysnackbucket.com/shop/chcolate-covered-fruits/choc-covered-raisins

and here's one from someone else's site

http://chrinaluc.ca/index.php?rt=product/product&product_id=120

You'll note that even though the pictures are different sizes -  the gap between the pic and the  mouse move stays the same.

Perhaps you can examine the code on the demo for that area and see what you might have changed.

good luck

Lee




Offline flyn

  • Full Member
  • ***
  • Posts: 142
  • Karma: +8/-0
    • View Profile
Re: I think there may be a bug for product images
« Reply #2 on: August 19, 2014, 12:08:56 PM »
Lee thanks as always for the input. I still think this is a bug because when I go here: http://chrinaluc.ca/index.php?rt=product/product&product_id=120

You will notice that every time you click on a thumbnail the large pictures moves up or goes down it does not stay in place when it should. Now the issue with the gap, yes that is fine on yours and theirs. That never changes.

But again you will the larger images do move up or down. I made my images all the same height and width to avoid this.

Offline llegrand

  • Hero Member
  • *****
  • Posts: 1470
  • Karma: +382/-2
    • View Profile
Re: I think there may be a bug for product images
« Reply #3 on: August 19, 2014, 12:28:22 PM »
not to dispute your take -  but it seems to me that it is operating as it should.   If you look at the top of the pic,  it remains in the same placement relationship to the Title.  The bottom moves up or down depending on the size of the pic and it keeps the relationship of the "Move..."  (zoom feature)  the same .

On yours,  the top placement actual moves also ( in addition to your spacing issue) as you go from pic to pic.  That's the area you need to look at for what may have adjusted the coding.

Leastwise that's my take on the issue.

But your site is really coming along -

Lee


Offline flyn

  • Full Member
  • ***
  • Posts: 142
  • Karma: +8/-0
    • View Profile
Re: I think there may be a bug for product images
« Reply #4 on: August 19, 2014, 12:32:50 PM »
You know what you are right. Since the pictures are not the same dimensions I do see why they would "jump" but there is no gap and they do stay aligned to the left side of the title.

I will have to look at the code there and adjust mine accordingly.

Thanks

 

Powered by SMFPacks Social Login Mod