Author Topic: Help configuring taxes....  (Read 3588 times)

Offline cibalibeb

  • Newbie
  • *
  • Posts: 21
  • Karma: +1/-0
    • View Profile
Help configuring taxes....
« on: September 07, 2014, 11:27:38 PM »
my domain is cellplatinum.com I am using Abantecart version 1.1.9 and I am struggling to get the sale tax configured correctly. I need to charge 6.85% sales tax to any orders shipped to Utah

I have attached screenshots of my current tax settings no matter what I do I cannot get taxes to show under guest account or registered user account. If I turn on the option that says display prices with sales tax it shows taxes on the main site but when you go to the cart it drops them from the sub total.

Please help!!  :o :o :o

Offline cibalibeb

  • Newbie
  • *
  • Posts: 21
  • Karma: +1/-0
    • View Profile
Re: Help configuring taxes....
« Reply #1 on: September 07, 2014, 11:28:18 PM »
last few images

Offline Basara

  • Administrator
  • Hero Member
  • *****
  • Posts: 4313
  • Karma: +202/-0
    • View Profile
Re: Help configuring taxes....
« Reply #2 on: September 08, 2014, 06:43:22 AM »
Hello.

Please check that products added to cart have correct Tax Class Enabled
“Chuck Norris is so amazing.”
― Mother Teresa

Offline cibalibeb

  • Newbie
  • *
  • Posts: 21
  • Karma: +1/-0
    • View Profile
Re: Help configuring taxes....
« Reply #3 on: September 08, 2014, 02:46:43 PM »
Yes they are all setup for "taxable goods"

Offline llegrand

  • Hero Member
  • *****
  • Posts: 1472
  • Karma: +383/-2
    • View Profile
Re: Help configuring taxes....
« Reply #4 on: September 08, 2014, 02:55:58 PM »
one more place to check for settings

System > Settings  all the way to the bottom find:

Shipping and Tax Estimate:
Allow customers to get quick shipping and tax estimate in the shopping cart. (HTML5 template)

Is that showing as ON?

Offline cibalibeb

  • Newbie
  • *
  • Posts: 21
  • Karma: +1/-0
    • View Profile
Re: Help configuring taxes....
« Reply #5 on: September 08, 2014, 03:14:31 PM »
I just checked it, and it shows that it's turned on....

Offline llegrand

  • Hero Member
  • *****
  • Posts: 1472
  • Karma: +383/-2
    • View Profile
Re: Help configuring taxes....
« Reply #6 on: September 08, 2014, 03:23:52 PM »
perhaps clearing your system cache will help -  I often find when I've been making changes to the aPanel settings I need to do such to have them show.  Abantecart uses a caching system  that is great for quickening the delivery of pages - good for customers,  but a bit burdensome for admins doing changes :)

See the screen shot for the steps (ignore #5)




Offline cibalibeb

  • Newbie
  • *
  • Posts: 21
  • Karma: +1/-0
    • View Profile
Re: Help configuring taxes....
« Reply #7 on: September 09, 2014, 11:51:46 AM »
I tried clearing the cache and the issue seems to persist, would someone be willing to check it from their machine? It should only be charging sales tax on orders sent to Utah....

Offline Basara

  • Administrator
  • Hero Member
  • *****
  • Posts: 4313
  • Karma: +202/-0
    • View Profile
Re: Help configuring taxes....
« Reply #8 on: September 10, 2014, 02:23:49 AM »
I tried clearing the cache and the issue seems to persist, would someone be willing to check it from their machine? It should only be charging sales tax on orders sent to Utah....
Hello.

See attached screenshot with Utah test tax applied correctly.
Make sure you clear AbanteCart cache and try to use new Shipping session (test in another browser this will force AbanteCart to create new customer session)

“Chuck Norris is so amazing.”
― Mother Teresa

Offline cibalibeb

  • Newbie
  • *
  • Posts: 21
  • Karma: +1/-0
    • View Profile
Re: Help configuring taxes....
« Reply #9 on: September 11, 2014, 07:55:35 PM »
just checked, my settings match exactly. I tried a new shipping session on a different computer its still not calculating taxes.... I know I'm probably missing something simple, if someone is open to doing a screenshare or something to take a look that would be great!

Offline Basara

  • Administrator
  • Hero Member
  • *****
  • Posts: 4313
  • Karma: +202/-0
    • View Profile
Re: Help configuring taxes....
« Reply #10 on: September 12, 2014, 03:35:59 AM »
just checked, my settings match exactly. I tried a new shipping session on a different computer its still not calculating taxes.... I know I'm probably missing something simple, if someone is open to doing a screenshare or something to take a look that would be great!

Did you try to clear AbanteCart cache?
“Chuck Norris is so amazing.”
― Mother Teresa

Offline cibalibeb

  • Newbie
  • *
  • Posts: 21
  • Karma: +1/-0
    • View Profile
Re: Help configuring taxes....
« Reply #11 on: September 13, 2014, 02:35:35 PM »
Just cleared all of the cache and tried again, its still not working  :'(

Offline cibalibeb

  • Newbie
  • *
  • Posts: 21
  • Karma: +1/-0
    • View Profile
Re: Help configuring taxes....
« Reply #12 on: September 13, 2014, 11:33:30 PM »
I've been playing around with this for a few hours and have found something else that is odd, I have my shipping set to be taxable When you choose Utah it is charging taxes on the shipping but is not charging taxes on the products, I have checked and re-checked, I have even tried adding new products and selecting "Taxable Goods" in the Tax Class but still cannot get it to charge taxes on the actual item...

Offline Basara

  • Administrator
  • Hero Member
  • *****
  • Posts: 4313
  • Karma: +202/-0
    • View Profile
Re: Help configuring taxes....
« Reply #13 on: September 16, 2014, 02:08:04 AM »
t still cannot get it to charge taxes on the actual item...

Hi.  :)

You need to enable Order Total: Taxes in Admin-Extensions-Order Totals

Note: it is Enabled by default so look like you set it off manually.
“Chuck Norris is so amazing.”
― Mother Teresa

Offline cibalibeb

  • Newbie
  • *
  • Posts: 21
  • Karma: +1/-0
    • View Profile
Re: Help configuring taxes....
« Reply #14 on: September 16, 2014, 02:18:51 AM »
Basara,

Thank you so much!!

 

Powered by SMFPacks Social Login Mod