Please help us to make AbanteCart Ideal Open Source Ecommerce Solution for everyone.

Support AbanteCart eCommerce

Author Topic: My whole site is gone? 1.2 Upgrade DB connection issues.  (Read 2968 times)

Offline thedarksyde

  • Full Member
  • ***
  • Posts: 131
  • Karma: +7/-1
    • View Profile
My whole site is gone? 1.2 Upgrade DB connection issues.
« on: December 28, 2014, 01:23:50 PM »
Are you kidding me?  Upgrading destroys your site?   Everything is gone?   How do I get it back, I don't even know how to get to my dashboard anymore. 
« Last Edit: December 29, 2014, 10:22:25 AM by thedarksyde »

Offline thedarksyde

  • Full Member
  • ***
  • Posts: 131
  • Karma: +7/-1
    • View Profile
Re: My whole site is gone?
« Reply #1 on: December 28, 2014, 01:32:42 PM »
Well I found the dashboard, but everything is gone, my categories, products, sales, customers, lists, everything is gone.  How do I get it back. 

Offline thedarksyde

  • Full Member
  • ***
  • Posts: 131
  • Karma: +7/-1
    • View Profile
Re: My whole site is gone?
« Reply #2 on: December 28, 2014, 01:57:00 PM »
Attempt to import mysql db.



2014-12-28 12:43:07 - database error: AbanteCart core v.1.2.0 Error: Duplicate entry '1' for key 'PRIMARY'
Error No: 1062
--
-- Dumping data for table `abc_addresses`
--
INSERT INTO `abc_addresses` (`address_id`, `customer_id`, `company`, `firstname`, `lastname`, `address_1`, `address_2`, `postcode`, `city`, `country_id`, `zone_id`) VALUES
(1, 2, '', 'Juliana', 'Davis', '9778 Golden Crescent', 'Apt 10', '85804-7365', 'Humansville', 223, 3616),
(2, 3, '', 'Keely', 'Mccoy', '5071 Misty Pond Farm', 'Suite #101', '63406-9081', 'Bumble Bee', 223, 3648),
(3, 4, 'BelfastCo', 'Zelda', 'Weiss', '6944 Sleepy Fawn Abbey', 'Suite #31', '86014-8121', 'Lawyers', 223, 3616),
(4, 5, '', 'Gloria', 'Macias', '7590 Easy Robin Hollow', '', '73477-3842', 'Sandymush', 223, 3660),
(5, 6, '', 'Bernard', 'Horne', '5607 Umber Branch Via', '', '86301-9785', 'Spook City', 223, 3616),
(6, 7, '', 'James', 'Curtis', '6500 Arapahoe Road', '', '80303', 'Boulder', 223, 3634),
(7, 8, '', 'Bruce', 'Rosarini', '61 Cumberland ST', '', '68624-2273', 'Skokie', 223, 3650),
(8, 9, '', 'Carlos', 'Compton', '31 Capital Drive', '', '63142-0892', 'Fort Misery', 223, 3648),
(9, 10, '', 'Garrison', 'Baxter', 'Eddie Hoffman Highway', '', '64034-2948', 'Shell Pile', 223, 3648),
(10, 11, '', 'Anthony', 'Blair', '104 Main Street', '', '29181-8284', 'Gassaway', 223, 3666),
(11, 12, '', 'Allen', 'Waters', '110 Shenandoah Avenue', '', '86565-1710', 'Honohina', 223, 3616),
(12, 13, '', 'Tom', 'Kipling', '100 Main Str', '', '64034-2948', 'Shell Pile', 223, 3648) in <b>/home1/darksyde/public_html/core/database/mysql.php</b> on line <b>114</b>
« Last Edit: December 28, 2014, 02:50:12 PM by thedarksyde »

Offline thedarksyde

  • Full Member
  • ***
  • Posts: 131
  • Karma: +7/-1
    • View Profile
Re: My whole site is gone?
« Reply #3 on: December 28, 2014, 02:08:13 PM »
I think I need to remove abc_ from the database directory root.  How can I do that, do I have to uninstall 1.2 and reinstall or write over it?

Offline thedarksyde

  • Full Member
  • ***
  • Posts: 131
  • Karma: +7/-1
    • View Profile
Re: My whole site is gone?
« Reply #4 on: December 28, 2014, 02:28:33 PM »
I tried restarting installation and I did not put a prefix for my database tables and I still have no data.  Still getting the same error on restore attempts.

2014-12-28 13:26:53 - database error: AbanteCart core v.1.2.0 Error: Duplicate entry '1' for key 'PRIMARY'
Error No: 1062
--
-- Dumping data for table `abc_addresses`
--
INSERT INTO `abc_addresses` (`address_id`, `customer_id`, `company`, `firstname`, `lastname`, `address_1`, `address_2`, `postcode`, `city`, `country_id`, `zone_id`) VALUES
(1, 2, '', 'Juliana', 'Davis', '9778 Golden Crescent', 'Apt 10', '85804-7365', 'Humansville', 223, 3616),
(2, 3, '', 'Keely', 'Mccoy', '5071 Misty Pond Farm', 'Suite #101', '63406-9081', 'Bumble Bee', 223, 3648),
(3, 4, 'BelfastCo', 'Zelda', 'Weiss', '6944 Sleepy Fawn Abbey', 'Suite #31', '86014-8121', 'Lawyers', 223, 3616),
(4, 5, '', 'Gloria', 'Macias', '7590 Easy Robin Hollow', '', '73477-3842', 'Sandymush', 223, 3660),
(5, 6, '', 'Bernard', 'Horne', '5607 Umber Branch Via', '', '86301-9785', 'Spook City', 223, 3616),
(6, 7, '', 'James', 'Curtis', '6500 Arapahoe Road', '', '80303', 'Boulder', 223, 3634),
(7, 8, '', 'Bruce', 'Rosarini', '61 Cumberland ST', '', '68624-2273', 'Skokie', 223, 3650),
(8, 9, '', 'Carlos', 'Compton', '31 Capital Drive', '', '63142-0892', 'Fort Misery', 223, 3648),
(9, 10, '', 'Garrison', 'Baxter', 'Eddie Hoffman Highway', '', '64034-2948', 'Shell Pile', 223, 3648),
(10, 11, '', 'Anthony', 'Blair', '104 Main Street', '', '29181-8284', 'Gassaway', 223, 3666),
(11, 12, '', 'Allen', 'Waters', '110 Shenandoah Avenue', '', '86565-1710', 'Honohina', 223, 3616),
(12, 13, '', 'Tom', 'Kipling', '100 Main Str', '', '64034-2948', 'Shell Pile', 223, 3648) in <b>/home1/darksyde/public_html/core/database/mysql.php</b> on line <b>114</b>

Offline thedarksyde

  • Full Member
  • ***
  • Posts: 131
  • Karma: +7/-1
    • View Profile
Re: My whole site is gone?
« Reply #5 on: December 28, 2014, 02:42:58 PM »
I need to tell abantecart to use my old data that is still there in the database, how do I tell it where it is.  I did it in the install, but it isn't working.  Is there a place to edit this, or where I can look at it and compare it to what I have in my cpanel on my host?

Offline thedarksyde

  • Full Member
  • ***
  • Posts: 131
  • Karma: +7/-1
    • View Profile
Re: My whole site is gone? 1.2 Upgrade DB connection issues.
« Reply #6 on: December 28, 2014, 11:47:51 PM »
I found the php config file but it all looks right.  Something isn't allowing the data in the sql to be used by abantecart.  This is where I need help.  I don't know what would be missing or needs to be set for it to be used correctly.  Where do I edit this? 
« Last Edit: December 28, 2014, 11:58:49 PM by thedarksyde »

yonghan

  • Guest
Re: My whole site is gone? 1.2 Upgrade DB connection issues.
« Reply #7 on: December 29, 2014, 03:59:55 AM »
Hello,you have a duplicate id in the addresses table based on the error message.Please login into your cpanel,open up phpmyadmin and check if there are existing data within the addresses table.

Hope it helps

Offline thedarksyde

  • Full Member
  • ***
  • Posts: 131
  • Karma: +7/-1
    • View Profile
Re: My whole site is gone? 1.2 Upgrade DB connection issues.
« Reply #8 on: December 29, 2014, 08:07:32 AM »
Right, the data is there, but abantecart is not using it.   I don't think the restore is what I need, because the data exists.  I need abantecart to use that data.  It is connected to the db because there are no errors during install and with a restore it is finding the duplicate data. So I need to fix whatever is making it not be used.

Offline thedarksyde

  • Full Member
  • ***
  • Posts: 131
  • Karma: +7/-1
    • View Profile
Re: My whole site is gone? 1.2 Upgrade DB connection issues.
« Reply #9 on: December 29, 2014, 08:35:08 AM »
No upon further inspection of the data only the first row, addresses is there, everything else is empty, or with base code.  Abantecart 1.2 overwrote my whole database.  And emptied the tables.  Now the decision to close the store forever or rebuild.  Thanks a lot. 

Offline llegrand

  • Hero Member
  • *****
  • Posts: 1417
  • Karma: +365/-2
    • View Profile
Re: My whole site is gone? 1.2 Upgrade DB connection issues.
« Reply #10 on: December 29, 2014, 09:20:02 AM »
How did you update?   using the system upgrade?  if so it is configured to make a backup- read here for more information.
http://www.abantecart.com/ecommerce-documentation/user-manual/installation/core-upgrade

If you upgraded manually and  you didn't make a backup BEFORE upgrading - that is always a necessity for any major change.  That was a very dumb move,  and one you won't make every again :)

If you originally installed used Softcaulous -  did you set the automatic backup within Softaculous?

Does your host have some type of backup for you,  i.e. A2Hosting  has a server rewind for accounts. 



Offline lukaszsz

  • Newbie
  • *
  • Posts: 23
  • Karma: +0/-1
    • View Profile
Re: My whole site is gone? 1.2 Upgrade DB connection issues.
« Reply #11 on: January 18, 2015, 08:02:42 PM »
fu,,,   i have thesame problem ....  after instalation evrything gone and looks difrent nothing works!!  i didint backup before instalation ! :(   nodady from AbanteCart help !!

 

Powered by SMFPacks Social Login Mod