Author Topic: Upgrade from 1.1.9 to 1.2.0 Error: Can't create sql dump of database during back  (Read 4806 times)

Offline dls2004

  • Newbie
  • *
  • Posts: 15
  • Karma: +7/-1
    • View Profile
Hi,

I have tried with several abantecart sites to run the upgrade package to upgrade v1.1.9 to v1.2.0

All of them fail with error as below:

Error: Can't create sql dump of database during backup

I tried the manual processes and downloaded the upgrade only package, extracted it. Copied the contents of the directory 'code' to my abantcart directory and then tried to use upgrade.sql in phpMyAdmin (Version information: 4.0.10.7, latest stable version: 4.3.7)
I should note this script has so many errors in it its almost unusable as it assume a schema table prefix is 'ac_' and the TIMESTAMP commands don't work with all version of phpMyAdmin . And has to be worked through line by line to get it work, checking the table columns and index first before running each block of sql code.

Even after doing this, Still the upgrade failed and the store page and admin pages both showed critical errors.

So I rolled back to V1.1.9 store and database from a softaculous backup.

Ok, so here's how I did manage to get the upgrade to succeed....MAKE A FULL SOFTACULOUS BACKUP FIRST OF LIVE SITE!

Using the provided backup.php file as provided in this thread ?http://forum.abantecart.com/index.php/topic,1676.15.html?

I renamed the existing backup.php in  /public_html/store/core/lib on your live site to backup.php.old

I then copied the downloaded backup.php file to /public_html/store/core/lib on live site

Then ran the upgrade using the message link or by typing 'abantecart_upgrade_120" into the 'Network Install tab' 'Installation Key' form textbox.

The package downloaded and installed correctly. Will do bit more testing but the store and backend appear to be working correctly.

So hope this work around helps anyone with similar upgrade issues as I had.




« Last Edit: January 22, 2015, 11:05:43 PM by dls2004 »

Offline artist3412

  • Full Member
  • ***
  • Posts: 117
  • Karma: +16/-0
    • View Profile
    • In The Wind Creations
I have had the critical error on both admin and live site for weeks now. I tried to do a manual upgrade to 1.2 and ran sql upgrade after replacing prefix as suggested. Still nothing. I would like to try this solution, however I am unsure what you mean by this line:

Then ran the upgrade using the message link or by typing 'abantecart_upgrade_120" into the 'Network Install tab' 'Installation Key' form textbox.

I am unable to get into my admin. Is this located somewhere else?
To send light into the darkness of men's hearts - such is the duty of the artist.  ~Schumann

Offline zoltan

  • Newbie
  • *
  • Posts: 20
  • Karma: +1/-0
  • MAKE SOMETHING AWESOME EVERYDAY.
    • View Profile
    • Business Cards | Full color printing | Custom Design
I'm just trying this right now.
Correct me if I'm wrong but I think what he meant is:

Step 1: Restore your cart to 1.1.9 version
Step 2: Download the backup.php from http://forum.abantecart.com/index.php/topic,1676.15.html
Step 3: Log-in to your Cpanel, locate the folder: /public_html/store/core/lib
Step 4: Rename the backup.php in that folder to backup.php.OLD
Step 5: Upload the backup.php file that you downloaded in Step 2:
Step 6: Now with the restored 1.1.9 log-in to your AbanteCart-cart admin panel
Step 7: Go to messages run the upgrade to 1.2

And it didn't work for me!!! so not really sure if this is what he meant but that's what I did.
Next I'll upload my error file here

Offline zoltan

  • Newbie
  • *
  • Posts: 20
  • Karma: +1/-0
  • MAKE SOMETHING AWESOME EVERYDAY.
    • View Profile
    • Business Cards | Full color printing | Custom Design
The error log:
2015-03-06 5:58:43 - warning:  AbanteCart core v.1.1.9 preg_grep(): Compilation failed: nothing to repeat at offset 0 in <b>/home/time2043/chrinalucCA/core/engine/language.php</b> on line <b>254</b>
2015-03-06 12:23:21 - database error:  AbanteCart core v.1.1.9 Error: Can't DROP 'ac_languages_index'; check that column/key exists<br />Error No: 1091<br />
ALTER TABLE `ab_languages`
  DROP INDEX ac_languages_index,
  ADD UNIQUE INDEX ac_languages_idx (language_id,code);
 in <b>/home/time2043/chrinalucCA/store/core/database/mysql.php</b> on line <b>114</b>
2015-03-06 12:23:35 - database error:  AbanteCart core v.1.2.0 Error: Unknown column 'date_modified' in 'order clause'<br />Error No: 1054<br />SELECT * FROM ab_messages ORDER BY status DESC, date_modified DESC, msg_id DESC LIMIT 0, 10 in <b>/home/time2043/chrinalucCA/store/core/database/mysql.php</b> on line <b>114</b>

Offline zoltan

  • Newbie
  • *
  • Posts: 20
  • Karma: +1/-0
  • MAKE SOMETHING AWESOME EVERYDAY.
    • View Profile
    • Business Cards | Full color printing | Custom Design
Another error message from the admin panel at this time it didn't go to the critical page and just gave me an error message on the admin page:
Home::Package Installer
Error: Can't create sql dump of database during backup

Offline Basara

  • Administrator
  • Hero Member
  • *****
  • Posts: 4407
  • Karma: +205/-0
    • View Profile
I'm just trying this right now.
Correct me if I'm wrong but I think what he meant is:

Step 1: Restore your cart to 1.1.9 version
Step 2: Download the backup.php from http://forum.abantecart.com/index.php/topic,1676.15.html
Step 3: Log-in to your Cpanel, locate the folder: /public_html/store/core/lib
Step 4: Rename the backup.php in that folder to backup.php.OLD
Step 5: Upload the backup.php file that you downloaded in Step 2:
Step 6: Now with the restored 1.1.9 log-in to your AbanteCart-cart admin panel
Step 7: Go to messages run the upgrade to 1.2

And it didn't work for me!! so not really sure if this is what he meant but that's what I did.
Next I'll upload my error file here

Backup your database and files then try to upgrade manually http://docs.abantecart.com/pages/settings/details.html
« Last Edit: November 01, 2016, 08:25:57 AM by Basara »
“Chuck Norris is so amazing.”
― Mother Teresa

Offline zoltan

  • Newbie
  • *
  • Posts: 20
  • Karma: +1/-0
  • MAKE SOMETHING AWESOME EVERYDAY.
    • View Profile
    • Business Cards | Full color printing | Custom Design
I'm sure Presta isn't perfect either and about the virus you could of get it from a million other places. Either way I liked AbanteCart cart so far it's in part that I'm having difficulties because didn't back up the work I did, but lessons learned. So far they been very helpful.

Offline zoltan

  • Newbie
  • *
  • Posts: 20
  • Karma: +1/-0
  • MAKE SOMETHING AWESOME EVERYDAY.
    • View Profile
    • Business Cards | Full color printing | Custom Design
But issue with a file, I have downloaded the abantecart_1.2.0_upgrade_only.tar.gz file from the link you sent also directly and from the mirror as well but all the time I get the same message from winrar and when I uploaded the file online I got the error message as well, please see attached pictures.

Offline Basara

  • Administrator
  • Hero Member
  • *****
  • Posts: 4407
  • Karma: +205/-0
    • View Profile
But issue with a file, I have downloaded the abantecart_1.2.0_upgrade_only.tar.gz file from the link you sent also directly and from the mirror as well but all the time I get the same message from winrar and when I uploaded the file online I got the error message as well, please see attached pictures.

Try 7zip it free
“Chuck Norris is so amazing.”
― Mother Teresa

Offline scorpbond

  • Newbie
  • *
  • Posts: 32
  • Karma: +2/-1
  • BlackPantherInternational
    • View Profile
    • Black Panther International Shopping Portal
Unable to update my cart from 1.2.0 to 1.2.1 error showing  Error: Can't find config-file package.xml inside package. Probably package is broken. Structure of package error.

Please provide me that config file package.xml and let me know location directory where to upload or past.

I tried installing by uploading core upgrade package.

Please help.
Regards.
Abhinav Mishra
For: BlackPantherInternational

 

Powered by SMFPacks Social Login Mod