Author Topic: Glitch in Shipping Module for Canadian addresses?  (Read 491 times)

Offline jsom

  • Newbie
  • *
  • Posts: 4
  • Karma: +1/-0
    • View Profile
Glitch in Shipping Module for Canadian addresses?
« on: May 06, 2017, 11:36:13 PM »
Hi -

I think I have found a glitch in the Shipping Module. When we have a Canadian customer make a purchase (we are in Florida), the last option in the International Shipping options always shows as "(Estimate Time: ) - $0.00", regardless of which options are selected or how many are available. I.e., if I have 4 options selected in the extension, the first 3 will show valid options and the 4th will be $0.00; if there are 3 options, the first 2 will be valid and the 3rd will be $0.00 and so on.

I notice this only happens for Canadian addresses, regardless of province. I haven't checked EVERY country; but the random countries I checked didn't show this.

I have attached a screen shot of the error.

Given the option of free shipping, who wouldn't select it? I know Canadians have a reputation for being nice and all, but I'm checking the free shipping option if I can ... LOL...

I've tried different combinations of International shipping options - no change
I've uninstalled and reinstalled the module - no change
I've upgraded to AC 1.2.10 - no change

Anyone else have this problem?
Is there a fix/work around?

TIA

Scott

Offline Basara

  • Administrator
  • Hero Member
  • *****
  • Posts: 3160
  • Karma: +149/-0
    • View Profile
Re: Glitch in Shipping Module for Canadian addresses?
« Reply #1 on: May 08, 2017, 12:40:23 AM »
Hello.

What "Shipping Module" you have installed?
“Chuck Norris is so amazing.”
― Mother Teresa

Offline jsom

  • Newbie
  • *
  • Posts: 4
  • Karma: +1/-0
    • View Profile
Re: Glitch in Shipping Module for Canadian addresses?
« Reply #2 on: May 08, 2017, 12:26:03 PM »
I have the default USPS shipping module

Offline Basara

  • Administrator
  • Hero Member
  • *****
  • Posts: 3160
  • Karma: +149/-0
    • View Profile
Re: Glitch in Shipping Module for Canadian addresses?
« Reply #3 on: May 09, 2017, 02:31:09 AM »
Hello.
First update usps files to latest one https://github.com/abantecart/abantecart-src/tree/1.2.11/public_html/extensions/default_usps
Then make sure you have services enabled in USPS setting allowing to ship to Canada

If it is still not work provide origin zipcode and Canadian Zip code you use
“Chuck Norris is so amazing.”
― Mother Teresa

Offline jsom

  • Newbie
  • *
  • Posts: 4
  • Karma: +1/-0
    • View Profile
Re: Glitch in Shipping Module for Canadian addresses?
« Reply #4 on: July 07, 2017, 11:07:02 AM »
Thanks for the advice... unfortunately, those solutions did not solve the problem.

I did fix the problem by purchasing the USPS_Integration module from the AbanteCart Store. I don't know what in that module fixed the problem, but it seems to me that this should also work in the free version of the USPS module.

 

Cheap Prom dresses 2018