Author Topic: Problem with SMTP server  (Read 4189 times)

Offline bigkrum

  • Newbie
  • *
  • Posts: 8
  • Karma: +1/-0
    • View Profile
Problem with SMTP server
« on: April 22, 2015, 06:38:39 AM »
Hello, dear support. Recently I have ordered hosting over Hosting24. Inside the panel there was an option of installing AbanteCart. I like how the things look so far but there seems to be a problem. Even when the SMTP details are entered correctly  there seems to be a problem and the script can't send e-mails. I have contacted my hosting support and this is the reply i got.

Quote
We have investigated the issue with our System Department and it seems that the issue is with your script. Even though we have edited all the details inside your AbanteCart admin area to match our server configuration, these are the errors that appeared inside Mail Server logs when using port 587:

2015-04-22 05:13:20 H=(v****.n*t) [*****]:54619 F= rejected RCPT : SMTP AUTH is required for message submission on port 587
2015-04-22 05:13:20 SMTP connection from (v****.n*t) [*****]:54619 closed by DROP in ACL

And these errors appeared when using port 25:

2015-04-22 05:16:06 H=(v****.n*t) [*****]:39165 F= rejected RCPT : Please turn on SMTP Authentication in your mail client. (v****.n*t) [*****]:39165 is not permitted to relay through this server without authentication.
2015-04-22 05:16:06 H=(v****.n*t) [*****]:39167 F= rejected RCPT : Please turn on SMTP Authentication in your mail client. (v****.n*t) [*****]:39167 is not permitted to relay through this server without authentication.
2015-04-22 05:16:06 SMTP call from (v****.n*t) [*****]:39167 dropped: too many syntax or protocol errors (last command was "To: b*****m@abv")
2015-04-22 05:16:06 SMTP call from (v****.n*t) [*****]:39165 dropped: too many syntax or protocol errors (last command was "To: b*****m@abv")

For some reason your script is using wrong email accounts even though they are not listed inside your Admin Area. This might be simply cached data, but you should consult regarding this with the software developers in any case.

Please contact us if you have further questions, comments or concerns.

Offline Basara

  • Administrator
  • Hero Member
  • *****
  • Posts: 4609
  • Karma: +225/-1
    • View Profile
Re: Problem with SMTP server
« Reply #1 on: April 22, 2015, 09:27:42 AM »
Hello.

Did you try different mail accounts? For example Gmail see example of gmail SMTP settings http://docs.abantecart.com/pages/settings/mail.html

Regarding this please clear AbanteCart cache
Quote
We have investigated the issue with our System Department and it seems that the issue is with your script. Even
For some reason your script is using wrong email accounts even though they are not listed inside your Admin Area. This might be simply cached data, but you should consult regarding this with the software developers in any case.
« Last Edit: November 01, 2016, 08:30:17 AM by Basara »
“Chuck Norris is so amazing.”
― Mother Teresa

Offline bigkrum

  • Newbie
  • *
  • Posts: 8
  • Karma: +1/-0
    • View Profile
Re: Problem with SMTP server
« Reply #2 on: April 22, 2015, 09:43:37 AM »
Hello.

Did you try different mail accounts? For example Gmail see example of gmail SMTP settings

Regarding this please clear AbanteCart cache
Quote
We have investigated the issue with our System Department and it seems that the issue is with your script. Even
For some reason your script is using wrong email accounts even though they are not listed inside your Admin Area. This might be simply cached data, but you should consult regarding this with the software developers in any case.

Yes i tried using Gmail account getting the same error: "Can't send emails. Please see log for details and check your mail settings." Also tried already to clean all the cached data and still no luck :( .

Offline abolabo

  • core-developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 1829
  • Karma: +269/-11
  • web for all, all for web!
    • View Profile
    • AbanteCart
Re: Problem with SMTP server
« Reply #3 on: April 22, 2015, 10:11:50 AM »
Looks like your host have some issues with ssl.
Abantecart use socket connection for sending emails (function fsockopen) and it works correctly.

Why do you use 587 port (TLS)? Did you tried 465 (SSL)?

“No one is useless in this world who lightens the burdens of another.”
― Charles Dickens

Offline bigkrum

  • Newbie
  • *
  • Posts: 8
  • Karma: +1/-0
    • View Profile
Re: Problem with SMTP server
« Reply #4 on: April 22, 2015, 10:29:58 AM »


My settings and still don't work :( .

Offline abolabo

  • core-developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 1829
  • Karma: +269/-11
  • web for all, all for web!
    • View Profile
    • AbanteCart
Re: Problem with SMTP server
« Reply #5 on: April 22, 2015, 10:48:18 AM »
i don't know how to help you. You need to check is that port available for your host.
The best way to do this run command in terminal
Code: [Select]
telnet smtp.gmail.com 465If host can connect you will see some messages like this
Code: [Select]
telnet smtp.gmail.com 465
Trying 173.194.71.109...
Connected to gmail-smtp-msa.l.google.com.
Escape character is '^]'.
In that case cause is in ssl-settings of your host.
Anyway ask hosting provider support about it.

You are first who asking us about these incredible errors.

“No one is useless in this world who lightens the burdens of another.”
― Charles Dickens

Offline bigkrum

  • Newbie
  • *
  • Posts: 8
  • Karma: +1/-0
    • View Profile
Re: Problem with SMTP server
« Reply #6 on: April 22, 2015, 01:37:20 PM »
I wanna say BIG THANK YOU. I contacted my hosting company again and this time they were able to fix the problem.

Offline maury1971

  • Newbie
  • *
  • Posts: 16
  • Karma: +1/-0
    • View Profile
Re: Problem with SMTP server
« Reply #7 on: September 27, 2015, 10:32:21 AM »
i do not manage to get it to work  as well
this is what i get from my hosting  for the settings i putted


Connection closed by foreign host.
root@datacenter [/home/pharmex/public_html/core/lib]# telnet 136.243.71.10 587
Trying 136.243.71.10...
Connected to 136.243.71.10.
Escape character is '^]'.
220-datacenter.oxiahosting.com ESMTP Exim 4.85 #2 Sun, 27 Sep 2015 16:21:44 +0200
220-We do not authorize the use of this system to transport unsolicited,
220 and/or bulk e-mail.

Offline abolabo

  • core-developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 1829
  • Karma: +269/-11
  • web for all, all for web!
    • View Profile
    • AbanteCart
Re: Problem with SMTP server
« Reply #8 on: September 28, 2015, 08:01:05 AM »
i do not manage to get it to work  as well
this is what i get from my hosting  for the settings i putted


Connection closed by foreign host.
root@datacenter [/home/pharmex/public_html/core/lib]# telnet 136.243.71.10 587
Trying 136.243.71.10...
Connected to 136.243.71.10.
Escape character is '^]'.
220-datacenter.oxiahosting.com ESMTP Exim 4.85 #2 Sun, 27 Sep 2015 16:21:44 +0200
220-We do not authorize the use of this system to transport unsolicited,
220 and/or bulk e-mail.
why 587?
587 is secure port for ingoing mail. 465 for outgoing.
“No one is useless in this world who lightens the burdens of another.”
― Charles Dickens

 

Powered by SMFPacks Social Login Mod