Author Topic: Categories & Content Pages not adding correctly (Resolved)  (Read 2908 times)

Offline RobinA

  • Newbie
  • *
  • Posts: 21
  • Karma: +6/-0
    • View Profile
Categories & Content Pages not adding correctly (Resolved)
« on: April 28, 2015, 12:04:41 PM »
Hello All,
I recently started using AbanteCart which looks really good.  Thanks for an excellent application.

The cart (Ver. 1.2.1) was automatically installed by the hosting company (Arvixe) and I've been having some issues from minute one.  They gave me the wrong Admin username.  I finally figured that one out.

Now after installing a new template and everything is taking shape, I found that I can edit the content pages but after saving them, they cannot be found from the front-end site menu.  The same thing for categories. I can edit a category but adding a category or a sub-category, there is a problem.  They show up fine in the front-end menu but generates an error when clicked.
When I mouse-over the menu item, i noticed the system is looking for the site URL/name.  (name is the name of the category or sub-category or content page.) 
I would really hate to start over.  Please HELP.

Robin
« Last Edit: April 28, 2015, 10:57:09 PM by RobinA »

Offline Gordon Taylor

  • Global Moderator
  • Full Member
  • *****
  • Posts: 149
  • Karma: +27/-0
    • View Profile
    • Natural Handcrafted Soaps
Re: Categories & Content Pages not adding correctly
« Reply #1 on: April 28, 2015, 01:17:40 PM »
Can  you please check your error log in the Admin Panel and post any messages that are there for the technicians to look at?
It would help a lot.

Offline llegrand

  • Hero Member
  • *****
  • Posts: 1489
  • Karma: +389/-2
    • View Profile
Re: Categories & Content Pages not adding correctly
« Reply #2 on: April 28, 2015, 01:22:11 PM »
Robin,  I saw you indicated you had installed a new template -  please check that the template you installed is capable of running on version 1.2.1

It should tell you on the template description page

Lee

Offline Gordon Taylor

  • Global Moderator
  • Full Member
  • *****
  • Posts: 149
  • Karma: +27/-0
    • View Profile
    • Natural Handcrafted Soaps
Re: Categories & Content Pages not adding correctly
« Reply #3 on: April 28, 2015, 01:47:13 PM »
Good point Lee, many templates out there are NOT compatible with the latest upgrade.

Offline RobinA

  • Newbie
  • *
  • Posts: 21
  • Karma: +6/-0
    • View Profile
Re: Categories & Content Pages not adding correctly
« Reply #4 on: April 28, 2015, 03:26:53 PM »
Gordon / Lee,
Thanks for your prompt response.
I did install the Foxy template which said it was compatible with the current version.
Hare are the last few lines of the error log.

2015-04-28 14:51:04 - App Error: AbanteCart core v.1.2.1 Error: cannot to pack /home/mydir/public_html/admin/system/backup/cat-export_04282015_144950.tar.gz in /home/mydir/public_html/core/lib/data.php on line 1455

2015-04-28 14:51:04 - warning: AbanteCart core v.1.2.1 file_get_contents(/home/mydir/public_html/admin/system/backup/cat-export_04282015_144950.tar.gz) [<a href='function.file-get-contents'>function.file-get-contents</a>]: failed to open stream: No such file or directory in <b>/home/mydir/public_html/core/lib/data.php</b> on line <b>265</b>

2015-04-28 14:53:54 - warning: AbanteCart core v.1.2.1 file_get_contents() [<a href='function.file-get-contents'>function.file-get-contents</a>]: Filename cannot be empty in <b>/home/mydir/public_html/core/lib/targz.php</b> on line <b>171</b>

2015-04-28 14:53:54 - App Error: AbanteCart core v.1.2.1 Error: cannot to pack /home/mydir/public_html/admin/system/backup/export_28042015_145304.tar.gz in /home/mydir/public_html/core/lib/data.php on line 1455

2015-04-28 14:53:54 - warning: AbanteCart core v.1.2.1 file_get_contents(/home/mydir/public_html/admin/system/backup/export_28042015_145304.tar.gz) [<a href='function.file-get-contents'>function.file-get-contents</a>]: failed to open stream: No such file or directory in <b>/home/mydir/public_html/core/lib/data.php</b> on line <b>265</b>

2015-04-28 15:02:46 - warning: AbanteCart core v.1.2.1 Invalid argument supplied for foreach() in <b>/home/mydir/public_html/admin/controller/pages/tool/updater.php</b> on line <b>76</b>

Thanks,
Robin

Offline llegrand

  • Hero Member
  • *****
  • Posts: 1489
  • Karma: +389/-2
    • View Profile
Re: Categories & Content Pages not adding correctly
« Reply #5 on: April 28, 2015, 04:27:35 PM »
thanks for checking all that out.

My recommendation is to post a comment on the extension page -  I believe natani is quite responsive.   And the extensions in the marketplace are "fixed" by the extension writer - they are all third party folks and ultimately responsible for the working of their extensions.

let us know what happens,  I was thinking of giving that extension a try myself -  so will follow your posts to see how it all works out. :)

Lee

Offline RobinA

  • Newbie
  • *
  • Posts: 21
  • Karma: +6/-0
    • View Profile
Re: Categories & Content Pages not adding correctly
« Reply #6 on: April 28, 2015, 05:23:53 PM »
Thanks Lee,
I will follow your suggestion.
Have a great day.

RA.

Offline RobinA

  • Newbie
  • *
  • Posts: 21
  • Karma: +6/-0
    • View Profile
Re: Categories & Content Pages not adding correctly (Resolved)
« Reply #7 on: April 28, 2015, 11:00:10 PM »
Hello All,
The issue has been resolved.  It was my error.  The developer suggested I turn off SEO URLs and that fixed the problem.  Everything works great now.
I love this project.

Thanks you all for your help.

Robin

Offline Gordon Taylor

  • Global Moderator
  • Full Member
  • *****
  • Posts: 149
  • Karma: +27/-0
    • View Profile
    • Natural Handcrafted Soaps
Re: Categories & Content Pages not adding correctly (Resolved)
« Reply #8 on: April 29, 2015, 07:14:58 AM »
Good going Robin, thanks for the update! Glad you got it working.

Offline Basara

  • Administrator
  • Hero Member
  • *****
  • Posts: 4394
  • Karma: +205/-0
    • View Profile
Re: Categories & Content Pages not adding correctly (Resolved)
« Reply #9 on: April 29, 2015, 09:59:52 AM »
When you enable SEO url follow instruction
http://docs.abantecart.com/pages/tips/enable_seo.html
Code: [Select]
To use SEO URL's Apache module mod-rewrite must be installed and you need to rename the htaccess.txt file to .htaccess
Search Engine Friendly URLs allows you to activate categories and product's SEO Keyword setting. For each product and category you can assign seo keyword visible in url. This will better describe a product's page to visitors and search engines.

mod_rewrite is something that is installed on your server by your web host. You need to ask your host (or look in their help guide) to find out if you have it.

Note: If you access store with sub-folder like http://www.mydomain/subfolder make sure to change RewriteBase/ to RewriteBase/subfolder/ in the .htaccess file.
« Last Edit: November 01, 2016, 08:19:45 AM by Basara »
“Chuck Norris is so amazing.”
― Mother Teresa

 

Powered by SMFPacks Social Login Mod