Author Topic: System Settings Mail error.  (Read 5749 times)

Offline RobinA

  • Newbie
  • *
  • Posts: 21
  • Karma: +6/-0
    • View Profile
System Settings Mail error.
« on: June 06, 2015, 11:39:15 PM »
Hello All,
I need some help here.  I ignored this error when the cart was first installed and now it's coming back to haunt me.
Whenever I click in System -> Settings --> Mail, it returns this error:
Quote
Method Not Implemented
GET to /index.php not supported.
Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
Please help.

Robin

Offline Basara

  • Administrator
  • Hero Member
  • *****
  • Posts: 4191
  • Karma: +202/-0
    • View Profile
Re: System Settings Mail error.
« Reply #1 on: June 08, 2015, 04:59:19 AM »
Check AbanteCart error log.
“Chuck Norris is so amazing.”
― Mother Teresa

Offline RobinA

  • Newbie
  • *
  • Posts: 21
  • Karma: +6/-0
    • View Profile
Re: System Settings Mail error.
« Reply #2 on: June 08, 2015, 11:53:00 AM »
Basara,
I did check the log and found nothing, but doing a system search for MAIL, I found a few entries.  I right clicked on the entry below and it opened up the mail configuration page and I was able to configure it and saved it.  However, when I try to access it from the menu, the same error appears and I have to press the BACK button to return to the admin section.

   Mail Protocol:Mail: Default server mail server will be used. Make sure it is configured and able to send email with PHP mail. - default

Robin
« Last Edit: June 19, 2015, 12:12:11 PM by RobinA »

Offline Basara

  • Administrator
  • Hero Member
  • *****
  • Posts: 4191
  • Karma: +202/-0
    • View Profile
Re: System Settings Mail error.
« Reply #3 on: June 09, 2015, 02:41:40 AM »
Please post screenshot  ???
“Chuck Norris is so amazing.”
― Mother Teresa

Offline RobinA

  • Newbie
  • *
  • Posts: 21
  • Karma: +6/-0
    • View Profile
Re: System Settings Mail error.
« Reply #4 on: June 09, 2015, 07:43:31 PM »
Not much to the screen shot.  Same as what I reported.

Thanks,
Robin

Offline abolabo

  • core-developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 1774
  • Karma: +246/-11
  • web for all, all for web!
    • View Profile
    • AbanteCart
Re: System Settings Mail error.
« Reply #5 on: June 10, 2015, 05:09:46 AM »
you have web-server software misconfiguration.

try read this http://stackoverflow.com/questions/2384423/index-php-not-loading-by-default or something else about this
“No one is useless in this world who lightens the burdens of another.”
― Charles Dickens

Offline RobinA

  • Newbie
  • *
  • Posts: 21
  • Karma: +6/-0
    • View Profile
Re: System Settings Mail error.
« Reply #6 on: June 11, 2015, 02:03:15 PM »
Hello abolabo,
I trust your judgement since you are part of the development team.  That may be true but I don't see the relevance to the index file not being recognized and my problem of the Mail module throwing an error.  Are you saying that the Linux mail is not configured correctly?  The cart can send mail perfectly.  I just can't access it from the admin menu.  I enabled the .htaccess file that came with the cart and when I click on mail from the admin menu, it now goes to the user screen with "The page you requested cannot be found!".
Everything else seem to be working fine.
The only configuration change I made to the server is the timezone.  I would assume that since the cart was installed by the hosting company, they should have the correct configuration for the software.
I don't know what else to do.

Robin


Offline abolabo

  • core-developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 1774
  • Karma: +246/-11
  • web for all, all for web!
    • View Profile
    • AbanteCart
Re: System Settings Mail error.
« Reply #7 on: June 11, 2015, 02:20:09 PM »
I enabled the .htaccess file that came with the cart and when I click on mail from the admin menu, it now goes to the user screen with "The page you requested cannot be found!".

is your cart works in base of domain or subfolder? i mean http://www.yourdomain.com or  http://www.yourdomain.com/subfolder?
Please, check rewriteBase rule inside .htaccess file. Also you can search this forum about it.

regarding mail settings.. check also file permissions. i do not imagine situation that calls your error.. Please check error log too.
“No one is useless in this world who lightens the burdens of another.”
― Charles Dickens

Offline RobinA

  • Newbie
  • *
  • Posts: 21
  • Karma: +6/-0
    • View Profile
Re: System Settings Mail error.
« Reply #8 on: June 18, 2015, 10:47:12 PM »
Hello abolabo,
The cart is installed in the root folder of the domain. 
I checked the .htaccess rewriteBase. That's not the issue.Which file do I check for the permission issue?

Thanks,
Robin.

Offline abolabo

  • core-developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 1774
  • Karma: +246/-11
  • web for all, all for web!
    • View Profile
    • AbanteCart
Re: System Settings Mail error.
« Reply #9 on: June 19, 2015, 05:58:45 AM »
can you post your system/logs/error.txt here?
“No one is useless in this world who lightens the burdens of another.”
― Charles Dickens

Offline RobinA

  • Newbie
  • *
  • Posts: 21
  • Karma: +6/-0
    • View Profile
Re: System Settings Mail error.
« Reply #10 on: June 19, 2015, 12:18:45 PM »
abolabo,
I clicked on mail several times but I don't see anything being added to the log.  Here is what's in there.
Quote
2015-06-19 4:01:16 - App Error: AbanteCart core v.1.2.1 Error: Incorrect or missing resource type Array in /home/robina/public_html/core/lib/resource_manager.php on line 61
2015-06-19 4:01:16 - App Error: AbanteCart core v.1.2.1 Error: Incorrect or missing resource type Array in /home/robina/public_html/core/lib/resource_manager.php on line 61

Hope this helps,

Robin

Offline abolabo

  • core-developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 1774
  • Karma: +246/-11
  • web for all, all for web!
    • View Profile
    • AbanteCart
Re: System Settings Mail error.
« Reply #11 on: June 22, 2015, 07:15:06 AM »
not helps..
how do to you login in admin? via https?
Is https domain the same as plain?
“No one is useless in this world who lightens the burdens of another.”
― Charles Dickens

Offline RobinA

  • Newbie
  • *
  • Posts: 21
  • Karma: +6/-0
    • View Profile
Re: System Settings Mail error.
« Reply #12 on: June 22, 2015, 01:42:16 PM »
Hello abolabo,
I login to admin using: http://domainname.com/index.php?s=YYYadminXXX
domainname and YYYadminXXX have been changed to protect the domain's identity.
All other menu options seem to be working fine.
This site is hosted by Arvixe and was automatically installed by them.  I don't have access to apache nor mail folders.

Thanks,
Robin

Offline abolabo

  • core-developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 1774
  • Karma: +246/-11
  • web for all, all for web!
    • View Profile
    • AbanteCart
Re: System Settings Mail error.
« Reply #13 on: June 23, 2015, 03:15:31 AM »
In this case, unfortunately, I can not help you determine the cause of the failure. Please contact technical support of Arvix for help.
“No one is useless in this world who lightens the burdens of another.”
― Charles Dickens

Offline Gordon Taylor

  • Global Moderator
  • Full Member
  • *****
  • Posts: 149
  • Karma: +27/-0
    • View Profile
    • Natural Handcrafted Soaps
Re: System Settings Mail error.
« Reply #14 on: June 23, 2015, 08:04:36 AM »
Indeed this seems to be a hosting issue, not an AbanteCart issue.

 

Powered by SMFPacks Social Login Mod