Author Topic: Design - Blocks banner_block (Critical Error)  (Read 2822 times)

Offline Sounds

  • Newbie
  • *
  • Posts: 21
  • Karma: +1/-0
  • If you think it can it probably has been..
    • View Profile
Design - Blocks banner_block (Critical Error)
« on: June 10, 2015, 03:32:40 AM »
Hi,

The main page banner block is not loading any images after I added a new one, tried deleting it but no joy.
I went to Design > Blocks and clicked on edit for both Main Page Banner Bottom & Main Page Banner Slider.
It takes me to an error page for both

There has been a critical error processing your request

Please check AbanteCart and webserver error logs for more details. You can check error log in the control panel if it is functional. Otherwise, refer to error log located on your web server

Can I delete/uninstall it and get the files again from the latest version?
If you think it can it probably has been..

Offline Basara

  • Administrator
  • Hero Member
  • *****
  • Posts: 4411
  • Karma: +205/-0
    • View Profile
Re: Design - Blocks banner_block (Critical Error)
« Reply #1 on: June 10, 2015, 05:18:21 AM »
Please post error from AbanteCart error log
“Chuck Norris is so amazing.”
― Mother Teresa

Offline Sounds

  • Newbie
  • *
  • Posts: 21
  • Karma: +1/-0
  • If you think it can it probably has been..
    • View Profile
Re: Design - Blocks banner_block (Critical Error)
« Reply #2 on: June 10, 2015, 06:05:45 AM »
Hi,

From system > Logs > Error Logs

2015-06-10 8:06:59 - warning: AbanteCart core v.1.2.2 key() expects parameter 1 to be array, null given in <b>/home/wwwdi/public_html/store/extensions/developer_tools/admin/model/tool/developer_tools.php</b> on line <b>1107</b>
2015-06-10 8:06:59 - warning: AbanteCart core v.1.2.2 key() expects parameter 1 to be array, null given in <b>/home/wwwdi/public_html/store/extensions/developer_tools/admin/model/tool/developer_tools.php</b> on line <b>1107</b>
2015-06-10 8:06:59 - warning: AbanteCart core v.1.2.2 key() expects parameter 1 to be array, null given in <b>/home/wwwdi/public_html/store/extensions/developer_tools/admin/model/tool/developer_tools.php</b> on line <b>1107</b>
2015-06-10 8:06:59 - warning: AbanteCart core v.1.2.2 key() expects parameter 1 to be array, string given in <b>/home/wwwdi/public_html/store/extensions/developer_tools/admin/model/tool/developer_tools.php</b> on line <b>1107</b>
2015-06-10 8:06:59 - warning: AbanteCart core v.1.2.2 key() expects parameter 1 to be array, null given in <b>/home/wwwdi/public_html/store/extensions/developer_tools/admin/model/tool/developer_tools.php</b> on line <b>1107</b>
2015-06-10 8:06:59 - warning: AbanteCart core v.1.2.2 key() expects parameter 1 to be array, null given in <b>/home/wwwdi/public_html/store/extensions/developer_tools/admin/model/tool/developer_tools.php</b> on line <b>1107</b>
2015-06-10 8:06:59 - warning: AbanteCart core v.1.2.2 key() expects parameter 1 to be array, null given in <b>/home/wwwdi/public_html/store/extensions/developer_tools/admin/model/tool/developer_tools.php</b> on line <b>1107</b>
2015-06-10 8:06:59 - warning: AbanteCart core v.1.2.2 key() expects parameter 1 to be array, null given in <b>/home/wwwdi/public_html/store/extensions/developer_tools/admin/model/tool/developer_tools.php</b> on line <b>1107</b>
2015-06-10 9:57:41 - : AbanteCart core v.1.2.2 No layout found for page_id/controller 1::generic! Requested data: template: theme_clone, page_id: , layout_id: in <b>/home/wwwdi/public_html/store/core/lib/layout_manager.php</b> on line <b>111</b>
2015-06-10 9:57:54 - : AbanteCart core v.1.2.2 No layout found for page_id/controller 1::generic! Requested data: template: theme_clone, page_id: , layout_id: in <b>/home/wwwdi/public_html/store/core/lib/layout_manager.php</b> on line <b>111</b>
If you think it can it probably has been..

Offline Basara

  • Administrator
  • Hero Member
  • *****
  • Posts: 4411
  • Karma: +205/-0
    • View Profile
Re: Design - Blocks banner_block (Critical Error)
« Reply #3 on: June 10, 2015, 06:09:39 AM »
Did you try to modify slider for template clone?
“Chuck Norris is so amazing.”
― Mother Teresa

Offline Sounds

  • Newbie
  • *
  • Posts: 21
  • Karma: +1/-0
  • If you think it can it probably has been..
    • View Profile
Re: Design - Blocks banner_block (Critical Error)
« Reply #4 on: June 10, 2015, 06:14:48 AM »
I'm not sure what you mean by modify slider for template clone
All I remember is going to banner manager and tried to add another image for the slider.
That was before I had the developer tool and before I made any clone of the default theme.
If you think it can it probably has been..

Offline Basara

  • Administrator
  • Hero Member
  • *****
  • Posts: 4411
  • Karma: +205/-0
    • View Profile
Re: Design - Blocks banner_block (Critical Error)
« Reply #5 on: June 10, 2015, 06:57:56 AM »
Your error logs indicate that you have problems with template clone. Just in case please turn OFF all additional templates in Admin-Extensions-Templates and try to edit Banner again.

You can compare and copy all banners and blocks content with our demo http://www.abantecart.com/shopping-cart-demo
“Chuck Norris is so amazing.”
― Mother Teresa

Offline Sounds

  • Newbie
  • *
  • Posts: 21
  • Karma: +1/-0
  • If you think it can it probably has been..
    • View Profile
Re: Design - Blocks banner_block (Critical Error)
« Reply #6 on: June 10, 2015, 08:02:36 AM »
Yes i don't think it installed everything, there's no tpl files or anything in the folders.
How do I just delete that whole cloned theme? delete it from extensions and developer tool?

EDIT

#My god, I turned off the cloned theme under extensions, then I uninstalled and deleted that
cloned default theme from extensions, now I can't get into Design > Blocks,

I get the same error blank page.
Actually I get this for every link under Design

There has been a critical error processing your request

Please check AbanteCart and webserver error logs for more details. You can check error log in the control panel if it is functional. Otherwise, refer to error log located on your web server

EDIT

Think I fixed that by going to appearance and saving the default theme again.

I'm now able to access banner_block - Main Page Banner Bottom & banner_block - Main Page Banner Slider.

But still unable to get anything to load in the slider, it just shows the blue background and left and right arrows in the slider.
« Last Edit: June 10, 2015, 08:17:12 AM by Sounds »
If you think it can it probably has been..

 

Powered by SMFPacks Social Login Mod