Author Topic: Fatal error on installation and slow installation  (Read 4500 times)

Offline teck

  • Newbie
  • *
  • Posts: 20
  • Karma: +0/-0
    • View Profile
Fatal error on installation and slow installation
« on: October 07, 2012, 08:42:01 AM »
Dear,

During installation, at the third stage after the configuration, when i pressed continue, the following error appeared.

Fatal error: Maximum execution time of 30 seconds exceeded in E:\xampp\htdocs\virtualCart\install\model\install.php on line 49

Can someone kindly show me why? many thanks

take care,
teck
« Last Edit: October 07, 2012, 03:51:06 PM by abantecart »

Offline teck

  • Newbie
  • *
  • Posts: 20
  • Karma: +0/-0
    • View Profile
Re: Fatal error
« Reply #1 on: October 07, 2012, 08:43:21 AM »
I am using AbanteCart v1.1

take care,
teck

Offline teck

  • Newbie
  • *
  • Posts: 20
  • Karma: +0/-0
    • View Profile
Re: Fatal error
« Reply #2 on: October 07, 2012, 10:05:17 AM »
Dear all,
It may be due to two php.ini files, one at the php directory and the other one at the shopping cart subdirectory.
I changed de setting of php.ini in the php folder from 30 sec to 18000 sec.
First time when i start the installation all over again and when it execute the configuration, it take ages and I stopped it. Then later I stop and start both the sql and apache servers. When i tried to run the installation process, the shopping cart website appear  without invoke the installation at all???
I try to access to the control panel, and it works?

I am confused?

take care,
teck

Offline abantecart

  • Administrator
  • Hero Member
  • *****
  • Posts: 4151
  • Karma: +251/-9
    • View Profile
    • Ideal Open Source Ecommerce Solution
Re: Fatal error
« Reply #3 on: October 07, 2012, 03:49:41 PM »
There is a process with installing language for admin and storefront. This process can take a minute or two depending on your server.

What you did with php.ini is correct to increase maximum execution time.

When you install just wait for the install to stop. Do not stop it.

You can make installation fast if you remove 1 line of code:
Open file public_html/install/controller/pages/install.php
Locate line 226 and remove the following code:
   
Code: [Select]
   $language->definitionAutoLoad(1,'all','all','update');
NOTE: Do this before you run installation and it will be blasting fast.
When you start running application it will build language automatically as it use them. 
We need your help to build better free open source eCommerce platform for everyone.
See how you can help

 

Powered by SMFPacks Social Login Mod