Author Topic: Error messages  (Read 6029 times)

Offline astiling

  • Newbie
  • *
  • Posts: 19
  • Karma: +2/-1
    • View Profile
Error messages
« on: October 12, 2012, 08:34:00 AM »
Hi - my error log is filling with the following:

2012-10-12 12:22:25 - runtime notice:  Declaration of AMenu_Storefront::_buildMenu() should be compatible with that of AMenu::_buildMenu() in <b>/home/stylospo/public_html/core/lib/menu_control_storefront.php</b> on line <b>302</b>
2012-10-12 12:22:25 - runtime notice:  Declaration of AAttribute_Manager::getAttributes() should be compatible with that of AAttribute::getAttributes() in <b>/home/stylospo/public_html/core/lib/attribute_manager.php</b> on line <b>565</b>

hosted with Siteground but they don't know the cause.  Have only made a few changes via the GUI so unsure why this has started - errors being generated really regularly - even when no usage.

Thanks for any help.
Adam

Offline abantecart

  • Administrator
  • Hero Member
  • *****
  • Posts: 4147
  • Karma: +251/-9
    • View Profile
    • Ideal Open Source Ecommerce Solution
Re: Error messages
« Reply #1 on: October 12, 2012, 07:07:40 PM »
Can you please tell us what core version you have? What changes you did? Did you install any extensions?
We need your help to build better free open source eCommerce platform for everyone.
See how you can help

Offline abolabo

  • core-developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 1770
  • Karma: +246/-11
  • web for all, all for web!
    • View Profile
    • AbanteCart
Re: Error messages
« Reply #2 on: October 14, 2012, 07:28:32 AM »
error_reporting ralated notices.
check error_reporting value of your php.ini.
I guess you have E_STRICT there. Try to set E_ALL & ~E_DEPRECATED
“No one is useless in this world who lightens the burdens of another.”
― Charles Dickens

Offline astiling

  • Newbie
  • *
  • Posts: 19
  • Karma: +2/-1
    • View Profile
Re: Error messages
« Reply #3 on: October 15, 2012, 05:26:47 AM »
Hi - I believe it is v1.1 - from version.php:
define('MASTER_VERSION', '1');
define('MINOR_VERSION', '1');
define('VERSION_BUILT', '0');

I use the PayPal standart (sp?), flat rate shipping and COD extensions.  Only things really is adding products and minor GUI changes but all through the GUI, no config file changes.

in php.ini (well not all of it but the bit they may be useful):

display_errors = off
magic_quotes_gpc = Off;
register_globals = Off;
default_charset   = UTF-8;
memory_limit = 128M;

abolabo - please let me know what you think I should add here - presumably to get more detailed error info.

Thanks
Adam

Offline abolabo

  • core-developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 1770
  • Karma: +246/-11
  • web for all, all for web!
    • View Profile
    • AbanteCart
Re: Error messages
« Reply #4 on: October 20, 2012, 05:53:42 PM »
Hi - I believe it is v1.1 - from version.php:
define('MASTER_VERSION', '1');
define('MINOR_VERSION', '1');
define('VERSION_BUILT', '0');

I use the PayPal standart (sp?), flat rate shipping and COD extensions.  Only things really is adding products and minor GUI changes but all through the GUI, no config file changes.

in php.ini (well not all of it but the bit they may be useful):

display_errors = off
magic_quotes_gpc = Off;
register_globals = Off;
default_charset   = UTF-8;
memory_limit = 128M;

abolabo - please let me know what you think I should add here - presumably to get more detailed error info.

Thanks
Adam

hello Adam.
1. you have  runtime notice in log. not error.
2. you can try replace

error_reporting(E_ALL);
by
error_reporting(E_ALL & ~E_DEPRECATED);
in file core/init.php
(please say what result, we have no account on Siteground)

or upgrade up to 1.1.1
“No one is useless in this world who lightens the burdens of another.”
― Charles Dickens

Offline astiling

  • Newbie
  • *
  • Posts: 19
  • Karma: +2/-1
    • View Profile
Re: Error messages
« Reply #5 on: October 21, 2012, 09:13:26 AM »
OK thanks have changed that as suggested.
Do I need to do anything to ensure this change is "live"?  So far the error log has the same errors being reported.
Adam

Offline abolabo

  • core-developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 1770
  • Karma: +246/-11
  • web for all, all for web!
    • View Profile
    • AbanteCart
Re: Error messages
« Reply #6 on: October 22, 2012, 07:17:23 AM »
OK thanks have changed that as suggested.
Do I need to do anything to ensure this change is "live"?  So far the error log has the same errors being reported.
Adam

what exaclty you changed? error_reporting(E_ALL & ~E_DEPRECATED);  OR upgrade from 1.1.0 up to 1.1.1?
Second variant prefer. There no sql changes, just replace files. (but do not forget backup)
“No one is useless in this world who lightens the burdens of another.”
― Charles Dickens

Offline astiling

  • Newbie
  • *
  • Posts: 19
  • Karma: +2/-1
    • View Profile
Re: Error messages
« Reply #7 on: October 22, 2012, 01:23:16 PM »
Hi - I changed the error reporting.  I didn't upgrade yet. Will look into that as well.

Offline astiling

  • Newbie
  • *
  • Posts: 19
  • Karma: +2/-1
    • View Profile
Re: Error messages
« Reply #8 on: November 12, 2012, 11:40:49 AM »
Hi, well I finally did the 1.1.1 upgrade, so easy being a file copy.  Unfortunately I still have this error appearing really frequently in the log:

2012-11-12 16:33:46 - runtime notice:  AbanteCart core v.1.1.1 Declaration of AMenu_Storefront::_buildMenu() should be compatible with that of AMenu::_buildMenu() in <b>/home/stylospo/public_html/core/lib/menu_control_storefront.php</b> on line <b>302</b>

Any suggestions for how to remove this?

Thanks
Adam

Offline Nimitz1061

  • Full Member
  • ***
  • Posts: 190
  • Karma: +21/-0
  • No matter where you go, there you are...
    • View Profile
Re: Error messages
« Reply #9 on: November 12, 2012, 01:46:37 PM »
error_reporting ralated notices.
check error_reporting value of your php.ini.
I guess you have E_STRICT there. Try to set E_ALL & ~E_DEPRECATED

Question:  Can this not be done when generating the distribution??  No full release should go to the server with an E_STRICT in place..

David

Offline abolabo

  • core-developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 1770
  • Karma: +246/-11
  • web for all, all for web!
    • View Profile
    • AbanteCart
Re: Error messages
« Reply #10 on: November 12, 2012, 05:33:03 PM »
Question:  Can this not be done when generating the distribution??  No full release should go to the server with an E_STRICT in place..

David
David,
 I have no any messages related to warning about deprecated features of php on my localhost (php 5.3). but i think it will be appear time by time because people use different builds of php (old and new).
Unfortunally, we have no a lot of time and resources to build all possible configurations of "lamp" and test on it. i hope you, i mean community, help us. it's main idea of open-source software, everybody helps each other.
We try to cover all bugs and also go forward.
“No one is useless in this world who lightens the burdens of another.”
― Charles Dickens

Offline Nimitz1061

  • Full Member
  • ***
  • Posts: 190
  • Karma: +21/-0
  • No matter where you go, there you are...
    • View Profile
Re: Error messages
« Reply #11 on: November 16, 2012, 09:36:35 AM »
Abolabo,

On or about line 57 of core/init.php you see:

Code: [Select]
// Error Reporting
error_reporting(E_ALL);

This will include E_STRICT from 5.4 onwards, and in any previous release which is configured at compile time to do so.

I would assert that the issue as originally reported above does NOT involve E_STRICT.  Why?

Because we do not set E_STRICT on our production servers at all.  Quite the opposite, in fact.

The E_ALL in the init file is overriding server defaults, including the
Code: [Select]
~E_NOTICE setting normally present.

Note that each of the reported errors is preceded by the " runtime notice: " label which explicitly identifies a runtime notice.

I'm suggesting that adding the
Code: [Select]
~E_NOTICE  to the error_reporting statement might remedy this situation in production sites...

David

Offline abolabo

  • core-developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 1770
  • Karma: +246/-11
  • web for all, all for web!
    • View Profile
    • AbanteCart
Re: Error messages
« Reply #12 on: November 22, 2012, 04:59:54 AM »
we addressed this issue in 1.1.2. Just renamed conflict methods.
Thank you.
“No one is useless in this world who lightens the burdens of another.”
― Charles Dickens

 

Powered by SMFPacks Social Login Mod