Please help us to make AbanteCart Ideal Open Source Ecommerce Solution for everyone.

Support AbanteCart eCommerce

Author Topic: File permission error messages  (Read 3892 times)

Offline robnado

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-1
    • View Profile
File permission error messages
« on: September 21, 2015, 10:02:53 AM »
Hi all,

I keep getting these messages popping up all the time:

"/system/config.php file needs to be set to read and execute modes (644 or 755) to keep it secured from editing!"
"/index.php file is writable. It is recommended to set read and execute modes (644 or 755) for this file to keep it secured and running properly!"
[/b]

Even after changing the relevant file permissions to 644 or 755 I still get the same error message.

Any help would be great.

Offline robnado

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-1
    • View Profile
Re: File permission error messages
« Reply #1 on: September 21, 2015, 11:19:07 AM »
 :-X Dont bother to help me its too late I just got rid of this mess of a e-commerce disaster. If your like me and need a e-commerce program that's easy to use and customise use prestashop.   8)

Offline webdevmerc

  • Full Member
  • ***
  • Posts: 172
  • Karma: +32/-1
    • View Profile
Re: File permission error messages
« Reply #2 on: September 21, 2015, 01:06:27 PM »
This error seemed to have popped up with the new upgrade...It sounds like you can ignore it for now and the devs maybe trying to find more security checks within Abantecart...

No idea how good/bad Prestacart is, but I tried to research most of them prior to using Abantecart myself and went with that...

Some old messages state Prestacart is very slow on the backend (I just did a quick google search) and had massive inventory stock management issues last year...)

Like with any cart program, good developers can probably make any of them work.

Offline Basara

  • Administrator
  • Hero Member
  • *****
  • Posts: 3771
  • Karma: +184/-0
    • View Profile
Re: File permission error messages
« Reply #3 on: September 22, 2015, 02:01:53 AM »
You can disable this check in Admin > Sytem > Settings > Sytem
Also double check that you change permissions
β€œChuck Norris is so amazing.”
― Mother Teresa