Please help us to make AbanteCart Ideal Open Source Ecommerce Solution for everyone.

Support AbanteCart eCommerce

Author Topic: Critical error - unable to open website  (Read 3801 times)

Offline Richard

  • Jr. Member
  • **
  • Posts: 53
  • Karma: +4/-0
    • View Profile
Critical error - unable to open website
« on: November 26, 2015, 06:48:06 PM »
Hi Support team ,

****** Help is needed  :'(

I tried to upgrade (directly in PROD environment)abantecart from version 1.1.9(currently in used) to version 1.2.5 using the admin section - add extension 'abantecart_upgrade_125 '. While halfway of the process it shows error 'There has been a critical error processing your request'.

Now, my website is totally un-accessible.

Can someone advise :

1) How can i fix this error to bring back up the website ?
2) There is a note during the installation that automatic full backup will be created, how can i roll-back installation to v1.1.9 using the automatic full backup ?

Hope to get help as soon as possible as there is a PROD impact here. Thanks


Regards ,
Richard


Offline Richard

  • Jr. Member
  • **
  • Posts: 53
  • Karma: +4/-0
    • View Profile
Re: Critical error - unable to open website
« Reply #1 on: November 27, 2015, 04:04:29 AM »
Any update, please ?

or can anyone advise where is the full backup folder/location ? Thanks

Regards ,
Richard

Offline Basara

  • Administrator
  • Hero Member
  • *****
  • Posts: 4318
  • Karma: +203/-0
    • View Profile
Re: Critical error - unable to open website
« Reply #2 on: November 27, 2015, 05:34:54 AM »
Hello.

You should update from 1.1.9 to 1.2.0 > 1.2.1 > ....> 1.2.5
Thant why your site broken.

About backup file http://forum.abantecart.com/index.php/topic,3522.msg15177.html#msg15177
“Chuck Norris is so amazing.”
― Mother Teresa

Offline Richard

  • Jr. Member
  • **
  • Posts: 53
  • Karma: +4/-0
    • View Profile
Re: Critical error - unable to open website
« Reply #3 on: December 15, 2015, 01:28:53 AM »
Hi All ,

I've downloaded the system backup file (look like this abantecart_1.1.9_2015-MM-DD-HH-MM-SS). After unzip there are 2 folders - CODE and DATA.

I read through the manual that to restore the DATA (dump.sql) file I would need to firstly gain access to my admin panel, the problem now is not I cannot even open/access to my admin panel. My admin panel is un-accessible because of some missing files.

Is the files and folders within the CODE main folder are meant to be replaced ? Can someone provide guidance on how can I restore back to the my previous working site that runs on version 1.1.9 using the latest system backup file ? Thanks

Richard

Offline abolabo

  • core-developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 1781
  • Karma: +247/-11
  • web for all, all for web!
    • View Profile
    • AbanteCart
Re: Critical error - unable to open website
« Reply #4 on: December 15, 2015, 03:01:06 AM »
Is the files and folders within the CODE main folder are meant to be replaced ?
yes. When you created backup all your files has been copied "as-is". Just put it back into your public_html directory.

fyi. you can ask your hosting providers about daily backups. They can be run it automatically and you can use it for reverting code.
“No one is useless in this world who lightens the burdens of another.”
― Charles Dickens

Offline Richard

  • Jr. Member
  • **
  • Posts: 53
  • Karma: +4/-0
    • View Profile
Re: Critical error - unable to open website
« Reply #5 on: December 15, 2015, 04:58:43 AM »
Thank you Abolabo and all ,

I finally managed to restored my site now.

I wanted to upgrade to the latest version from my current ver 1.1.9.

Understand that the upgrade should be from 1.1.9 to 1.2.0 > 1.2.1 > ....> 1.2.5... Can someone share some guide on how to upgrade from 1.1.9 to 1.2.0 and so on ? Thanks

Richard

Offline webdevmerc

  • Full Member
  • ***
  • Posts: 172
  • Karma: +32/-1
    • View Profile
Re: Critical error - unable to open website
« Reply #6 on: December 15, 2015, 02:16:48 PM »
If you've changed anything, the upgrade would lose those changes if you've made any changes to any of the core files...

You need to find and compare all the files in the new release which have changed so if you're familiar with unix and scripting, you can run commands to parse the new files with what you have now.  Going from 1.1.9 to 1.2.5 (IMO) would be a lot of work if you have a lot of changes assuming you'd want to keep them all.  You also have to factor in any extensions you have not supported in 1.2.x.


Another option is to just load the newest version (1.2.5) and migrate your data over which would work.  You'd have to weigh which is easier and how much knowledge you have with the O/S, Abantecart, etc...

As I've mentioned in other posts, I'd suggest setting up a test environment first, then try to upgrade a backup of your existing site first in that test environment....then move forward with your production after backups...


Offline Richard

  • Jr. Member
  • **
  • Posts: 53
  • Karma: +4/-0
    • View Profile
Re: Critical error - unable to open website
« Reply #7 on: December 16, 2015, 02:01:36 AM »
Hi Webdevmerc ,

Thank you for your input.

You have lay out some good points there.
Looks like there are a lot more to consider before initiating the upgrade process to 1.2.5.

I think i'd have to have some thought on the upgrade for now.

Richard

Offline webdevmerc

  • Full Member
  • ***
  • Posts: 172
  • Karma: +32/-1
    • View Profile
Re: Critical error - unable to open website
« Reply #8 on: December 16, 2015, 08:53:27 AM »
Lastly, once you do this once and figure out how most things fit together, any problems popping up will be far far easier to solve since you can recover your site with a simple backup and you know what part needs what.

Key things are your mysql database with the data and the actual individual files within linux...recover both and your site should be back up.

Offline scorpbond

  • Newbie
  • *
  • Posts: 32
  • Karma: +2/-1
  • BlackPantherInternational
    • View Profile
    • Black Panther International Shopping Portal
Re: Critical error - unable to update from 1.2.0 to 1.2.5
« Reply #9 on: January 21, 2016, 03:38:54 AM »
Hi
I want to  upgrade from 1.2.0 to 1.2.5. Is this possible?  When i check in message alert. it is showing "AbanteCart core upgrade to v1.2.1 is now available"   

ALSO 

When I try to update through the link "attachment submited"


It Showing the error. " Error: Can't find config-file package.xml inside package. Probably package is broken. Structure of package error." snapshot attached.

Please help me to upgrade
Regards.
Abhinav Mishra
For: BlackPantherInternational

Offline Basara

  • Administrator
  • Hero Member
  • *****
  • Posts: 4318
  • Karma: +203/-0
    • View Profile
Re: Critical error - unable to open website
« Reply #10 on: January 21, 2016, 03:43:45 AM »
Hello.
You can try to update manually http://docs.abantecart.com/pages/upgrade/manual.html
Version by version - 1.2.0 > 1.2.1 > 1.2.2
Please backup your database and files before upgrade
“Chuck Norris is so amazing.”
― Mother Teresa

Offline scorpbond

  • Newbie
  • *
  • Posts: 32
  • Karma: +2/-1
  • BlackPantherInternational
    • View Profile
    • Black Panther International Shopping Portal
Re: Critical error - Upgrade help needed
« Reply #11 on: January 21, 2016, 03:50:34 AM »
I tried to upgrade from v1.2.0 to v1.2.1 but is showing  Error: Can't find config-file package.xml inside package. Probably package is broken. Structure of package error.  attachment enclosed.

I also download the package from the Download upgrade package  sourceforge net but when I upload the package and install it shows "Error: Can't find config-file package.xml inside package. Probably package is broken. Structure of package error.
"
« Last Edit: January 21, 2016, 03:58:55 AM by scorpbond »
Regards.
Abhinav Mishra
For: BlackPantherInternational

Offline abolabo

  • core-developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 1781
  • Karma: +247/-11
  • web for all, all for web!
    • View Profile
    • AbanteCart
Re: Critical error - unable to open website
« Reply #12 on: January 21, 2016, 10:18:07 AM »
Try to check permissions for directory /admin/system and subdirectories. It must be writable for php.
“No one is useless in this world who lightens the burdens of another.”
― Charles Dickens

Offline scorpbond

  • Newbie
  • *
  • Posts: 32
  • Karma: +2/-1
  • BlackPantherInternational
    • View Profile
    • Black Panther International Shopping Portal
Re: Critical error - unable to open website
« Reply #13 on: January 31, 2016, 07:52:22 AM »
All file and folder under Admin or

just system folder and all file and folder under it?

I gave 777 permission to admin folder and its subdirectories and files. Is it Ok or do I just need to 777 only to system directory and its file and folder.
« Last Edit: January 31, 2016, 07:55:43 AM by scorpbond »
Regards.
Abhinav Mishra
For: BlackPantherInternational

Offline abolabo

  • core-developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 1781
  • Karma: +247/-11
  • web for all, all for web!
    • View Profile
    • AbanteCart
Re: Critical error - unable to open website
« Reply #14 on: February 01, 2016, 09:58:28 AM »
777 means writeable for all. You should set writeable for php-user.
Please read about unix file permissions r-w-x and owner, group, all..
“No one is useless in this world who lightens the burdens of another.”
― Charles Dickens

 

Powered by SMFPacks Social Login Mod