Author Topic: Problem with login into the admin area  (Read 4491 times)

Offline shezzan

  • Newbie
  • *
  • Posts: 4
  • Karma: +0/-0
    • View Profile
Problem with login into the admin area
« on: December 04, 2015, 04:48:58 AM »
Dear AbanteCart Forum,
First of all thank you for making this great sofware.
I intend to use it to create a marketplace, so i would love the multishop feature that it seems to have.
My problem is, i installed the script properly but i receive this message at login screen:

Your server is unable to create a session necessary for AbanteCart functionality. Check logs for exact error details and contact your hosting support administrator to resolve this error.

I was reading the forum messages, but i did already what you suggest, especially i fixed the folders permissions and i also think my configuration is ok.

My hosting is Ipage, i report what they said about this error:


Hello,

There is no issue on the server that is causing this session error at http//xxxxxx.com/index.php?s=xxxxxxx. The session of this account is working fine at http//xxxxxxx.ipage.com/session.php . Also, there is no error log for reported issue. The issue appears to be with the AbanteCart application itself. We do not provide support for third party applications. I suggest you to contact your application vendor regarding this issue.

If you have any further questions, please update the Support Console.

Sincerely,

Nithin K
Technical Specialist

Can you explain me what to do step by step please?

Thank you very much,
Rick

Offline abolabo

  • core-developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 1773
  • Karma: +246/-11
  • web for all, all for web!
    • View Profile
    • AbanteCart
Re: Problem with login into the admin area
« Reply #1 on: December 04, 2015, 05:44:44 AM »
hello.

it is known issue.

You have 2 solutions.
1. change(or set) php-directive "session.save_path" in your php.ini (on redhat-based linux distributives it have empty value). Just uncomment it and set value "/tmp".
2. replace your file by this https://raw.githubusercontent.com/abantecart/abantecart-src/1.2.6/public_html/core/helper/system_check.php

“No one is useless in this world who lightens the burdens of another.”
― Charles Dickens

Offline shezzan

  • Newbie
  • *
  • Posts: 4
  • Karma: +0/-0
    • View Profile
Re: Problem with login into the admin area
« Reply #2 on: December 07, 2015, 09:04:49 AM »
I did what you said but nothing changes.
Any other options?
Is anybody kind enough to have a look on my installation?
Thanks

Offline eCommerce Core

  • Administrator
  • Hero Member
  • *****
  • Posts: 1600
  • Karma: +93/-1
    • View Profile
Re: Problem with login into the admin area
« Reply #3 on: December 08, 2015, 07:38:45 AM »
Can you PM access to your server and admin ?
“If you’re in the luckiest one per cent of humanity, you owe it to the rest of humanity to think about the other 99 per cent.”
― Warren Buffett

Offline shezzan

  • Newbie
  • *
  • Posts: 4
  • Karma: +0/-0
    • View Profile
Re: Problem with login into the admin area
« Reply #4 on: December 11, 2015, 11:03:01 PM »
Dear Admin,
I sent you my installations details, i hope that you can help me solving the problems, so i can learn how to use this great e-commerce solution.
Thank you in advance.

Offline shezzan

  • Newbie
  • *
  • Posts: 4
  • Karma: +0/-0
    • View Profile
Re: Problem with login into the admin area
« Reply #5 on: December 13, 2015, 07:13:47 AM »
Hello dear Admin the problem is solved now but thanks for your help anyway.FYI was a session path problem.

Offline moebius

  • Newbie
  • *
  • Posts: 26
  • Karma: +3/-0
    • View Profile
Re: Problem with login into the admin area
« Reply #6 on: December 13, 2015, 03:19:37 PM »
hello.

it is known issue.

You have 2 solutions.
1. change(or set) php-directive "session.save_path" in your php.ini (on redhat-based linux distributives it have empty value). Just uncomment it and set value "/tmp".
2. replace your file by this https://raw.githubusercontent.com/abantecart/abantecart-src/1.2.6/public_html/core/helper/system_check.php

Thank you!  the file edit from GitHub didn't work, but I added the session save path string to PHP.INI, and it is now working for me.  Much appreciated!

 

Powered by SMFPacks Social Login Mod