Author Topic: Upgrade to 1.2.9 failed  (Read 896 times)

Offline kthackwray

  • Newbie
  • *
  • Posts: 7
  • Karma: +1/-0
    • View Profile
Upgrade to 1.2.9 failed
« on: January 05, 2017, 12:29:21 PM »
Hi there
I tried upgrading from a previous version (1.2.4 if I remember correctly )  to 1.2.9 and I get the following message

warning: require_once(/home/filtrmtk/public_html/core/helper/system_check.php): failed to open stream: No such file or directory in /home/filtrmtk/public_html/core/init.php on line 229
Fatal error: require_once(): Failed opening required '/home/filtrmtk/public_html/core/helper/system_check.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/filtrmtk/public_html/core/init.php on line 229
compile error: require_once(): Failed opening required '/home/filtrmtk/public_html/core/helper/system_check.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/filtrmtk/public_html/core/init.php on line 229

Based on the info I have now found on the forum - it looks like I have to do incremental upgrades 1.2.4 1.2.5 1.2.6 etc which would be OK if I could just recover the previous version - when doing the upgrade I got a message that AbanteCart would do a backup so I never did a backup thinking it would be OK ?

I have an old full system backup so my question is which folders and files should I copy back into the "home" directory ?

so far I have copied all the old files in the "public_html" folder ? (still get the same error )

Please help



Offline abolabo

  • core-developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 1781
  • Karma: +247/-11
  • web for all, all for web!
    • View Profile
    • AbanteCart
Re: Upgrade to 1.2.9 failed
« Reply #1 on: January 05, 2017, 12:50:12 PM »
You should to download file public_html/core/helper/system_check.php from our repository and try again
find your version here  archive and pull it
“No one is useless in this world who lightens the burdens of another.”
― Charles Dickens

Offline kthackwray

  • Newbie
  • *
  • Posts: 7
  • Karma: +1/-0
    • View Profile
Re: Upgrade to 1.2.9 failed
« Reply #2 on: January 06, 2017, 11:36:43 AM »
Thanks for the help

Now get this error ?

Fatal error: Call to undefined method ACache::isCacheEnabled() in /home/filtrmtk/public_html/core/engine/extensions.php on line 429

Line 427,428,429 from extensions.php


   public function getExtensionsList($data = array (), $mode = ''){
      $cache_key = '';
      if ($mode == '' && $this->cache && $this->cache->isCacheEnabled()){


Offline abolabo

  • core-developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 1781
  • Karma: +247/-11
  • web for all, all for web!
    • View Profile
    • AbanteCart
Re: Upgrade to 1.2.9 failed
« Reply #3 on: January 08, 2017, 02:40:19 PM »
do the same with core/lib/cache.php
“No one is useless in this world who lightens the burdens of another.”
― Charles Dickens

Offline kthackwray

  • Newbie
  • *
  • Posts: 7
  • Karma: +1/-0
    • View Profile
Re: Upgrade to 1.2.9 failed
« Reply #4 on: January 09, 2017, 06:47:40 AM »
Thanks again
I now get this message
Fatal error: Call to undefined method AException::errorCode() in /home/filtrmtk/public_html/core/lib/exceptions.php on line 90

Just a quick question
I have a full  backup from when the site was on  1.2.0
Would it be possible to install 1.2.0  / 1.2.9 as a new installation - link it to the existing database (1.2.0 version I think ) and then just update the folders and content that have changed - or am I being too simplistic ?
Cheers

Offline abolabo

  • core-developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 1781
  • Karma: +247/-11
  • web for all, all for web!
    • View Profile
    • AbanteCart
Re: Upgrade to 1.2.9 failed
« Reply #5 on: January 09, 2017, 07:46:36 AM »
no. you should to do incremental upgrade. from 1.2.0 to 1.2.1 then 1.2.2 etc
“No one is useless in this world who lightens the burdens of another.”
― Charles Dickens

 

Powered by SMFPacks Social Login Mod