Author Topic: Incorrect File Permissions  (Read 2265 times)

Offline MessEleven

  • Jr. Member
  • **
  • Posts: 52
  • Karma: +8/-0
    • View Profile
Incorrect File Permissions
« on: April 26, 2017, 11:05:00 AM »
Just the latest in a LONG line of issues. I really regret having upgraded to 1.2.10. If we ever get this straightened out, we're done with upgrades. The latest is the following persistent error message:

public_html/system/config.php file needs to be set to read and execute modes to keep it secured from editing!

I've just completed changing the file permissions for this config file to every possible combination, and still the error message persists. I've deleted the cache, yet no change seems to affect it. Functionality on the site seems to be fine now, but we're concerned about the security. Any thoughts?

Offline eCommerce Core

  • Administrator
  • Hero Member
  • *****
  • Posts: 1602
  • Karma: +93/-1
    • View Profile
Re: Incorrect File Permissions
« Reply #1 on: April 26, 2017, 03:31:29 PM »
Set public_html/system/config.php to 644 and it will be safe. This file is never effected in the upgrade.
“If you’re in the luckiest one per cent of humanity, you owe it to the rest of humanity to think about the other 99 per cent.”
― Warren Buffett

Offline MessEleven

  • Jr. Member
  • **
  • Posts: 52
  • Karma: +8/-0
    • View Profile
Re: Incorrect File Permissions
« Reply #2 on: April 26, 2017, 03:44:17 PM »
Changed it as you suggested to 644, opened our site and immediately got the error message again.

Offline eCommerce Core

  • Administrator
  • Hero Member
  • *****
  • Posts: 1602
  • Karma: +93/-1
    • View Profile
Re: Incorrect File Permissions
« Reply #3 on: April 26, 2017, 03:51:50 PM »
Changed it as you suggested to 644, opened our site and immediately got the error message again.

Are you sure that message is not old. Is your server on linux or windows based OS?
“If you’re in the luckiest one per cent of humanity, you owe it to the rest of humanity to think about the other 99 per cent.”
― Warren Buffett

Offline eCommerce Core

  • Administrator
  • Hero Member
  • *****
  • Posts: 1602
  • Karma: +93/-1
    • View Profile
Re: Incorrect File Permissions
« Reply #4 on: April 26, 2017, 03:52:22 PM »
Try 755 or 555
“If you’re in the luckiest one per cent of humanity, you owe it to the rest of humanity to think about the other 99 per cent.”
― Warren Buffett

Offline MessEleven

  • Jr. Member
  • **
  • Posts: 52
  • Karma: +8/-0
    • View Profile
Re: Incorrect File Permissions
« Reply #5 on: April 26, 2017, 04:13:14 PM »
Server is Linux, and I've already tried both of those combinations. Is there a chance that I might have incorrect permissions elsewhere that are affecting this? The error warnings are new each time I clear them, and open a page on the site. I'll send you a pm of the site's address.

Offline eCommerce Core

  • Administrator
  • Hero Member
  • *****
  • Posts: 1602
  • Karma: +93/-1
    • View Profile
Re: Incorrect File Permissions
« Reply #6 on: April 26, 2017, 04:33:13 PM »
The system checks if file is writable for the web user (apache).

Code: [Select]
if (is_writable(DIR_SYSTEM . 'config.php')) {

I suspect that public_html/system/config.php owner is the same as your web user. If you set file permissions 555 or 444 this check will pass.

« Last Edit: April 26, 2017, 04:35:18 PM by eCommerce Core »
“If you’re in the luckiest one per cent of humanity, you owe it to the rest of humanity to think about the other 99 per cent.”
― Warren Buffett

Offline MessEleven

  • Jr. Member
  • **
  • Posts: 52
  • Karma: +8/-0
    • View Profile
Re: Incorrect File Permissions
« Reply #7 on: April 26, 2017, 11:01:45 PM »
Tried it both ways (555 and 444) with no luck. Still getting error messages. Regardless of the messages, is the site safe using any of these configurations, including 755?

Offline Basara

  • Administrator
  • Hero Member
  • *****
  • Posts: 4586
  • Karma: +224/-0
    • View Profile
Re: Incorrect File Permissions
« Reply #8 on: April 27, 2017, 02:54:28 AM »
Hello, MessEleven. AbanteCart do the best to report you an issue with security. System check if config.php file writable because some servers not configured correctly or to avoid server administrator mistake.
This message just indicate a problem to help you be more secure.
Please read a bit about permissions but it is more about your server/users configuration and not about AbanteCart  ;)
http://docs.abantecart.com/pages/tips/troubleshooting.html#permissions

If you just want to hide this message and you sure your permissions are correct simply disable System check in Admin > System > Settings page.
« Last Edit: April 27, 2017, 02:57:16 AM by Basara »
“Chuck Norris is so amazing.”
― Mother Teresa

Offline MessEleven

  • Jr. Member
  • **
  • Posts: 52
  • Karma: +8/-0
    • View Profile
Re: Incorrect File Permissions
« Reply #9 on: April 27, 2017, 06:22:32 AM »
I think I've finally figured it out. Instead of changing permissions with cPanel, I was doing it with the remote server through Dreamweaver. For some reason when doing so, the changes on the server side weren't being saved. I made the permission corrections last night via cPanel instead, and voila! No error messages since.

Thank you both - eCommerce Core and Basara - for your help with this frustrating issue!

Offline Basara

  • Administrator
  • Hero Member
  • *****
  • Posts: 4586
  • Karma: +224/-0
    • View Profile
Re: Incorrect File Permissions
« Reply #10 on: April 27, 2017, 06:25:55 AM »
Thank you for reply back. This will help other AbanteCart Community users  ;D
“Chuck Norris is so amazing.”
― Mother Teresa

 

Powered by SMFPacks Social Login Mod