Author Topic: Hi and Thank You  (Read 128 times)

Offline Knockishee

  • Newbie
  • *
  • Posts: 12
  • Karma: +2/-0
    • View Profile
Hi and Thank You
« on: September 06, 2017, 09:37:46 PM »
Just wanted to say Hi and a big thank you for the software.

I am 17 and started my business around a year ago (full time), its tiny at the moment but I wanted to open a online shop, I looked at loads of packages but nothing seems to fit.

Then I came across AbanteCart Cart, looks like it will do everything I ever wanted and then some!! Its likely I will be on here alot asking questions, i have read the docs but me and the web have issues :D.

Once I have stopped my site looking like a bomb hit it (i been customizing!), I will post a link. Sorry in advance for any stupid questions I will ask.

I nearly didnt use it because the numbering system fooled me, For some odd reason I was sure the latest version didnt support embedding of products!! Then I discovered I cant count properly and embedding is supported!! that and multiple stores sealed the deal big time.

I am aware the sensible approach is to hire a developer to make the few changes I want, however even the lower figures quoted are around a years turnover for my little business, so I am going to have a go myself until I can afford a pro :D.

Not that I think the prices quoted were high, its more a case I am a very small start up business.

Sorry for the waffle, and thanks again for high quality free software.

one small thing however, i couldnt sign up with my normal email address, apparently the validation dosnt take some of the newer TLD's into account. On my set up is there anyway I can add more TLD's? I dont want customers put off signing up because they cant use say .service as a email address. Thanks again

Offline Basara

  • Administrator
  • Hero Member
  • *****
  • Posts: 2995
  • Karma: +141/-0
    • View Profile
Re: Hi and Thank You
« Reply #1 on: September 07, 2017, 01:44:20 AM »
Hello. Welcome and thank you

Email problem should be easy to fix. Can you post example of email you cannot register with?
“Chuck Norris is so amazing.”
― Mother Teresa

Offline Knockishee

  • Newbie
  • *
  • Posts: 12
  • Karma: +2/-0
    • View Profile
Re: Hi and Thank You
« Reply #2 on: September 07, 2017, 07:29:27 AM »
The email address was admin at knockishee.services  I got a invalid email address, obviously i didnt spell out At i did use @ :D

Offline abolabo

  • core-developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 1626
  • Karma: +206/-10
  • web for all, all for web!
    • View Profile
    • AbanteCart
Re: Hi and Thank You
« Reply #3 on: September 07, 2017, 09:05:15 AM »
Hi.
AbanteCart use global constant for email address validation which contains regular expression
Code: [Select]
define('EMAIL_REGEX_PATTERN','/^[A-Z0-9._%-]+@[A-Z0-9.-]{0,61}[A-Z0-9]\.[A-Z]{2,16}$/i');
As you see you can have any letters in the domain suffix up to 16 characters.
I tried to test your email and it passed validation. Also had tried to register - same result, no problem
Can you provide more details such as abantecart version, platform details, erros in log-file?
“No one is useless in this world who lightens the burdens of another.”
― Charles Dickens

Offline Knockishee

  • Newbie
  • *
  • Posts: 12
  • Karma: +2/-0
    • View Profile
Re: Hi and Thank You
« Reply #4 on: September 07, 2017, 03:49:14 PM »
version was 2.10 installed via softaculous.

No error in logs, i also registered an account under another email address, the account shows as being there but it will not send a verification through....

I have a more pressing problem at the moment, however as soon as I have dealt with that I will pop back and give you a detailed report on all the issues I had in trying to sign up.

One problem involved missing the captcha pic (it was below the small screen i was using, and I didnt notice it, the software asked me to press the back button (which I did) and resend. I also did this. At that point I was informed the account existed, however it didnt, i proved this by closing the page and reopening it, then filling the form out again, i was then able to get an account open.

I will try another account using a similar email, any errors i get I will investigate fully and report back. But at the moment I have a major problem cloning the theme, i would like to get that issue sorted first if I can.

I appreciate all the help and the effort you guys put in to sort out these small problems that crop up.

By the way, the email not being sent isnt down to a spam box, i used an email account that dosnt have any spam protection on. the email and account for that is username LGPaul  and the email address was business at lgpaul.org  this should show in the logs as a inactivated account, again I did send for another confirmation email but it never arrived.

This despite not having a spam filter, could well be down to the use of a shared hosting account, it is not uncommon for emails to go missing for no apparent reason.

I am keen to help if I can, so I will report back with full details in due course.

 

application and website monitoring