Author Topic: default_stripe_ssl_off_error  (Read 2169 times)

Offline barry819

  • Newbie
  • *
  • Posts: 23
  • Karma: +2/-0
    • View Profile
default_stripe_ssl_off_error
« on: November 12, 2017, 06:15:34 PM »
Having a problem with my Abantecart installation at theresamatherfantasyshop.com. It's not showing the box to enter credit card info, and giving the error default_stripe_ssl_off_error. Not sure how to fix it.

I did the Abantecart update, and I've also verified Stripe is connected to it. Was working fine about a week ago before update

Offline Basara

  • Administrator
  • Hero Member
  • *****
  • Posts: 4410
  • Karma: +205/-0
    • View Profile
Re: default_stripe_ssl_off_error
« Reply #1 on: November 13, 2017, 12:55:46 AM »
Hello.
Did you enable SSL in your store? Is your ssl certificate valid?
“Chuck Norris is so amazing.”
― Mother Teresa

Offline barry819

  • Newbie
  • *
  • Posts: 23
  • Karma: +2/-0
    • View Profile
Re: default_stripe_ssl_off_error
« Reply #2 on: November 13, 2017, 10:53:23 AM »
It was working fine until sometime this week, when it stopped and began giving this message. This may have been triggered by an update to Abantecart.

I am running Abantecart 1.2.11, and Stripe Payment extension 1.0.1

What does the "default_stripe_ssl_off_error" error mean?

Offline Basara

  • Administrator
  • Hero Member
  • *****
  • Posts: 4410
  • Karma: +205/-0
    • View Profile
Re: default_stripe_ssl_off_error
« Reply #3 on: November 13, 2017, 11:46:17 PM »
Hello.

Stipe extension was changed in 1.2.11 please install latest 1.0.2
https://github.com/abantecart/abantecart-src/tree/master/public_html/extensions/default_stripe

This error mean 'Secure connection cant be established'
“Chuck Norris is so amazing.”
― Mother Teresa

Offline barry819

  • Newbie
  • *
  • Posts: 23
  • Karma: +2/-0
    • View Profile
Re: default_stripe_ssl_off_error
« Reply #4 on: November 15, 2017, 01:04:30 AM »
I can see a bunch of files on that page, but I have no idea how to do an update with those. Can't the updated version of the Stripe extension be made available in the extensions library where it could be installed from? There isn't a free one there at all right now, only the "Advanced Stripe Gateway" which is $39. Or shouldn't the installed extension show that an update is available?

I am trying to sell things. I am not a programmer.

Offline Basara

  • Administrator
  • Hero Member
  • *****
  • Posts: 4410
  • Karma: +205/-0
    • View Profile
Re: default_stripe_ssl_off_error
« Reply #5 on: November 15, 2017, 02:12:53 AM »
Hi.

You dont need to be a programmer.
Download latest AbanteCart https://github.com/abantecart/abantecart-src/archive/master.zip
unarchive zip. Go to unarchived folder /abantecart-src/public_html/extensions/ and upload via FTP default_stripe directory to your serverwhereabantecartinstalled/extensions/

Replace all files if ask.

“Chuck Norris is so amazing.”
― Mother Teresa

Offline barry819

  • Newbie
  • *
  • Posts: 23
  • Karma: +2/-0
    • View Profile
Re: default_stripe_ssl_off_error
« Reply #6 on: November 16, 2017, 11:31:08 AM »
OK, I've done that, uninstalled the Stripe extension, then reinstalled it. It still says it's version 1.0.1, but I did replace all the files. Why is it not showing as the updated version 1.0.2? Is it or is it not updated? Does something else in the installation need to be updated to work with it?

Now I'm showing a different error on the checkout page: Secure connection cannot be established! What causes this error?

More precisely, what is making Abantecart unable to establish a secure connection with Stripe? It used to work fine.


And since I have Paypal working - for now - is there a way to turn off the "Checkout" button on the cart page so that only the Paypal button is visible? Customers can pay with Paypal, the checkout button is a dead end until Stripe is fixed.
« Last Edit: November 16, 2017, 05:07:48 PM by barry819 »

Offline Basara

  • Administrator
  • Hero Member
  • *****
  • Posts: 4410
  • Karma: +205/-0
    • View Profile
Re: default_stripe_ssl_off_error
« Reply #7 on: November 17, 2017, 12:30:29 AM »
Secure connection cannot be established!

Hi, do you have SSL enabled in your store settings? Is your SSL certificate valid?
“Chuck Norris is so amazing.”
― Mother Teresa

Offline barry819

  • Newbie
  • *
  • Posts: 23
  • Karma: +2/-0
    • View Profile
Re: default_stripe_ssl_off_error
« Reply #8 on: November 17, 2017, 12:37:56 AM »
I haven't made any changes to security between the time it was working and now. My security settings were fine and acceptable before the most recent Abantecart update.

 

Powered by SMFPacks Social Login Mod