Author Topic: Latest compatible PHP version?  (Read 998 times)

Offline Geoffrey

  • Full Member
  • ***
  • Posts: 153
  • Karma: +27/-3
    • View Profile
Latest compatible PHP version?
« on: April 26, 2018, 01:41:40 AM »
Hello,

I want to update my xampp version on my local machine. 

Multiple xampp options are available:
I can get xampp with PHP 7.2.4 or 7.1.16 or 7.0.29.

On my live server, if I switch from php 7.0 to 7.2, the AC site fails to load. 

So I guess AC is not compatible with any php 7.2.x?

What is the latest PHP version compatible with AC?

Can you recommend whether I choose xampp with 7.0.29 or 7.1.16?

Thanks.


Offline Basara

  • Administrator
  • Hero Member
  • *****
  • Posts: 4380
  • Karma: +205/-0
    • View Profile
Re: Latest compatible PHP version?
« Reply #1 on: April 26, 2018, 04:27:18 AM »
Hello.

For 1.2.12 use php 7.0
for 1.2.13 php 7.2
“Chuck Norris is so amazing.”
― Mother Teresa

Offline JerryPF

  • Newbie
  • *
  • Posts: 7
  • Karma: +2/-0
    • View Profile
Re: Latest compatible PHP version?
« Reply #2 on: April 26, 2018, 07:21:31 AM »
Hi,

On our development server we run PHP 7.1.16 without experiencing any problems.
AC version we use is 1.2.12

AC 1.2.13 ? That's interesting. On the AC website I can only find a download link
to apparently the latest AC version 1.2.12

How to download AC version 1.2.13 and when will it be available?

Cheers,
Jerry

Offline Geoffrey

  • Full Member
  • ***
  • Posts: 153
  • Karma: +27/-3
    • View Profile
Re: Latest compatible PHP version?
« Reply #3 on: September 05, 2018, 12:19:32 PM »
My AC site is fabulous. 
Very clean and efficient. 
Heavily modified so that it could be clean and efficient. 
Many core mods. 

It took a very long time to build. 
Lots of work. 
Lots. 

It's on 1.2.11.

It will stay on 1.2.11 forever. 
It will never update to a later version of AC because the work involved is not worth the end result. 

Therefore, it would be nice to be able to modify 1.2.11 to run on PHP 7.2 or even 7.3.

Because in the grand scheme, it's not really okay to have a cart app that runs on 7.0 but won't run on 7.1 or 7.2 or 7.x. 

In 1.2.11, what files do I need to change so that AC will run on 7.2?

Thx.

Offline Basara

  • Administrator
  • Hero Member
  • *****
  • Posts: 4380
  • Karma: +205/-0
    • View Profile
Re: Latest compatible PHP version?
« Reply #4 on: September 06, 2018, 01:19:22 AM »
Hello.
The latest version of AbanteCart 1.2.13 was tested on PHP 7.2.5 but it will be tricky to apply all changes to outdated 1.2.11
Commits with changes here https://github.com/abantecart/abantecart-src/commits/master
https://github.com/abantecart/abantecart-src/compare/1.2.11...1.2.13?w=1

A diff view with reduced white space has been available in github by adding ?w=1 to the URL.
“Chuck Norris is so amazing.”
― Mother Teresa

Offline Geoffrey

  • Full Member
  • ***
  • Posts: 153
  • Karma: +27/-3
    • View Profile
Re: Latest compatible PHP version?
« Reply #5 on: September 06, 2018, 05:20:33 PM »
Thanks for the info!

I will check out your links and see how things go...


 

Powered by SMFPacks Social Login Mod