Please help us to make AbanteCart Ideal Open Source Ecommerce Solution for everyone.

Support AbanteCart eCommerce

Author Topic: Contact Form Not Sending Me Emails  (Read 8567 times)

Offline FG

  • Newbie
  • *
  • Posts: 27
  • Karma: +5/-0
    • View Profile
Contact Form Not Sending Me Emails
« on: February 25, 2013, 06:36:20 AM »
I'm going through the testing phase now of my new website and the Contact form isn't sending me any emails after filling it in.  I've already had one customer register and they filled out the contact form to ask us a question but after not hearing from us within a couple of days they replied to the email that AbanteCart sent thanking them for registering their account and I received that OK so the emails are going out to customers OK, just not to us via the Contact Us form.

What settings can I check to make sure it's setup OK?

Thanks.

Offline abolabo

  • core-developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 1840
  • Karma: +277/-11
  • web for all, all for web!
    • View Profile
    • AbanteCart
Re: Contact Form Not Sending Me Emails
« Reply #1 on: February 25, 2013, 06:43:50 AM »
please search in forum for that. we already answered
“No one is useless in this world who lightens the burdens of another.”
― Charles Dickens

Offline FG

  • Newbie
  • *
  • Posts: 27
  • Karma: +5/-0
    • View Profile
Re: Contact Form Not Sending Me Emails
« Reply #2 on: February 25, 2013, 06:58:29 AM »
I've tried searching the forum and got no results.  I've just tried again and the only result I get is this thread!  :(

Offline abolabo

  • core-developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 1840
  • Karma: +277/-11
  • web for all, all for web!
    • View Profile
    • AbanteCart
Re: Contact Form Not Sending Me Emails
« Reply #3 on: February 25, 2013, 07:16:54 AM »
be sure that your server sends emails. Just register new customer and place order. You have to get email.
if not - you need to set up mail settings, for ex. for gmail.com
“No one is useless in this world who lightens the burdens of another.”
― Charles Dickens

Offline FG

  • Newbie
  • *
  • Posts: 27
  • Karma: +5/-0
    • View Profile
Re: Contact Form Not Sending Me Emails
« Reply #4 on: February 25, 2013, 07:24:22 AM »
The server is sending emails OK as like I mentioned above a customer has already registered with my site and they have received an email from it.  I know this as they replied to the email asking why I hadn't responded to their question they put in the Contact form so I can see that the site has emailed out when the customer registered but nothing comes in me inbox when using the contact form.

I've just tried searching google for problems with AbanteCart and the contact form and get no relavent results.  You say this has already been answered before so can you please put a link to it in this thread so I can take a look please?

Thanks.  :)

Offline abolabo

  • core-developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 1840
  • Karma: +277/-11
  • web for all, all for web!
    • View Profile
    • AbanteCart
Re: Contact Form Not Sending Me Emails
« Reply #5 on: February 26, 2013, 01:09:42 AM »
Are you got message "Your enquiry has been successfully sent to the store owner!" after sent?
What mail-service do you use?  Own or third party? for ex. gmail, yahoo, homail etc
try to set up mail-settings in admin of your AbanteCart like here
http://forum.abantecart.com/index.php/topic,144.msg401.html#msg401
And try to send message from contact form to yourself.

“No one is useless in this world who lightens the burdens of another.”
― Charles Dickens

Offline FG

  • Newbie
  • *
  • Posts: 27
  • Karma: +5/-0
    • View Profile
Re: Contact Form Not Sending Me Emails
« Reply #6 on: February 26, 2013, 06:58:00 AM »
Are you got message "Your enquiry has been successfully sent to the store owner!" after sent?
What mail-service do you use?  Own or third party? for ex. gmail, yahoo, homail etc
try to set up mail-settings in admin of your AbanteCart like here
http://forum.abantecart.com/index.php/topic,144.msg401.html#msg401
And try to send message from contact form to yourself.

Yes I get the successfully sent message but no email received. I'm not using SMTP as it says it recommends you use the Mail option so I've left it like that.  It sends out emails OK when you register as a customer so I know it's sending OK.  Does the Contact form use different settings?

Offline FG

  • Newbie
  • *
  • Posts: 27
  • Karma: +5/-0
    • View Profile
Re: Contact Form Not Sending Me Emails
« Reply #7 on: February 26, 2013, 08:23:46 AM »
I've resolved the issue by not using the recommended setting of 'Mail' but using the 'SMTP' option instead.

 

Powered by SMFPacks Social Login Mod