Author Topic: Design - Layouts not Updating  (Read 19272 times)

Offline srs

  • Newbie
  • *
  • Posts: 22
  • Karma: +1/-0
    • View Profile
Design - Layouts not Updating
« on: May 17, 2013, 01:17:54 PM »
Selecting Design > Layouts (Layout & Blocks Manager), amending the content of the blocks and then selecting Save at the bottom of the page produces a message "Success: You have modified layout & blocks!" on a green background.

The Layout & Blacks Manager page refreshes and the change is not visible - ie it is just as it was before! And the change has NOT been made despite the success message.

Offline abantecart

  • Administrator
  • Hero Member
  • *****
  • Posts: 3963
  • Karma: +241/-9
    • View Profile
    • Ideal Open Source Ecommerce Solution
Re: Design - Layouts not Updating
« Reply #1 on: May 17, 2013, 02:43:28 PM »
What version do you use?
We need your help to build better free open source eCommerce platform for everyone.
See how you can help

Offline srs

  • Newbie
  • *
  • Posts: 22
  • Karma: +1/-0
    • View Profile
Re: Design - Layouts not Updating
« Reply #2 on: May 17, 2013, 04:04:15 PM »
Version 1.1.4 on a Windows Server platform.

Offline abantecart

  • Administrator
  • Hero Member
  • *****
  • Posts: 3963
  • Karma: +241/-9
    • View Profile
    • Ideal Open Source Ecommerce Solution
Re: Design - Layouts not Updating
« Reply #3 on: May 18, 2013, 10:48:25 AM »
Can you please check the log in system -> log -> error log?

also try to clear cache.
We need your help to build better free open source eCommerce platform for everyone.
See how you can help

Offline srs

  • Newbie
  • *
  • Posts: 22
  • Karma: +1/-0
    • View Profile
Re: Design - Layouts not Updating
« Reply #4 on: May 19, 2013, 12:04:40 PM »
Cache cleared - all files. Made no difference.

Extracts from error log attached - many more were generated and have been deleted from the attachment due to your upload size restrictions.

Is this another case of the system trying to rely on a Unix standard call which cannot be found on a Windows server?

Offline abantecart

  • Administrator
  • Hero Member
  • *****
  • Posts: 3963
  • Karma: +241/-9
    • View Profile
    • Ideal Open Source Ecommerce Solution
Re: Design - Layouts not Updating
« Reply #5 on: May 19, 2013, 11:40:41 PM »
If you look at you log, you can see that many files can not be write to or deleted. Check permission on files on your system in relation to your web server.
This is clear indication of problem. Cache can not be saved or removed and layout  updates will not be effected.
We need your help to build better free open source eCommerce platform for everyone.
See how you can help

Offline srs

  • Newbie
  • *
  • Posts: 22
  • Karma: +1/-0
    • View Profile
Re: Design - Layouts not Updating
« Reply #6 on: May 20, 2013, 06:05:56 AM »
I had already looked at the log before posting my previous message. And, from the previous problem I had I had already worked out that the software was failing to write something somewhere.

I had also checked, double checked and triple checked that the various directories listed in the install requirements were set to read/write. They wera at every check and I've check again and they still are.

These facts are, indeed, a clear indication of a problem - but not where you seem to think. Unless, that is, there is another factor relating to windows servers you haven't told me about.

A solution is required.

Offline srs

  • Newbie
  • *
  • Posts: 22
  • Karma: +1/-0
    • View Profile
Re: Design - Layouts not Updating
« Reply #7 on: May 20, 2013, 08:03:33 AM »
I thought I'd give matters another try - these errors appear in the Firefox error console.

There are quite a few, just a small selection in the attached file.

Offline abolabo

  • core-developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 1744
  • Karma: +235/-10
  • web for all, all for web!
    • View Profile
    • AbanteCart
Re: Design - Layouts not Updating
« Reply #8 on: May 21, 2013, 05:14:12 AM »
Please do not confuse errors with a warning.
All that you posted related to 3d-party (jquery cross-browser css etc.).
Nevermind.
“No one is useless in this world who lightens the burdens of another.”
― Charles Dickens

Offline srs

  • Newbie
  • *
  • Posts: 22
  • Karma: +1/-0
    • View Profile
Re: Design - Layouts not Updating
« Reply #9 on: May 22, 2013, 02:32:43 AM »
The fact remains that the problem prevents any use of the system.

If the problem is caused by 'third party' items, then you must assume responsibility for putting in calls to 'third party' systems that clearly aren't working.

Your final comment "nevermind" shows a cavalier attitude to potential users.

Are any of the support team really interested in solving this?
« Last Edit: May 22, 2013, 02:45:50 AM by srs »

Offline abolabo

  • core-developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 1744
  • Karma: +235/-10
  • web for all, all for web!
    • View Profile
    • AbanteCart
Re: Design - Layouts not Updating
« Reply #10 on: May 22, 2013, 04:16:16 AM »
The fact remains that the problem prevents any use of the system.

please describe details how this "problem" prevents any use of the system
“No one is useless in this world who lightens the burdens of another.”
― Charles Dickens

Offline srs

  • Newbie
  • *
  • Posts: 22
  • Karma: +1/-0
    • View Profile
Re: Design - Layouts not Updating
« Reply #11 on: May 22, 2013, 04:50:51 AM »
In order to satisfy myself that it is usable I require to customise the layout.

If the system is to be usable to me then all features need to work on my existing web site platform.

Offline abolabo

  • core-developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 1744
  • Karma: +235/-10
  • web for all, all for web!
    • View Profile
    • AbanteCart
Re: Design - Layouts not Updating
« Reply #12 on: May 22, 2013, 05:56:18 AM »
In order to satisfy myself that it is usable I require to customise the layout.
If the system is to be usable to me then all features need to work on my existing web site platform.
it's just a words.
I understand that you have no evidence of dysfunction Abantecart.
All that you have taken - a warning (not an error), which gives one or another browser on css-hacks.
“No one is useless in this world who lightens the burdens of another.”
― Charles Dickens

Offline srs

  • Newbie
  • *
  • Posts: 22
  • Karma: +1/-0
    • View Profile
Re: Design - Layouts not Updating
« Reply #13 on: May 22, 2013, 06:21:50 AM »
I decided to explore a bit further - and see if there are any more clues to where the problem lies.

I added a category and a product to see if that part of the system would work. I was able to add them once the first reported issue had been resolved (see topic "Add Product" on the Fresh Installation board) by provision of a proper function instead of a call to unix one that doesn't exist on a windows server.

I then went to the Shop Front Home Page and expected to see the category that is automatically installed appear in the category box together with the category I created. I also expected the product to show up on the page. These expectations are not unreasonable. Neither appeared and the page stubbornly displayed the exact information it did when when first installed: category box no entries, no product on view. The product is, incidentally, flagged as 'featured' and failed to be shown there either.

As an experiment I changed the language setting from English to Spanish. Wow! - the product was displayed and the categories were listed and the product appeared in the featured panel. Change it back to English - and the entries all disappeared again.

This might give you a clue as to where to start looking for the solution to the problem of the system not working and your actions to solve the problem instead of nit-picking.

As for claims of 'no evidence' - read the above again and again. If the failure of the entered categories and products to appear on the shop front isn't clear evidence of a serious dysfunction then what is?



Offline abolabo

  • core-developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 1744
  • Karma: +235/-10
  • web for all, all for web!
    • View Profile
    • AbanteCart
Re: Design - Layouts not Updating
« Reply #14 on: May 22, 2013, 06:41:07 AM »
As an experiment I changed the language setting from English to Spanish. Wow! - the product was displayed and the categories were listed and the product appeared in the featured panel. Change it back to English - and the entries all disappeared again.

it's looks like you don't set up english variant of category name on admin side.
Please check language inside of edit form that usually placed on heading panel under header of page. We call it "content language switcher". It gives  a ability to you to regulate category list depending on interface language.

about claims. i'm sorry. I just want to be more meaningful discussion. :)
“No one is useless in this world who lightens the burdens of another.”
― Charles Dickens

 

Maternity Dress