Please help us to make AbanteCart Ideal Open Source Ecommerce Solution for everyone.

Support AbanteCart eCommerce

Author Topic: invoice link has backslash before url [solved]  (Read 144 times)

Offline Jimako

  • Newbie
  • *
  • Posts: 3
  • Karma: +1/-0
    • View Profile
invoice link has backslash before url [solved]
« on: September 03, 2019, 07:26:51 AM »
Hello,
I have installed store in the subdirectory.
I checked the store details, there is no backslash.

Everything works normally, only on invoice page link after the order is the wrong URL.

You can view your order details by going to the invoice page.

"\https:// " -  there is backslash before url.

Where to look? Thank you.
« Last Edit: September 03, 2019, 08:15:09 AM by Jimako »

Offline Basara

  • Administrator
  • Hero Member
  • *****
  • Posts: 4351
  • Karma: +204/-0
    • View Profile
Re: invoice link has backslash before url
« Reply #1 on: September 03, 2019, 07:36:19 AM »
Hello.
For storefront you can enable debug mode to see what controller and template (.tpl file) to edit
https://abantecart.atlassian.net/wiki/spaces/AD/pages/7569496/Debug#Debug-Templatedebug
“Chuck Norris is so amazing.”
― Mother Teresa

Offline Jimako

  • Newbie
  • *
  • Posts: 3
  • Karma: +1/-0
    • View Profile
Re: invoice link has backslash before url
« Reply #2 on: September 03, 2019, 08:14:50 AM »
Hi,
no, the problem was somewhere else.

With PDO enabled there is a problem with character %,  it was fixed with using amysqli connection.

But language xml is still loaded with \%  instead %, so this was parsed: 

Quote
You can view your order details by going to the <a href="\%s">invoice page</a>


Refresh didn't help. I had it manually change in language definitions (English).



Offline abolabo

  • core-developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 1782
  • Karma: +247/-11
  • web for all, all for web!
    • View Profile
    • AbanteCart
Re: invoice link has backslash before url
« Reply #3 on: September 04, 2019, 03:32:55 AM »
Hi,
no, the problem was somewhere else.

With PDO enabled there is a problem with character %,  it was fixed with using amysqli connection.

But language xml is still loaded with \%  instead %, so this was parsed: 

Quote
You can view your order details by going to the <a href="\%s">invoice page</a>

can you open phpMyAdmin and check collation of table language_definitions and it's columns?
It must be utf8_general_ci

Refresh didn't help. I had it manually change in language definitions (English).
“No one is useless in this world who lightens the burdens of another.”
― Charles Dickens

 

Powered by SMFPacks Social Login Mod