Author Topic: Upgrade from 1.2.13 to 1.2.14 error  (Read 994 times)

Offline ehon

  • Newbie
  • *
  • Posts: 14
  • Karma: +0/-0
    • View Profile
Upgrade from 1.2.13 to 1.2.14 error
« on: November 12, 2019, 09:22:54 AM »
Hi, I wanted upgrade my website from 1.2.13 to 1.2.14. auto upgrade from link didn't work (but I could do from 1.2.12 to 1.2.13),
I got this error log.

database error: AbanteCart core v.1.2.13 SQL Error: Table 'ehoncana_v1.reviews' doesn't exist
Error No: 1146
SQL: SELECT DISTINCT *,
pd.name AS name,
m.name AS manufacturer,
ss.name AS stock_status,
stock_checkout,
lcd.unit as length_class_name, ( SELECT AVG(r.rating)
FROM reviews r
WHERE p.product_id = r.product_id AND status = 1
GROUP BY r.product_id
) AS rating , COALESCE( ( SELECT p2sp.price
FROM product_specials p2sp
WHERE p2sp.product_id = p.product_id
AND p2sp.customer_group_id = '1'
AND ((p2sp.date_start = '0000-00-00' OR p2sp.date_start < NOW())
AND (p2sp.date_end = '0000-00-00' OR p2sp.date_end > NOW()))
ORDER BY p2sp.priority ASC, p2sp.price ASC LIMIT 1
) , p.price) as final_price FROM products p
LEFT JOIN product_descriptions pd
ON (p.product_id = pd.product_id
AND pd.language_id = '1')
LEFT JOIN products_to_stores p2s ON (p.product_id = p2s.product_id)
LEFT JOIN manufacturers m ON (p.manufacturer_id = m.manufacturer_id)
LEFT JOIN stock_statuses ss
ON (p.stock_status_id = ss.stock_status_id
AND ss.language_id = '1') LEFT JOIN length_class_descriptions lcd
ON (p.length_class_id = lcd.length_class_id
AND lcd.language_id = '1')
WHERE p.product_id = '553'
AND p2s.store_id = '0'
AND p.date_available <= NOW() AND p.status = '1' in <b>/home/ehoncana/public_html/core/database/amysqli.php</b> on line <b>109</b>

So I tried by manually.
some files couldn't transfer (always same 107 files)

For example:
Error: Failed to open "C:\Users\Yuko\Downloads\abantecart_1.2.14_upgrade_only.tar\abantecart_1.2.14_upgrade_only\abantecart_1.2.14_upgrade_only\code\extensions\default_authorizenet\vendor\authorizenet\authorizenet\lib\net\authorize\api\controller\CreateCustomerPaymentProfileController.php" for reading
Error: File transfer failed

then I asked my host server, then they said they have this problem below.

[ehoncana@nw3 public_html]$ mysql -uehoncana_v1 -p ehoncana_v1 < upgrade.sql
Enter password:
ERROR 1054 (42S22) at line 1: Unknown column 'title' in 'store_descriptions'

I thought to replace "ac_" to empty, but it wasn't the problem...
Please give me some advice...
Thank you.

Offline ehon

  • Newbie
  • *
  • Posts: 14
  • Karma: +0/-0
    • View Profile
Re: Upgrade from 1.2.13 to 1.2.14 error
« Reply #1 on: November 13, 2019, 02:45:47 PM »
I downloaded again 1.2.14 files and did upload files. This time I got failed files only 2.
I tried to sql file run in phpmyAdmin and get error message...

ERROR 1054 (42S22) at line 1: Unknown column 'title' in 'store_descriptions'

Then I added column by manually.
Then I got this messages.

 Warning: #1101 BLOB, TEXT, GEOMETRY or JSON column 'description' can't have a default value

I don't know why so many problem...
Since I didn't do manually from 1.2.12 to 1.2.13, so it should be easily upgrade from link...
Please someone give some advices...

Thank you.

Offline ehon

  • Newbie
  • *
  • Posts: 14
  • Karma: +0/-0
    • View Profile
Re: Upgrade from 1.2.13 to 1.2.14 error
« Reply #2 on: November 15, 2019, 11:59:10 AM »
I installed new abantecart and transfer files I need.
So far it looks working.
Hope no more issue...

Offline Basara

  • Administrator
  • Hero Member
  • *****
  • Posts: 4662
  • Karma: +241/-2
    • View Profile
Re: Upgrade from 1.2.13 to 1.2.14 error
« Reply #3 on: November 18, 2019, 12:24:01 AM »
I installed new abantecart and transfer files I need.
So far it looks working.
Hope no more issue...

Hello. Transfer files will not copy your products data

 

Powered by SMFPacks Social Login Mod