Author Topic: Upgrade from 1.2.15 to 1.2.16 error  (Read 1159 times)

Offline bonus

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
    • View Profile
Upgrade from 1.2.15 to 1.2.16 error
« on: May 16, 2020, 11:53:15 AM »
I click on the upgrade link given in the admin notice and accepted the risk of the upgrade.
The page when blank
Then the error "Parse error: syntax error, unexpected ':', expecting ';' or '{' in /home/onlinesr/public_html/test3/core/lib/PaymentHandlerInterface.php on line 22" when I try to access my site.

What's wrong?
Luckily it was a plain vanilla test site which I've installed from cpanel just a day before.

Offline MrTim

  • Newbie
  • *
  • Posts: 4
  • Karma: +1/-0
    • View Profile
Re: Upgrade from 1.2.15 to 1.2.16 error
« Reply #1 on: May 17, 2020, 08:47:06 AM »
I have this same problem, but unfortunately this is my eCommerce site. I hope there will be a fix for this shortly.

Offline MrTim

  • Newbie
  • *
  • Posts: 4
  • Karma: +1/-0
    • View Profile
Re: Upgrade from 1.2.15 to 1.2.16 error
« Reply #2 on: May 17, 2020, 10:16:42 AM »
I checked PaymentHandlerInterface.php both current file and the backup file. They are the same.
Looked at the error log and it shows the same error.

2020-05-17 12:36:26 - parsing error:  AbanteCart core v.1.2.16 syntax error, unexpected ':', expecting ';' or '{' in <b>/home/ivystone/public_html/AbanteCart/core/lib/PaymentHandlerInterface.php</b> on line <b>22</b>

Line 22 ends with ";"

Any help would be greatly appreciated.

Offline Russell37uk

  • Newbie
  • *
  • Posts: 10
  • Karma: +2/-0
    • View Profile
Re: Upgrade from 1.2.15 to 1.2.16 error
« Reply #3 on: May 17, 2020, 02:03:32 PM »
Same error here but with a completely fresh install of v 1.2.16

Fresh install, due to the other mentioned issue of a completely blank screen when using the upgrade link from 1.2.15

Offline Russell37uk

  • Newbie
  • *
  • Posts: 10
  • Karma: +2/-0
    • View Profile
Re: Upgrade from 1.2.15 to 1.2.16 error
« Reply #4 on: May 17, 2020, 03:24:27 PM »
I have this same problem, but unfortunately this is my eCommerce site. I hope there will be a fix for this shortly.

Same here, I accepted the risk updating a 'live' site as business is very slow at the moment.

Thought i'd broke it so done a completely fresh install of 1.2.16 and had the exact same problem

AbanteCart core v.1.2.16 syntax error, unexpected ':', expecting ';' or '{' in <b>/home/ivystone/public_html/AbanteCart/core/lib/PaymentHandlerInterface.php</b> on line <b>22</b>

Line 22 ends with ";"


Offline Nuno Neff

  • Newbie
  • *
  • Posts: 27
  • Karma: +7/-0
    • View Profile
Re: Upgrade from 1.2.15 to 1.2.16 error
« Reply #5 on: May 17, 2020, 06:45:41 PM »
I tried to upgrade from 1.1.15  to new version and it does not work

Offline rightonjoe

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
Re: Upgrade from 1.2.15 to 1.2.16 error
« Reply #6 on: May 18, 2020, 12:32:17 AM »
Same story here, I updated a live site and it went blank white.
I suspect is that the database prefix may have changed but it didn't update somewhere but I'm not exactly sure. Just a hunch for anyone with knowledge that can verify.

Offline abolabo

  • core-developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 1816
  • Karma: +264/-11
  • web for all, all for web!
    • View Profile
    • AbanteCart
Re: Upgrade from 1.2.15 to 1.2.16 error
« Reply #7 on: May 18, 2020, 04:17:55 AM »
What php version do you use?

Please try to replace your file core/lib/PaymentHandlerInterface.php with attached
 
“No one is useless in this world who lightens the burdens of another.”
― Charles Dickens

Offline Russell37uk

  • Newbie
  • *
  • Posts: 10
  • Karma: +2/-0
    • View Profile
Re: Upgrade from 1.2.15 to 1.2.16 error
« Reply #8 on: May 18, 2020, 04:32:03 AM »
What php version do you use?

Please try to replace your file core/lib/PaymentHandlerInterface.php with attached

I am using PHP version 7.3 (i think),  indecently the replacement file provided worked for me and can now see my website, although i did have to reset password for admin access as i wasn't recognized as a user!

Offline MrTim

  • Newbie
  • *
  • Posts: 4
  • Karma: +1/-0
    • View Profile
Re: Upgrade from 1.2.15 to 1.2.16 error
« Reply #9 on: May 18, 2020, 06:59:13 AM »
What php version do you use?

Please try to replace your file core/lib/PaymentHandlerInterface.php with attached

I checked the file against the one in use and they are the same. I did replace the file as suggested but it did not make any difference. I still get the same error message.

Offline rightonjoe

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
Re: Upgrade from 1.2.15 to 1.2.16 error
« Reply #10 on: May 18, 2020, 11:26:01 PM »
What php version do you use?

Please try to replace your file core/lib/PaymentHandlerInterface.php with attached

I am using PHP version 7.3 (i think),  indecently the replacement file provided worked for me and can now see my website, although i did have to reset password for admin access as i wasn't recognized as a user!

I changed my PHP to version 7.3 and replaced the file and now mine works too. Thanks!

Offline MrTim

  • Newbie
  • *
  • Posts: 4
  • Karma: +1/-0
    • View Profile
Re: Upgrade from 1.2.15 to 1.2.16 error
« Reply #11 on: May 19, 2020, 07:52:14 AM »
I updated my PHP version to 7.2 and my site came back up. No need to replace any files.
Thanks everyone for the input.

 

Powered by SMFPacks Social Login Mod