Author Topic: Stripe payments no longer working since update  (Read 327 times)

Offline barry819

  • Newbie
  • *
  • Posts: 31
  • Karma: +3/-0
    • View Profile
Stripe payments no longer working since update
« on: May 21, 2020, 04:51:32 PM »
My Stripe payments are no longer working. I upgraded from 1.2.15 to 1.2.16, and now on my checkout page, the box for the customer to type in the name on their card is editable, but hte box for the card number is not, it is compressed flat (like the editable part has been removed, so the border collapsed.

I've tried reconnecting to Stripe, and that appears to work fine, but it doesn't fix the problem on the checkout page.

Offline llegrand

  • Hero Member
  • *****
  • Posts: 1535
  • Karma: +413/-3
    • View Profile
Re: Stripe payments no longer working since update
« Reply #1 on: May 21, 2020, 04:58:06 PM »
are you using Stripe default?  or Stripe extensions in MarketPlace?
If the extension  have you updated to latest version ?


Offline barry819

  • Newbie
  • *
  • Posts: 31
  • Karma: +3/-0
    • View Profile
Re: Stripe payments no longer working since update
« Reply #2 on: May 21, 2020, 05:02:57 PM »
I'm using the Stripe default 1.0.1, which was working fine prior to the upgrade. I processed an order yesterday just fine, before the upgrade was done.

Offline barry819

  • Newbie
  • *
  • Posts: 31
  • Karma: +3/-0
    • View Profile
Re: Stripe payments no longer working since update
« Reply #3 on: May 21, 2020, 05:05:49 PM »
I found this in the error log:

2020-05-21 15:02:22 - App Warning: AbanteCart core v.1.2.16 Warning: Accessing store with non-configured or unknown domain ( mail.theresamatherfantasyshop.com/dir/ ).
Check setting of your store domain URL in System Settings. Loading default store configuration for now. in /home/shortfor/public_html/TheresaMatherFantasyShop.com/dir/core/lib/config.php on line 228

I do not know what this is or how to fix it.

Offline barry819

  • Newbie
  • *
  • Posts: 31
  • Karma: +3/-0
    • View Profile
Re: Stripe payments no longer working since update
« Reply #4 on: May 21, 2020, 05:09:59 PM »
Here is my Store Details screen, which does not seem to correspond to what the error says.

Offline barry819

  • Newbie
  • *
  • Posts: 31
  • Karma: +3/-0
    • View Profile
Re: Stripe payments no longer working since update
« Reply #5 on: May 21, 2020, 05:28:43 PM »
To be clear, I am connected to Stripe "Live".

My memory says that this has something to do with something that has to be turned "on" but I cannot recall what that is. I have tried everything I can think of and cannot find any place that is not activated.

Offline barry819

  • Newbie
  • *
  • Posts: 31
  • Karma: +3/-0
    • View Profile
Re: Stripe payments no longer working since update
« Reply #6 on: May 21, 2020, 05:42:31 PM »
OK, tried something different. I deactivated Stripe and turned on Paypal payments. But now When I reload the Payment page on the site, I get

Error: Payment method required!

So  something seems to be blocking my payment methods no matter what they are.

Offline Basara

  • Administrator
  • Hero Member
  • *****
  • Posts: 4581
  • Karma: +224/-0
    • View Profile
Re: Stripe payments no longer working since update
« Reply #7 on: May 22, 2020, 01:13:30 AM »
Hello.
Clean AbanteCart caches and your browser cache. Try again with the opened browser console and see is any errors on the page with stripe inputs, and check the errors in AbanteCart error log
“Chuck Norris is so amazing.”
― Mother Teresa

Offline abolabo

  • core-developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 1817
  • Karma: +266/-11
  • web for all, all for web!
    • View Profile
    • AbanteCart
Re: Stripe payments no longer working since update
« Reply #8 on: May 22, 2020, 03:06:46 AM »
To be clear, I am connected to Stripe "Live".

My memory says that this has something to do with something that has to be turned "on" but I cannot recall what that is. I have tried everything I can think of and cannot find any place that is not activated.

Please check your ssl url of store in the settings (system-> settings->store details). Stripe will not work on non-secure connections
“No one is useless in this world who lightens the burdens of another.”
― Charles Dickens

Offline user88

  • Jr. Member
  • **
  • Posts: 68
  • Karma: +11/-0
    • View Profile
    • Visit my website
Re: Stripe payments no longer working since update
« Reply #9 on: June 05, 2020, 04:51:24 PM »
Hi all,

I did an upgrade from 1.2.15 to 1.2.16 on a staged website and had same error with Stripe. Checked store url in store settings and noticed AbanteCart upgrade changed url from https to http. I then modified to https and clicked save and got error message. See image.

No idea what changed, because on 1.2.15 AbanteCart allowed me to save my https address.

Any thoughts?

Offline llegrand

  • Hero Member
  • *****
  • Posts: 1535
  • Karma: +413/-3
    • View Profile
Re: Stripe payments no longer working since update
« Reply #10 on: June 05, 2020, 05:48:32 PM »
Hi User 88  ,  I see you have a /staged url install.  I am assuming you used  Softaculous Staging to test.   If you don't pay close attention when cloning or staging in Softaculous you can miss setting the protocol  to the desired setting.  the default always show up at http:/  and you need to use the dropdown to select the https://

Offline Basara

  • Administrator
  • Hero Member
  • *****
  • Posts: 4581
  • Karma: +224/-0
    • View Profile
Re: Stripe payments no longer working since update
« Reply #11 on: June 08, 2020, 01:22:03 AM »
Hello. The default stripe in 1.2.16 have known issue and it is already resolved in 1.2.17 check this solution
http://forum.abantecart.com/index.php/topic,8524.msg33876.html#msg33876

new stripe with fixes
https://github.com/abantecart/abantecart-src/files/4715023/default_stripe_v1.0.5.tar.gz
“Chuck Norris is so amazing.”
― Mother Teresa

Offline user88

  • Jr. Member
  • **
  • Posts: 68
  • Karma: +11/-0
    • View Profile
    • Visit my website
Re: Stripe payments no longer working since update
« Reply #12 on: June 08, 2020, 05:19:50 PM »
Thanks Ilegrand. Redid staging using https and now AbanteCart store settings show https address.

I have upgraded both a staging version and a clone version to 1.2.16 and applied the stripe udpate, but I still have the same problem with stripe not working.

A look at my error log page revealed this (see image). Don't know if this is related or not.

Thanks for your support

Offline llegrand

  • Hero Member
  • *****
  • Posts: 1535
  • Karma: +413/-3
    • View Profile
Re: Stripe payments no longer working since update
« Reply #13 on: June 08, 2020, 06:02:17 PM »
there is a known issue with Stripe and there is a new version  that is indicated to fix it.

The info and the patch file  is in this Post -  scroll down a ways to the reply  from Basara Reply #6 on: June 02, 2020, 12:58:20 AM

https://forum.abantecart.com/index.php/topic,8485.msg33825.html#msg33825


 

Powered by SMFPacks Social Login Mod