Author Topic: Can't seem to get multiple stores to work correctly  (Read 341 times)

Offline fdangelo

  • Newbie
  • *
  • Posts: 17
  • Karma: +4/-1
    • View Profile
Can't seem to get multiple stores to work correctly
« on: June 08, 2020, 06:29:36 PM »
Hi All,
I've looked around and can't find a similar problem, but I hope someone can help.
I believe I've got myself turned around and the answer may be right in front of me, but I can't see it.

I started developing my store, leaving it named "default".
Then I wanted to open a new store, which is a sub-set of "default" and called it "BCM".
My intention was to simply assign the product categories to one or the other.
I created the BCM store, and set up a subdomain as instructed.
Then I lost access to "default", but the BCM store looked just as I expected.
I deleted the BCM store, and "default" came back.

Then I thought, how about having "default" act as the main holder of all system wide attributes and assign them to the appropriate store as needed. I do need to eventually have 3 stores: THL, BCM and MYN.

I recreated BCM, then created THL (leaving MYN for later).
I assigned the product categories, but now all three stores: "default", THL and BCM look the same.
As they should, because when I click on "View the store" the URL comes up the same: "https://www.dnwbus.com/newdnw.dnwbus.com/"
Attached are some screen shots of C-Panel and the store attributes.

At this point, I am just so confused.

Offline Basara

  • Administrator
  • Hero Member
  • *****
  • Posts: 4663
  • Karma: +241/-2
    • View Profile
Re: Can't seem to get multiple stores to work correctly
« Reply #1 on: June 09, 2020, 05:56:37 AM »
Hello.

The subdomains paths should go to /public_html/ directory.
Default store url should be https://www.dnwbus.com/
The new store urls should be https://newdnw.dnwbus.com/

Offline fdangelo

  • Newbie
  • *
  • Posts: 17
  • Karma: +4/-1
    • View Profile
Re: Can't seem to get multiple stores to work correctly
« Reply #2 on: June 10, 2020, 06:04:06 PM »
Thanks for your help, but I'm sorry, I just don't get it.
Perhaps you're saying that this is how I should have installed it?

The software is already installed as depicted in the screen images above.

I've gone through every combination of URLs and paths and I still get the default store.
I would like to show you how I understand it, and perhaps you can point out my error(s).

This is what I have now:
Main URL:  www.dnwbus.com (but there is no web access to the stores yet).

1. Default store:
Sub domain:  newdnw.dnwbus.com
Sub domain directory path: /public_html/newdnw.dnwbus.com/
Contains directory 'storefront' and all other directories consistent with AbanteCart naming (so, this is the place)
AbanteCart URL specific to the default store: https://www.dnwbus.com/newdnw.dnwbus.com/

2. BCM store
Sub domain: bcm.newdnw.dnwbus.com
Sub domain directory path: /public_html/newdnw.dnwbus.com/bcm
Only contains sub-directory 'cgi-bin'
In the store setup, the URL for the BCM store is: http://dnwbus.com/newdnw.dnwbus.com/bcm
and also tried: http://dnwbus.com/newdnw.dnwbus.com/bcm.newdnw.dnwbus.com
and also tried: https://dnwbus.com/bcm.newdnw.dnwbus.com/
And it always goes to the default store.

Thoughts?

 

Powered by SMFPacks Social Login Mod