Author Topic: Tables not reading database??? HELP  (Read 155 times)

Offline gear259

  • Newbie
  • *
  • Posts: 4
  • Karma: +0/-0
    • View Profile
Tables not reading database??? HELP
« on: October 10, 2020, 06:37:02 AM »
Hi everyone, I hope this is an easy fix.  I'm a new user for a start so don't assume i know anything.

I have a new installation up, generated with softaculous.  The problem im having is that from within my admin panel the tables? as i call it that control things such as products, orders, customers, users, groups and so on are not displaying the data therein.  I've confirmed that if i create a new user, customer or group from the admin panel, it does indeed seem to create the correct entry in phpmyadmin. However, it seems that there is something blocking the admin panel from retrieving the data. 

I've spent about 6 hours trying to figure this out and im no futher on.  If its a permission issue please be specific in what it should be.  I have checked logs and its giving me nothing.

Offline maxter

  • Full Member
  • ***
  • Posts: 172
  • Karma: +59/-0
    • View Profile
Re: Tables not reading database??? HELP
« Reply #1 on: October 10, 2020, 07:00:50 AM »
Welcome to Abantecart gear259!

You might have one of below two issues:

1. If you have multiple stores setup, make sure you have a correct store selected in the admin. There is a store selector in the top right corner.
Customers, products, etc are created per store.

3. Abantecart cache is not cleared.
Try to clear the cache
https://abantecart.atlassian.net/wiki/spaces/AD/pages/14483758/Cache
If this does not help, you might have permission issue on the files/directories
folder files under .../system/cache/... should be writable for a user running a web server.

Note. It is not recommended to make changes in database (phpmyadmin) directly, unless you know what you doing.
« Last Edit: October 10, 2020, 07:02:27 AM by maxter »

Offline maxter

  • Full Member
  • ***
  • Posts: 172
  • Karma: +59/-0
    • View Profile
Re: Tables not reading database??? HELP
« Reply #2 on: October 10, 2020, 07:02:40 AM »
Welcome to Abantecart gear259!

You might have one of below two issues:

1. If you have multiple stores setup, make sure you have a correct store selected in the admin. There is a store selector in the content top right corner.
Customers, products, etc are created per store.

3. Abantecart cache is not cleared.
Try to clear the cache
https://abantecart.atlassian.net/wiki/spaces/AD/pages/14483758/Cache
If this does not help, you might have permission issue on the files/directories
folder files under .../system/cache/... should be writable for a user running a web server.

Note. It is not recommended to make changes in database (phpmyadmin) directly, unless you know what you doing.

Offline gear259

  • Newbie
  • *
  • Posts: 4
  • Karma: +0/-0
    • View Profile
Re: Tables not reading database??? HELP
« Reply #3 on: October 10, 2020, 07:22:56 AM »
Hi Maxter

Thanks for the quick reply!

As per, I have only the 1 'default' store and ive cleared the cache via the clear cache tab and selected all.

Im leaning towards your theory on a file permission issue...  is that something i fix in cpanel? terminal? php?

Much appreciated

Offline gear259

  • Newbie
  • *
  • Posts: 4
  • Karma: +0/-0
    • View Profile
Re: Tables not reading database??? HELP
« Reply #4 on: October 10, 2020, 07:40:46 AM »
Going through Cpanel I think the directory your referring to is set to 0755.  Is this correct?

Offline gear259

  • Newbie
  • *
  • Posts: 4
  • Karma: +0/-0
    • View Profile
Re: Tables not reading database??? HELP
« Reply #5 on: October 10, 2020, 09:35:20 AM »
Now found this error in log. Is it relevant?
warning: AbanteCart core v.1.2.16 Invalid argument supplied for foreach() in <b>/home/xxxxxxxx/public_html/admin/model/tool/updater.php</b> on line <b>131</b>

Offline Basara

  • Administrator
  • Hero Member
  • *****
  • Posts: 4663
  • Karma: +241/-2
    • View Profile
Re: Tables not reading database??? HELP
« Reply #6 on: October 12, 2020, 01:04:02 AM »
Hello.
Did you check the browser console for javascript issues?

Offline maxter

  • Full Member
  • ***
  • Posts: 172
  • Karma: +59/-0
    • View Profile
Re: Tables not reading database??? HELP
« Reply #7 on: October 12, 2020, 08:05:11 AM »
755 permissions are OK as long as linux user is the same as user running your webserver.

I think cusomers and users are not cached, so if you create user or register a customer you should see thouse.

 

Powered by SMFPacks Social Login Mod