Author Topic: File Upload  (Read 4405 times)

Offline Evolution

  • Newbie
  • *
  • Posts: 19
  • Karma: +2/-0
    • View Profile
    • Voltisoft
File Upload
« on: July 25, 2013, 04:09:15 PM »
Hi,

I'm trying to upload an archive file and it's 2.11MB.

When I upload it, it says max_fileupload_size in php.ini is 2M.

When I go to /store/php.ini it says
max_fileupload_size 100M

I tried changing it to 5MB, 200M, 200MB, 500M, 500MB, etc. Still says max: 2M.

Then I go to php.ini in /public_html and change things, same thing.

Any help please?

Offline abantecart

  • Administrator
  • Hero Member
  • *****
  • Posts: 4150
  • Karma: +251/-9
    • View Profile
    • Ideal Open Source Ecommerce Solution
Re: File Upload
« Reply #1 on: July 25, 2013, 05:03:51 PM »
If you try to add file to resource library, check setting in Settings -> System "Resource Library Upload Max File Size, kB"


Try to run phpinfo in any new file and see what you have for max file upload.

<?php
phpinfo();
?>

/store/php.ini my not be allowed by your hosting and it is not loaded.

We need your help to build better free open source eCommerce platform for everyone.
See how you can help

Offline Evolution

  • Newbie
  • *
  • Posts: 19
  • Karma: +2/-0
    • View Profile
    • Voltisoft
Re: File Upload
« Reply #2 on: July 25, 2013, 05:49:55 PM »
Thanks for replying.

In the AbanteCart settings it is set to 16000kb (15.625MB), and in php.ini it is set to 100M, and in php.info it says upload_max_filesize=100M.
This has been confirmed with the host tech. support.

But, when uploading archive to resource for download it says 2M max :/

Offline abantecart

  • Administrator
  • Hero Member
  • *****
  • Posts: 4150
  • Karma: +251/-9
    • View Profile
    • Ideal Open Source Ecommerce Solution
Re: File Upload
« Reply #3 on: July 25, 2013, 10:03:37 PM »
How about post_max_size in php.ini?

Do you have any  php_value upload_max_filesize or php_value post_max_size in .htaccess?
We need your help to build better free open source eCommerce platform for everyone.
See how you can help

Offline Evolution

  • Newbie
  • *
  • Posts: 19
  • Karma: +2/-0
    • View Profile
    • Voltisoft
Re: File Upload
« Reply #4 on: July 27, 2013, 02:04:18 PM »
post_max_size reads 8M in php.ini,

there are no php_value, upload_max_filesize, post_max_size in /public_html/.htaccess or /public_html/store/.htaccess


Offline calbashmc

  • Jr. Member
  • **
  • Posts: 52
  • Karma: +8/-0
    • View Profile
Re: File Upload
« Reply #5 on: December 08, 2013, 11:17:16 PM »
Did you ever get this sorted because I am experiencing the same issue.  Trying to import products.csv which is about 2.2Mb.  php.ini is set to 100M.

Offline junkyard

  • Full Member
  • ***
  • Posts: 127
  • Karma: +24/-0
    • View Profile
Re: File Upload
« Reply #6 on: December 09, 2013, 03:08:24 AM »
hi,   upload_max_filesize = 2M is a default setting in server PHP5..  so it seems there's a php.ini somewhere up above spoiling this for you.
If your having a hosting control panel from hoster, try and check something like "php configuration" in there. 
Perhaps, the hoster's tech support needs to recheck it because it all appears as if the hoster's (and abantecart's) settings get overriden by the server itself.

Abantecart's  /public_html/php.ini  (or any other php.ini below /public_html/) should override similar PHP settings from other php.ini files above public_html, if this file is accessible for the web server.  So it could be one of the settings mentioned in
  http://forum.abantecart.com/index.php/topic,1265.15.html

Is it the same error/size if you try to upload a test file in admin via the Catalog > Downloads section?
Are there any specific errors written in  /public_html/system/logs/error.txt  when you try to upload it.

We just saw a bugfix called "Fixed validation of the max size of the uploaded file" mentioned here:
 http://www.abantecart.com/shopping-cart-news/118-abantecart-new-version-117
Could it be that it started happening after upgrade?  or it is 1.1.6 and all your previous CSV's were smaller so it didn't happen?

Cheers

Offline calbashmc

  • Jr. Member
  • **
  • Posts: 52
  • Karma: +8/-0
    • View Profile
Re: File Upload
« Reply #7 on: December 10, 2013, 02:05:01 AM »
Ah, it was a change in the setting in php.ini for me that fixed this.
The php.ini file that comes with abantecart has
max_upload_filesize = 100M

it should read
upload_max_filesize = 100M


Offline junkyard

  • Full Member
  • ***
  • Posts: 127
  • Karma: +24/-0
    • View Profile
Re: File Upload
« Reply #8 on: December 10, 2013, 12:44:17 PM »
Pretty spiffy!  it will be a bug of the day

 

Powered by SMFPacks Social Login Mod