Show Posts


Messages - hislordship

Pages: [1]
1
How-to questions / Re: Missing Link?
« on: July 26, 2018, 05:06:59 AM »
Thank you, clears that up for me

2
How-to questions / Missing Link?
« on: July 26, 2018, 03:18:14 AM »
Hello.
Please have a look at my work website http://www.tjn.co.za

On the home page I have the SPECIALS | FEATURED | NEW PRODUCTS blocks showing.

Now I am wondering if the heading should be a link.
For example SPECIALS See Products On Sale is showing but there is no link to anywhere to see all products on special.

Is this normal or should there be a link?
If a link, why is it not working? I have SEO links on and working (see any product or category and it works.

Thank you for your help!

3
How-to questions / Re: Product price based on global attributes
« on: July 23, 2018, 04:11:34 AM »
Thank you. That would be great to have as option.
Have a look at Zencart, from what I remember it is an option they have.

4
How-to questions / Product price based on global attributes
« on: July 19, 2018, 06:24:22 AM »
Hello

Is there a trick to have a product price based on default global attributes? Example:

* Small size = $5.00
Medium = $6.00
Large = $7.00

Personalise:
* No = $0.00
Yes = $2.00

* is the default option.

So the actual product price is set to $0.00 and the two default options would add up to make a price.
On the main home page or even in the product page, it will show the price as $0.00 and not add the size price of $5.00.
It only shows on the product page under Total Price.

Any help would be great.
Thank you :-)

5
Built-in Features / Re: Multiple Product attributes setting
« on: July 12, 2018, 07:14:07 AM »
Hello.

Same problem here.
I want to offer clients the following:

MEDAL COLOUR:
GOLD
SILVER
BRONZE

RIBBON COLOUR:
BLACK
WHITE
RED
YELLOW
BLUE
GREEN
... and so on

I can list these options but if I include attribute images, then it will either show a picture of (for example) a gold medal or a picture of a red ribbon.

The only workaround is to have options as:
GOLD MEDAL WITH RED RIBBON
SILVER MEDAL WITH RED RIBBON
BRONZE MEDAL WITH RED RIBBON
GOLD MEDAL WITH BLUE RIBBON
SILVER MEDAL WITH BLUE RIBBON
BRONZE MEDAL WITH BLUE RIBBON

and so on.

Is there a way to have the global images show up with multiple images?
So a gold medal and underneath is a red ribbon?

6
How-to questions / Re: Permanent Redirect Issues
« on: June 08, 2018, 06:21:16 AM »
.htaccess file is as follows:

# 1. To use URL Aliases you need to be running apache with mod_rewrite enabled.

# 2. In your abantecart main directory rename file htaccess.txt to .htaccess

# 3. Edit file .htaccess. If abantecart is installed in yourdomain/ subfolder change configuration line  RewriteBase /  to  RewriteBase /subfolder/.
# Example:  yourdomain.com/store   use RewriteBase /store/
# Important to have / at the end of the line.

# 4. if htaccess and mode_rewrite still does not works - check and set apache2 webserver directive AllowOverride All for your virtual hosts

# For any support issues please visit: http://forum.abantecart.com

Options +FollowSymlinks

# Prevent Directory listing
Options -Indexes

# Prevent Direct Access to files
<FilesMatch "\.tpl">
Order deny,allow
Deny from all
</FilesMatch>

RewriteEngine on

# Rewrite section for retina high-res images with @2x in the end of filename base on cookie HTTP_IS_RETINA
# To emulate Retina mode on your NON-Retina display, add HTTP_IS_RETINA cookie in your browser
RewriteCond %{HTTP_COOKIE} HTTP_IS_RETINA [NC]
RewriteCond %{REQUEST_FILENAME} !@2x
RewriteRule ^(.*)\.(gif|jpg|jpeg|png)$ $1@2x.$2
# if @2x isn't available fulfill the original request
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule ^(.*)@2x\.(gif|jpg|jpeg|png)$ $1.$2

# SEO URL Settings
RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)\?*$ index.php?_route_=$1 [L,QSA]

# SITE PERFORMANCE TUNING #
# Browser Caching, Compression and Headers cache control
# This is to manage browser cache and improve site loading
# NOTE: If you do active development disable this as you will need to clear your browser cache manually

# Enable Compression
<IfModule mod_deflate.c>
  AddOutputFilterByType DEFLATE application/javascript
  AddOutputFilterByType DEFLATE application/rss+xml
  AddOutputFilterByType DEFLATE application/vnd.ms-fontobject
  AddOutputFilterByType DEFLATE application/x-font
  AddOutputFilterByType DEFLATE application/x-font-opentype
  AddOutputFilterByType DEFLATE application/x-font-otf
  AddOutputFilterByType DEFLATE application/x-font-truetype
  AddOutputFilterByType DEFLATE application/x-font-ttf
  AddOutputFilterByType DEFLATE application/x-javascript
  AddOutputFilterByType DEFLATE application/xhtml+xml
  AddOutputFilterByType DEFLATE application/xml
  AddOutputFilterByType DEFLATE font/opentype
  AddOutputFilterByType DEFLATE font/otf
  AddOutputFilterByType DEFLATE font/ttf
  AddOutputFilterByType DEFLATE image/svg+xml
  AddOutputFilterByType DEFLATE image/x-icon
  AddOutputFilterByType DEFLATE text/css
  AddOutputFilterByType DEFLATE text/html
  AddOutputFilterByType DEFLATE text/javascript
  AddOutputFilterByType DEFLATE text/plain
</IfModule>
<IfModule mod_gzip.c>
  mod_gzip_on Yes
  mod_gzip_dechunk Yes
  mod_gzip_item_include file .(html?|txt|css|js|php|pl)$
  mod_gzip_item_include handler ^cgi-script$
  mod_gzip_item_include mime ^text/.*
  mod_gzip_item_include mime ^application/x-javascript.*
  mod_gzip_item_exclude mime ^image/.*
  mod_gzip_item_exclude rspheader ^Content-Encoding:.*gzip.*
</IfModule>
# Leverage Browser Caching
<IfModule mod_expires.c>
  ExpiresActive On
  ExpiresByType image/jpg "access 1 year"
  ExpiresByType image/jpeg "access 1 year"
  ExpiresByType image/gif "access 1 year"
  ExpiresByType image/png "access 1 year"
  ExpiresByType text/css "access 1 month"
  ExpiresByType text/html "access 1 month"
  ExpiresByType application/pdf "access 1 month"
  ExpiresByType text/x-javascript "access 1 month"
  ExpiresByType application/x-shockwave-flash "access 1 month"
  ExpiresByType image/x-icon "access 1 year"
  ExpiresDefault "access 1 month"
</IfModule>
<IfModule mod_headers.c>
  Header set Connection keep-alive
  <filesmatch "\.(ico|flv|jpg|jpeg|png|gif|css|swf)$">
  Header set Cache-Control "max-age=2678400, public"
  </filesmatch>
  <filesmatch "\.(html|htm)$">
  Header set Cache-Control "max-age=7200, private, must-revalidate"
  </filesmatch>
  <filesmatch "\.(pdf)$">
  Header set Cache-Control "max-age=86400, public"
  </filesmatch>
  <filesmatch "\.(js)$">
  Header set Cache-Control "max-age=2678400, private"
  </filesmatch>
</IfModule>
RewriteCond %{HTTP_HOST} ^tjn\.co\.za$ [OR]
RewriteCond %{HTTP_HOST} ^www\.tjn\.co\.za$
RewriteCond %{REQUEST_URI} !^/[0-9]+\..+\.cpaneldcv$
RewriteCond %{REQUEST_URI} !^/\.well-known/pki-validation/[A-F0-9]{32}\.txt(?:\ Comodo\ DCV)?$
RewriteRule ^newsletter$ "http\:\/\/eepurl\.com\/cHBk" [R=301,L]


7
How-to questions / Re: Permanent Redirect Issues
« on: June 08, 2018, 05:54:13 AM »
Thank you for the reply.

My hosting company has replied as follows:

The difference from trophyjunction.co.za would be abantecart .htaccess rules present in tjn.co.za.
This seems to be disrupting the re-writes rules for newsletter redirect to mailchimp url.
You might have to consult a developer or abantecart support to resolve the apparent redirect conflict.

8
How-to questions / Permanent Redirect Issues
« on: May 24, 2018, 05:13:51 AM »
Hello

This is a new problem I'm having, never was an issue on Zencart so I am puzzled.

I want to redirect a specific URL for newsletter signups as follows:
tjn.co.za/newsletter => eepurl.com/cHBk

Done the redirect as a permanent redirect in CPanel but it doesn't work. I always end up at my Abantecart site with the error page.

Any suggestions?

9
How-to questions / Tax Included Message
« on: May 23, 2018, 03:23:31 AM »
Hello

I tried using AbanteCart feature Localization Taxes to show prices with tax included, but I end up with rounding errors compared to my Quickbooks system prices. So since I am only selling in this country with tax included I have deleted the tax rate and just have the prices shown.

What I need to do now is add a message that informs customers that all prices are inclusive of VAT.

Any suggestions?

10
General Support / Re: Where do I find ... ?
« on: February 19, 2018, 07:08:36 AM »
Funny, that is what I thought. But it doesn't work even though other things were imported with the database and they do work.

Ok, looks like I'll have to fix them manually rather.

11
General Support / Re: Where do I find ... ?
« on: February 13, 2018, 05:45:02 AM »
Thank you - I did read that BEFORE posting here.

Please re-read - I have done this differently to the link's method, so I need to know an answer to a simple question.
I can't go back to doing a backup as per their method, that isn't an option.

Surely layout/blocks are stored somewhere?
All I need to know is where.

12
General Support / Re: Where do I find ... ?
« on: February 12, 2018, 04:52:04 AM »
Thank you for the reply.

Do you know which folders though?
You see why I ask for this specifically is because I have copied some to the new host but not all.

So I suppose I should ask:
Which folders do I need to copy across when I want to move my Abantecart to a new host?
Using the backup method is not an option.
I only have the database as backup, the files/folder are only available as a direct FTP download from the old host.
Old hosting account doesn't exist any more/

13
General Support / Where do I find ... ?
« on: February 10, 2018, 07:30:42 AM »
Hello

I have moved my Abantecart installation to a new host using a slightly unorthodox method.
I backed up the database and FTP transferred the whole installation to my laptop.

On the new host it is now up and running, except that the Layouts are back to default.
Please tell me which folder or file this is stored under.
(Not admin console settings - I know where that is ).

Thank you

14
How-to questions / One Time Set-up Fee?
« on: October 10, 2017, 03:13:28 AM »
Good morning

I have tried searching for an option to do this but not having much success.

We sell trophies, medals etc.
When a customer purchases trophies from us, they want to add engraving on the trophies.
Sometimes this includes a company logo.
I have set it up as an option to add engraving, which is added per trophy ordered.
But for the logo, we charge a one-off fee to set up the logo.
Is it possible to have this fee added somewhere?
This fee should be added ONCE, not per trophy.
Preferably it should be once only per shopping session, so if they order another different trophy it doesn't charge the fee again.

Any ideas are greatly appreciated and thank you for your time to help me with this.

Pages: [1]