Show Posts


Messages - hani

Pages: [1] 2 3 ... 7
1
Built-in Features / Re: Product option images
« on: November 20, 2019, 10:43:11 AM »
Hi
Yes there was an issue with the extension and i reported that and it was fixed very quickly.

It is a very useful extension and i highly recommend it


2
General Support / Re: abantecart errors
« on: September 06, 2019, 01:53:06 AM »
No i don't notice any problems and i tested again now and checked the log errors and in the logs the message did not show up.
there is something strange don't know why the message comes up sometimes and sometimes no


3
General Support / Re: abantecart errors
« on: September 06, 2019, 12:42:06 AM »
Hi

I am still getting this error and i have debug disabled.

But i have noticed that this error comes up when an item is added to cart and i don't think that it is due to a bot possibly it is a bug in version 1.2.15

it is worth checking

4
General Support / Re: abantecart errors
« on: July 18, 2019, 05:33:55 AM »
Hi

what about the second error message a below is it also related to the server??

2019-07-05 0:30:46 - App Error: AbanteCart core v.1.2.15 Error: Error in data of page with controller: 'pages/product/product'. Please check for key_value present where key_param was set.
Requested URL: ://www.mydomain.com/r/product/product/addToCart&product_id=
Referer URL:
Trace:
#0 /home/XXXXXX/public_html/core/engine/layout.php on line 202
#1 /home/XXXXXX/public_html/core/engine/layout.php on line 109
#2 /home/XXXXXX/public_html/core/engine/page.php on line 101
#3 /home/XXXXXX/public_html/core/engine/router.php on line 176
#4 /home/XXXXXX/public_html/core/engine/router.php on line 80

 

5
General Support / abantecart errors
« on: July 06, 2019, 03:48:41 AM »
Hi

I have installed abantecart version 1.2.15 and i get the bellow errors in my log can anyone explain please what are these errors?

2019-07-04 11:58:46 - warning: AbanteCart core v.1.2.15 Error while sending QUERY packet. PID=2027823 in <b>/home/XXXXXXX/public_html/core/database/amysqli.php</b> on line <b>79</b>
2019-07-04 11:58:46 - database error: AbanteCart core v.1.2.15 SQL Error: MySQL server has gone away
Error No: 2006
SQL: DELETE FROM `abc_online_customers`
WHERE `date_added`< (NOW() - INTERVAL 1 HOUR) in <b>/home/XXXXXX/public_html/core/database/amysqli.php</b> on line <b>114</b>

2019-07-05 0:30:46 - App Error: AbanteCart core v.1.2.15 Error: Error in data of page with controller: 'pages/product/product'. Please check for key_value present where key_param was set.
Requested URL: ://www.mydomain.com/r/product/product/addToCart&amp;product_id=
Referer URL:
Trace:
#0 /home/XXXXXX/public_html/core/engine/layout.php on line 202
#1 /home/XXXXXX/public_html/core/engine/layout.php on line 109
#2 /home/XXXXXX/public_html/core/engine/page.php on line 101
#3 /home/XXXXXX/public_html/core/engine/router.php on line 176
#4 /home/XXXXXX/public_html/core/engine/router.php on line 80

Thanks

6
Built-in Features / Re: Product option images
« on: June 25, 2019, 01:49:39 AM »
Hi

I found the problem it is NOT from abantecart code, it is caused from the third party extension "Editor Enhancement with Image Manager"
Thanks for your help and i will contact the extension manager

7
Built-in Features / Re: Product option images
« on: June 24, 2019, 11:57:36 PM »
The images are uploaded in the media and also uploaded in product option page see attached images

9
Built-in Features / Re: Product option images
« on: June 24, 2019, 09:48:13 AM »
Yes it is in the default template also, sorry that i did not mention it in my post

10
Built-in Features / Product option images
« on: June 24, 2019, 08:17:56 AM »
Hello
In previous versions of abantecart, 1.2.13 and lower when a product has attributes and we assign an image for each attribute for example color attribute then on the storefront when the customer choose the color the image of the product will change.

On version 1.2.14 and also 1.2.15 this is not the case, that is, the image of the product does not change according to the customer choice. Is this a bug or i am missing something in the configurations

11
General Support / Re: W3C CSS and W3C HTML validation
« on: June 24, 2019, 12:55:57 AM »
Thanks for your reply
I purchased a third party template how can i updated my template CSS rules, shall i contact the template owner or is there a code i need to change??
I will also look in the forum if there is a reply on this issue

12
General Support / W3C CSS and W3C HTML validation
« on: June 22, 2019, 02:19:31 AM »
Hi

When i checked my site pages at the W3C validator for CSS and HTML there are together around 800 warnings, i thought possibly that these warnings are due to third party extensions so i put all extensions OFF and tested and the validation was more or less the same, which mostly means that it is most probably from the abantecart code.

Websites with no such warning may rank better on search engines and it is a good thing if these can be checked and fixed, please see the links below for errors and warnings

https://validator.w3.org/nu/?doc=https%3A%2F%2Fwww.bethlehemcasting.com%2Fsaint-michael-keychain

http://jigsaw.w3.org/css-validator/validator?uri=https%3A%2F%2Fwww.bethlehemcasting.com%2Fsaint-michael-keychain&profile=css3&usermedium=all&warning=1

Regards

13
General Support / Re: 2checkout multistore issue
« on: June 06, 2019, 06:22:47 AM »
Hi
I have https://www.bethlehemcasting.com/ as the main store and a wholesale store with the subdomain https://wholesale.bethlehemcasting.com/ note the word "wholesale" in the begining

Hani

14
General Support / Re: 2checkout multistore issue
« on: June 06, 2019, 03:13:57 AM »
Thank you for your prompt reply

Let me see if i understood you correctly, You mean that i need to configure 2checkout to the subdomain??

and if so the approved URL for the subdomain will be https://SUBDOMAIN.COM/index.php?rt=checkout/success and the INS URL will be
https://SUBDOMAIN.COM/index.php?rt=extension/2checkout/callback

15
General Support / 2checkout multistore issue
« on: June 06, 2019, 02:13:30 AM »
Hello

I have a multistore site, the domain https://www.bethlehemcasting.com and subdomain https://wholesale.bethlehemcasting.com for wholesale.

When a sale is made at the main domain and processed with 2checkout the approved URL is correct and the order status is updated from "Failed" to "processing"

When the sale is made on the wholesale site, the subdomain, the order status is not changed although the payment was successful

I am not an expert but I think that this issue is because the approved URL is the same for both the main domain and the subdomain and possibly also i need to configure the approved URL with 2checkout to accept payments from 2 domains, the main domain and the subdomain with 2 different approved URL's

Thanks for the help in advance
Hani

Pages: [1] 2 3 ... 7

Powered by SMFPacks Social Login Mod