Show Posts


Topics - user88

Pages: [1] 2 3
1
Fresh Installation / I think I found another bug? Email Templates
« on: September 01, 2020, 08:09:00 PM »
Hi,

First, sorry if I'm posting these in the wrong place. Couldn't figure out where to post possible bugs.

I was updating the email templates and I noticed a very strange behavior. Maybe is just my installation?

Again, this is on a completely fresh install. All my data has been imported to it.

When I open an email template for editing the page loads up with the html body in html/text mode. The code looks just fine. See pic "email template 1"

When change html body mode to "visual" it tries to load an image which it can't load and shows a broken image logo. See pic "email template visual." This somehow brakes the html code of the message.

When I switch the html body back to html/text mode, the code is all changed and messed up. See pic "email template 2" This means the email formatting no longer works as designed and the client gets an "ugly" email.

They way I had to work around this was by making all my changes in html/text mode without ever switching to visual mode.

I don't do anything other than switch from html/text to visual and then back to html/text mode.

2
Fresh Installation / I think I found a bug - fast checkout
« on: August 29, 2020, 01:58:04 AM »
Hi,

As you may know, I have been tinkering with a fresh installation of AbanteCart 1.2.16.

After wrestling with Murphy for a few days... I finally got everything to work... even fast checkout...

BUT

Fast checkout works fine only when "Guest checkout" is ON. Once I turn "guest checkout" OFF and I run a test purchase, AbanteCart freezes when  clicking on the "checkout" button on the "shopping cart" page. It goes to the fast checkout page but nada, only the icon showing page is loading.

Worse, when this happens, it completely freezes my entire website. I can't access anything. No admin access, no blog software access... nothing related to my website that is in a sub directory.

Eventually the server stops whatever happens with AbanteCart and my websites become available again.

First time it happened I freaked out! Fortunately I decided to go ahead and do something else for a few hours. Upon return all was working again. Then I continued updating and migrating my store to the fresh installation, testing, smiling... all is working fine... UNTIL I decided to test "guest checkout" ... Now my websites are all down again.

One AbanteCart cart tab of my admin panel I left opened showed a gateway timeout error. see image

3
New Features Discussion / Status of download activation options
« on: August 24, 2020, 03:41:18 PM »
Hi everyone,

This is a follow up on this topic.

http://forum.abantecart.com/index.php/topic,7309.0.html

I noticed this feature is not available in the latest AbanteCart version. Has a decision been made to drop it?

Seems to me that having multiple options for download availability is important. Otherwise whenever someone changes the status of the order, the download files become unavailable to the client.

Example:

I sell both digital and physical products. If a client orders both, then when I update the status of the order to "shipped" then the client no longer has access to the download file.

4
Fresh Installation / Migration into a fresh installation
« on: August 21, 2020, 07:06:38 PM »
Hi,

I had some issues with upgrades so I would like to start with a fresh installation of AbanteCart in a new subfolder, migrate my store there, and then clone this new installation back to my original store's subfolder. (No hosting change)

Besides backing up the database and the content using -system/data/backup-restore and then uploading it to my fresh installation, is there anything else to be done?

Is there really a need to backup core files and copy those to my new installation? Or should I completely avoid this?

Thanks

5
Upgrade / Products don't display with 1.2.16 and default template
« on: August 04, 2020, 05:29:49 PM »
Hi,

I made this comment on another thread as part of some other issues, but want to separate it from that thread.

Here is my situation:

1. I upgraded to 1.2.16
2. I use my own customized template (which I was told will need updated to 1.2.16 standards - but right now I have it functional)
3. When I switch to default template (and clear all cache,) AbanteCart storefront does not display products on category pages. Home page displays ok, product page displays ok, but category page doesn't show any products. See images.

Any thoughts? My concern is that if I start updating my theme using new default theme files I will break my site.

6
Payment Modules / Default Stripe - New observations
« on: July 31, 2020, 06:42:47 PM »
Hi all,

Having had the same issue with default stripe and abantecart (cc box not showing) I upgraded both and I have been doing extensive tests.

I have noticed that default stripe doesn't always shows the cc box on checkout page. Sometimes it does but once in a while nothing... (I lost a sale yesterday to this - stripe shows the client and under details shows no cc entry at all thus no capture)


On my website checkout page, the cc card number box shows out of place. see image. Small stuff, but that's what clients notice and find "fishy."

Also, comparing my stripe account activity with what I was doing in AbanteCart I noticed that when default stripe is selected for payment at Step 2 of checkout and client presses the 'continue' button, AbanteCart communicates with stripe while checkout page is loading and sends client information to stripe BEFORE client enters cc number.

In this process AbanteCart sends the first name twice: once for the first name and once for the last name causing stripe to identify the client only by first name, first name. (see image)

The other thing about this sending of information before client completes purchase is that stripe still records the client in its customer list even if client abandons cart... and if you are testing live like me (up to checkout page but without completing purchase), then stripe records each occurrence of the checkout page as a new customer. OR, if client decides to edit order and leaves checkout only to return later to it with the updated order, then stripe records the same client twice. This creates a long list of repeated customers. See image.

Other thing I noticed is that the checkout page takes a long time to finish loading because of communication with stripe. The checkout page loads, but browser continues to churn while showing it is communicating with stripe. No clue what this means.

It seems that the default stripe payment app needs to be gone reviewed or perhaps even better - re-done from scratch rather than patch?

Hope info helps.

7
Hi,

For whatever reason the Stripe upgrade to 1.0.5 did not fix the missing cc card number field with my Abantecart.

History of my problem

1. Running AbanteCart 1.2.15 and default stripe.
2. Learned that the donation extension was failing with default stripe.
3. Donation app developer suggested upgrading default stripe to 1.0.5
4. Upgraded to stripe 1.0.5 and stay with AbanteCart 1.2.15
5. Stripe stops working - it no longer displays cc number field.
6. Upgrade to 1.2.16 to see if this solves problem. NO. Problem is still there.

I have php 7.3

I have attached AbanteCart error log and web console code from checkout page.

Any thoughts?

8
General Support / Customer Status
« on: July 23, 2020, 06:12:37 PM »
Hi,

What is the purpose of the Customer Status being ON or OFF?

I noticed newsletter subscribers have the status as OFF. Is there a need for me to turn their status to ON?

Thanks.

9
General Support / Adding video
« on: September 08, 2019, 09:06:47 PM »
Hi everyone, hope all is well,

I read the manual and forum about videos and successfully uploaded my own video, created a video block, and activated it on the product layout page.

When I go to the product page, the video is not embedded on the page. Instead you have to click it and then it opens a black screen. (see picture) After the video finishes there is no way to go back to the product page. Really unpleasant experience.

Here is a link so you can see what I mean (the video is a small test file).

https://bluestarway.com/increase4all/index.php?rt=product/product&product_id=78

-----  Is it possible to have the video embedded on the product page so that it can be viewed right there?

Thanks a lot

10
New Features Discussion / Adding a progress bar to uploads in Media Manager
« on: September 03, 2019, 01:28:40 PM »
Hi everyone,

The problem:

I have been trying to upload a video via the media manager over a SLOW connection. The media manager shows only a status bar, so I have no way of monitoring if the upload is progressing or not. I have been sitting for almost an hour waiting and so far the upload hasn't finished. Without a progress bar I can't tell - is it almost done, half way, no where close? Should I continue to wait or cancel and try again later?

Suggestion

Add a progress bar to media manager upload. Show percent complete and perhaps transfer speed.

This would give those with slow connections and large files a way of telling if the upload is working or got somehow interrupted or the connection is way to slow for successful completion.

Thanks a bunch for all the good work.


11
General Support / Patch files for 1.2.14
« on: June 10, 2019, 06:00:50 PM »
Hi,

I went to the abantecart patch file page to download the patch files for 1.2.14.  I was able to download all files except two:

B.core/lib/

and

H.storefront/model/catalog/

When I click on those to files I get error message:

                                                 Sorry, the file you are requesting is unavailable.

Does that mean these two files are no longer necessary to patch upgrade from 1.2.13 to 1.2.14?

Thanks.



12
SEO / Use of keywords
« on: April 15, 2019, 06:55:12 PM »
Hi, just beginning to understand how this SEO thing works. I read several of the older posts and realized that I probably don't understand the right use of keywords. So here are some very basic questions.

Q1
Until today, I was of the (probably tremendously false and outdated assumption) that I could enter as many keywords in the 'meta keywords' header as I wanted that pertained to the general focus of my website regardless whether those keywords appear on that page's visible content.

So for example my home page meta keywords include all kinds of keywords that relate to subjects, topics, and products that can be found throughout my website. Looking closely, most of those keywords don't appear in the content of that home page at all. I take this to be a mistake. Is that accurate?

Q2
Do I understand it right that I should probably limit the number of keywords I put inside the 'meta keywords' header  to 8 or less?

Q3
Then, I should use each keyword I entered in the 'meta keywords' header within the visible content of my page. And that the use of each keyword within this content should not exceed 4 to 6 times. Right?

Q4
Should I also include these keywords in my 'meta tag description'?

Thanks for your help.

13
General Support / Tracking free downloads
« on: April 07, 2019, 11:12:52 PM »
Hi,

I have made several e-files available as free downloads on my shopping cart. Is there a way to track how many times each of these free files is downloaded?

Thanks

14
New Features Discussion / Download activation
« on: January 30, 2019, 05:26:23 PM »
Hi again,

Still very happy with the cart, just another thing I realized. This time with downloads.

I have downloads set to activate when the order status is 'processing' which is my default order status for the store.

Now, I decided that whenever a customer would download the file, I would manually change the order status to complete. Unfortunately this created a problem. After the manual change, the order status 'complete' doesn't match the download requirement 'processing' and this deactivates the download for a customer.

At first I didn't understand the warning message I was getting from this change of order status.  The warning message would appear in the order summary under the downloaded files tab.

Eventually I recognized the problem and changed the order status back to 'processing' and this solved the problem.

Why is this a problem?

1. If customer downloads file and I change the order status to 'complete', he can't go back and make another download even if I allow several downloads of a file.
2. If I need to push an updated version of the file to the customer after I change the order status to 'complete', this file cannot be downloaded by customer

My suggestion for future carts would be:

1. would it be desirable to allow for several selections to be made under the downloads setting so that users can activate a download when order status is 'processing' and / or 'complete' and / or ...

2. if I were to change the store default order status to 'complete' then I would have to change all my downloads to activate on 'complete' and I have dozens upon dozens of them. Perhaps a feature to make batch changes to products would be a nice addition.

3. is there another option (besides no longer manually changing order status)?

Thanks,

Martin


15
New Features Discussion / Color scheme
« on: January 30, 2019, 05:03:05 PM »
Hi,

Very happy with the cart. One minor suggestion. The color scheme selected for showing which options are on or off has been a little confusing. Sometimes it is difficult to immediately recognize what the selected setting is.

For example, I just realized that the 'send mail' page in AbanteCart Cart defaults the 'message body' to 'html/text' and that I was sending completely unformatted emails. I always thought I was in 'visual' mode... though I admit I found it odd to have no formatting tools... but figured it was just the way it was designed.

Thanks

Pages: [1] 2 3

Powered by SMFPacks Social Login Mod