Please help us to make AbanteCart Ideal Open Source Ecommerce Solution for everyone.

Support AbanteCart eCommerce

Author Topic: checkout  (Read 3321 times)

Offline gear for hunter

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
checkout
« on: April 11, 2023, 06:48:39 PM »
Trying to get my checkout to work and I get this message   2023-04-11 16:01:14 - Unknown Error: AbanteCart core v.1.3.3 Class "net\authorize\api\contract\v1\MerchantAuthenticationType" not found in <b>/home/gearforhunters/public_html/extensions/default_authorizenet/storefront/model/extension/default_authorizenet.php</b> on line <b>36</b>  the place it looks like the change needs made is not editable Crontab in Linux command any help



Offline llegrand

  • Hero Member
  • *****
  • Posts: 1802
  • Karma: +524/-7
    • View Profile
Re: checkout
« Reply #1 on: April 11, 2023, 11:15:02 PM »
there is a known issue with authorize net for v 1.3.3 

The core devs have fixed it for the next release.   In the meantime you can find the patch file here
https://why2central.net/patch/abantecart-v1-3-3-default-authorizenet-patch-file/

along with the directions of how to install it.

This should get your issue resolved.

The support team at WHY2

Offline gear for hunter

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
Re: checkout
« Reply #2 on: April 13, 2023, 05:39:11 PM »
Thank you for your response when is the next release coming out

Offline llegrand

  • Hero Member
  • *****
  • Posts: 1802
  • Karma: +524/-7
    • View Profile
Re: checkout
« Reply #3 on: April 13, 2023, 05:56:05 PM »
Unknown currently.  they indicate they are 18% complete.  So best guess it will be awhile.

Offline Basara

  • Administrator
  • Hero Member
  • *****
  • Posts: 5838
  • Karma: +275/-2
    • View Profile
Re: checkout
« Reply #4 on: April 14, 2023, 01:39:23 AM »
Hello.
You dont need to wait for the release. Download the 1.3.4 branch and copy the public_html/extensions/default_authorizenet/ folder to your site

Offline Baychaser

  • Newbie
  • *
  • Posts: 37
  • Karma: +4/-0
    • View Profile
Re: checkout
« Reply #5 on: April 17, 2023, 12:23:50 PM »
So all of us can replace the files with these right, and my version is 1.3.3 I don't use that extension but a fix is nice if there is a problem. Thanks


Quote from: Basara link=topic=10156.msg39369#msg39369
date=1681450763
Hello.
You dont need to wait for the release. Download the 1.3.4 branch and copy the public_html/extensions/default_authorizenet/ folder to your site
« Last Edit: April 17, 2023, 12:28:14 PM by Baychaser »

 

Powered by SMFPacks Social Login Mod