Author Topic: Is PHP 8.3.4 going to be OK?  (Read 140 times)

Offline jimcooncat

  • Newbie
  • *
  • Posts: 26
  • Karma: +4/-0
    • View Profile
Is PHP 8.3.4 going to be OK?
« on: March 31, 2024, 10:20:43 AM »
I'm running an Ubuntu Server 22.04.4 LTS on my Linode. Had some Apache on it, and apt update brought PHP up to 8.3.4. Is this going to be ok for running AbanteCart 1.3.4? I'm confused because the requirements at https://abantecart.atlassian.net/wiki/spaces/AD/pages/3768390/AbanteCart+System+Requirements show No for PHP 8.3 or greater.

Offline Nuno Neff

  • Full Member
  • ***
  • Posts: 187
  • Karma: +23/-7
    • View Profile
Re: Is PHP 8.3.4 going to be OK?
« Reply #1 on: March 31, 2024, 11:29:50 AM »
Hello, I don't think it will work well with this version because as far as I know version 1.4 of Abantecart will support version 8.2.

Offline jimcooncat

  • Newbie
  • *
  • Posts: 26
  • Karma: +4/-0
    • View Profile
Re: Is PHP 8.3.4 going to be OK?
« Reply #2 on: March 31, 2024, 04:18:05 PM »
Thank you. I'll update-alternatives to the recommended version, 8.1.

Offline jimcooncat

  • Newbie
  • *
  • Posts: 26
  • Karma: +4/-0
    • View Profile
Re: Is PHP 8.3.4 going to be OK?
« Reply #3 on: March 31, 2024, 04:23:24 PM »
update-alternatives did not let me do 8.1, as it wasn't available on the system. 8.2 was, though. Seemed to work alright.

Offline Basara

  • Administrator
  • Hero Member
  • *****
  • Posts: 5798
  • Karma: +274/-2
    • View Profile
Re: Is PHP 8.3.4 going to be OK?
« Reply #4 on: April 01, 2024, 02:18:54 AM »
update-alternatives did not let me do 8.1, as it wasn't available on the system. 8.2 was, though. Seemed to work alright.
Hello. It might work but not stable. In some cases, it may fail.

 

Powered by SMFPacks Social Login Mod