Please help us to make AbanteCart Ideal Open Source Ecommerce Solution for everyone.

Support AbanteCart eCommerce

Author Topic: Which version of AbanteCart are your using and why? (in January 2024)  (Read 5299 times)

Offline OneMore

  • Newbie
  • *
  • Posts: 46
  • Karma: +12/-0
    • View Profile
Hi everyone and Happy New Year!

There is a poll "What Version are you using?", but it is eight years old.

As we enter 2024, I would be happy to hear which version(s) you are currently using, and why.


How to fill the following survey

For your answers in this thread, I would suggest that you copy the whole survey, fill it and remove the version-specific questions that are not relevant in your case.

( ) = one possible answer (= radio button)
[ ] = several possible answers

For the pseudo-checkboxes represented by brackets:
  • tick them with a x if or primary importance
  • tick them with a o if of secondary importance
  • use numbers ([3],[ ],[1],[2]) in case you want to prioritize answers by order of importance.


Let's start!

1. Since when are you a user of AbanteCart?

2. How many websites are you managing that use AbanteCart?
- in production: ...
- in development: ...

3. Which kind or user are you currently?

( ) invididual seller with in-house web skills. I installed and adapted AbanteCart to my needs.
( ) employee as IT specialist for a company that uses AbanteCart
( ) webagency or freelance, creating eCommerce websites for others
( ) end user, either self-employed or employee. (The website has been installed and configured by someone other.)
( ) other (please specify)

4. Did you test only one or several versions?
   Which ones and to what extent?

5. Which versions are you currently using?
   (Please specify if your are using them in production or in development.)

6. If you are using version 1.2, for which reason(s)?

Historical reasons:
[ ] Version 1.2 was the most recent available one when I created my website or when I did the last update from a prior version.
[ ] Because this is the version that I installed initially, although newer versions were available.
[ ] Because this version was installed by our IT specialist or web agency.
[ ] Because this is the version that was installed by Softaculous on my web hosting.

Technical reasons
[ ] After some comparative tests with version 1.3, I found that version 1.2 was still better for me. (Please tell when you tested version 1.3.)
[ ] Because they were few translations or extensions for the version 1.3 at the time I installed AbanteCart, version 1.2 was a better choice.
[ ] Because I have customized it a lot and changing would be difficult.
[ ] Some translations that I use are available for the version 1.2 but not yet for the 1.3.
[ ] Some extensions that I use are currently available for the version 1.2, but not the 1.3.
[ ] I find that the catalogue of available extensions globally better for version 1.2 than for version 1.3.
[ ] I find that some extensions are better for version 1.2 than for version 1.3. (Please specify which ones.)
[ ] Because the PHP version that my hosting is using is incompatible with newer versions.
[ ] Stability reason (Please detail.)
[ ] Security reason (Please detail.)

Other reasons
[ ] The size of the community seems larger for this version.
[ ] I prefer version 1.2 to version 1.3 for other reason(s). Please explain: ...

7. If you are using version 1.2, why did you not upgrade to version 1.3?

[ ] My website is okay with version 1.2 and I don't fully feel yet the need to upgrade.
[ ] So far, I  could not find enough time to test newer versions.
[ ] So far, I could not find enough time to migrate the data.
[ ] Upgrading to version 1.3 would be too complex.
[ ] Version 1.3 brings some useless features and/or some useless addtional complexity.
[ ] Other reason that was already mentioned at point 6.

8. If you are using version 1.3, how did you come to this version?

[ ] Version 1.3 was available when I started my eCommerce and I simply decided to select the newest version.
[ ] After some initial tests with versions 1.2 and 1.3, I found that version 1.3 was better for me.
[ ] I upgraded my eCommerce to version 1.3 from a prior version (1.2 or older).
[ ] I am doing it, but this is work in progress and it requires time.

9. If you are using version 1.3, for which reason(s)?

Historical reasons
[ ] It was already available when I created my eCommerce. I simply downloaded the most up-to-date version.
[ ] Because this version was installed by our IT specialist of web agency.
[ ] Because this is the version that was installed by Softaculous on my web hosting.

Technical reasons
[ ] After some comparative with version 1.2, I found that version 1.3 was the best for me. (Please mention when you tested.)
[ ] Some translations that I use are available for the version 1.3 but not for the 1.2
[ ] Some extensions that I use are currently available for the version 1.3 but not for the 1.2.
[ ] I find that the catalogue of available extensions globally better for version 1.3 than for version 1.2.
[ ] I find that some extensions are better in version 1.3 than in version 1.2. (Please specify which ones.)
[ ] Because of the PHP version that my hosting is using is incompatible with older versions.
[ ] Stability reason. (Give detail if necessary.)
[ ] Security reason (Give detail if necessary.)
[ ] Because I prefer the installer of version 1.3 to thus of version 1.2.

Other reasons
[ ] The size of the community seems larger for this version.
[ ] Because I wanted to test it.
[ ] I prefer version 1.3 to version 1.2 for other reason(s). Please explain: ...

10. If you are using version 2.0, for which reason?

[ ] I belong to AbanteCart 2.0 core developer team.
[ ] I am developer of extensions or translations and I am writing them or adapting them to AbanteCart 2.0.
[ ] After some comparative tests, I believe the version 2.0 is the future.
[ ] I am seller and I believe that AbanteCart 2.0 is already good enough for in-production sites.
[ ] I am currently porting my website from version 1.x to version 2.0.
[ ] Other reason. Please describe: ...

11. Is there something this survey missed about AbanteCart versions and that you would like to share?
...

Thank you for sharing!

Offline abantecart

  • Administrator
  • Hero Member
  • *****
  • Posts: 4358
  • Karma: +299/-10
    • View Profile
    • Ideal Open Source Ecommerce Solution
Re: Which version of AbanteCart are your using and why? (in January 2024)
« Reply #1 on: January 01, 2024, 09:03:44 PM »
I think this post needs to be covered to Poll
Please  rate your experience or leave your review
We need your help to build better free open source ecommerce platform for everyone. See how you can help

Offline OneMore

  • Newbie
  • *
  • Posts: 46
  • Karma: +12/-0
    • View Profile
Re: Which version of AbanteCart are your using and why? (in January 2024)
« Reply #2 on: January 03, 2024, 07:23:57 AM »
I think this post needs to be covered to Poll
I don't fully see what this has in common with "Idea Poll" for "AbanteCart development", apart the fact it can give an insight of what the community is currently using and possibly needs. Okay let it here.

I did not convert the survey into an interactive poll, because rather than stats I think it is more useful to have a more in-depth view of specific situations of users.


So, let's fill the survey. Here is the situation for me:

1. Since when are you a user of AbanteCart?
End of September 2023.

2. How many websites are you managing that use AbanteCart?
- in production: 0
- in development: 1

3. Which kind or user are you currently?

(x) invididual seller with in-house web skills. I installed and adapted AbanteCart to my needs.
( ) employee as IT specialist for a company that uses AbanteCart
( ) webagency or freelance, creating eCommerce websites for others
( ) end user, either self-employed or employee. (The website has been installed and configured by someone other.)
( ) other (please specify)

4. Did you test only one or several versions?
   Which ones and to what extent?

   1.2.11, with catalogue inserted. Have done some customizations to my needs.
   1.3.4, installed, to see what it looks like and which extensions are available, but not used so far.

5. Which versions are you currently using?
   (Please specify if your are using them in production or in development.)
 
    1.2.11, for eCommerce in development.

6. If you are using version 1.2, for which reason(s)?

Historical reasons
[ ] Version 1.2 was the most recent available one when I created my website or when I did the last update from a prior version.
[x] Because this is the version that I installed initially, although newer versions were available.
[ ] Because this version was installed by our IT specialist or web agency.
[ ] Because this is the version that was installed by Softaculous on my web hosting.

Technical reasons
[ ] After some comparative tests with version 1.3, I found that version 1.2 was still better for me. (Please tell when you tested version 1.3.)
[ ] Because they were few translations or extensions for the version 1.3 at the time I installed AbanteCart, version 1.2 was a better choice.
[ ] Because I have customized it a lot and changing would be difficult.
[2] Some translations that I use are available for the version 1.2 but not yet for the 1.3.
[ ] Some extensions that I use are currently available for the version 1.2, but not the 1.3.
[ ] I find that the catalogue of available extensions globally better for version 1.2 than for version 1.3.
[ ] I find that some extensions are better for version 1.2 than for version 1.3. (Please specify which ones.)
[1] Because the PHP version that my hosting is using is incompatible with newer versions.
[ ] Stability reason (Please detail.)
[ ] Security reason (Please detail.)

Other reasons
[ ] The size of the community seems larger for this version.
[ ] I prefer version 1.2 to version 1.3 for other reason(s). Please explain: ...

7. If you are using version 1.2, why did you not upgrade to version 1.3?

[2] My website is okay with version 1.2 and I don't fully feel yet the need to upgrade.
[ ] So far, I  could not find enough time to test newer versions.
[1] So far, I could not find enough time to migrate the data.
[ ] Upgrading to version 1.3 would be too complex.
[ ] Version 1.3 brings some useless features and/or some useless addtional complexity.
[ ] Other reason that was already mentioned at point 6.

 

Powered by SMFPacks Social Login Mod