Author Topic: When creating an account the page remains blank  (Read 391 times)

Offline Yormas1995

  • Newbie
  • *
  • Posts: 5
  • Karma: +0/-0
    • View Profile
When creating an account the page remains blank
« on: April 02, 2024, 10:00:01 AM »
Hello, when creating an account, all the fields for registration are filled out and when I click to register, the page loads and remains blank and generates the following error in the registration

2024-04-01 23:46:10 - Unknown Error: AbanteCart core v.1.3.4 Call to undefined function Symfony\Component\Mailer\Transport\Smtp\Stream\proc_open() in <b>/home/electron/public_html /vendor/symfony/mailer/Transport/Smtp/Stream/ProcessStream.php</b> on line <b>41</b>

I look at the file and I see everything fine. I replaced it again with the original to see if there was any error and it still persists.
Can someone help me with this error.

I clarify that the account is registered, but of course the person who registers does not know if it was created or not, since it does not generate the website where the account was actually created. help me thanks.

Offline abolabo

  • core-developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 2048
  • Karma: +319/-13
  • web for all, all for web!
    • View Profile
    • AbanteCart
Re: When creating an account the page remains blank
« Reply #1 on: April 03, 2024, 03:31:06 AM »
hi,
is it your v1.3.4 after upgrade or it's a newly installed 1.3.4 ?

please check file public_html/core/init.php
these lines must be there

Code: [Select]
const DIR_VENDOR = DIR_ROOT . DS . 'vendor' . DS;

require DIR_VENDOR.'autoload.php';
“No one is useless in this world who lightens the burdens of another.”
― Charles Dickens

Offline Yormas1995

  • Newbie
  • *
  • Posts: 5
  • Karma: +0/-0
    • View Profile
Re: When creating an account the page remains blank
« Reply #2 on: April 03, 2024, 10:08:13 AM »
Yes, the codes you just mentioned are in the init.php file

What I am looking at is that in the footer part of the page the administration would believe that I changed the copyright only in that part, I don't know if that affected anything and I don't know how I did it.
I would appreciate your help.

Quote
const DIR_VENDOR = DIR_ROOT . DS . 'vendor' . DS;

require DIR_VENDOR.'autoload.php';

looking good.
Well, the footer is editable in the same panel, which I think has nothing to do with. I don't know what it could be yet
« Last Edit: April 03, 2024, 10:25:15 AM by Yormas1995 »

Offline Yormas1995

  • Newbie
  • *
  • Posts: 5
  • Karma: +0/-0
    • View Profile
Re: When creating an account the page remains blank
« Reply #3 on: April 03, 2024, 10:44:19 AM »
When I press the continue button when I have already completed the registration form, it looks like this in the image that I will attach

But I go into the administrative panel and see that the account has been created. but it is an inconvenience that the website remains blank and the person does not know if the account was actually created successfully

Offline Basara

  • Administrator
  • Hero Member
  • *****
  • Posts: 5791
  • Karma: +274/-2
    • View Profile
Re: When creating an account the page remains blank
« Reply #4 on: April 04, 2024, 02:45:50 AM »
Hello.
This is an issue with the mail sent after registration is completed. Please make sure your mail is configured correctly or switch to the native PHP Mail feature (Mail Protocol: Inner Mailer) https://abantecart.atlassian.net/wiki/spaces/AD/pages/7372837/Mail+Settings

Offline abolabo

  • core-developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 2048
  • Karma: +319/-13
  • web for all, all for web!
    • View Profile
    • AbanteCart
Re: When creating an account the page remains blank
« Reply #5 on: April 04, 2024, 03:25:11 AM »
Hello, when creating an account, all the fields for registration are filled out and when I click to register, the page loads and remains blank and generates the following error in the registration

2024-04-01 23:46:10 - Unknown Error: AbanteCart core v.1.3.4 Call to undefined function Symfony\Component\Mailer\Transport\Smtp\Stream\proc_open() in <b>/home/electron/public_html /vendor/symfony/mailer/Transport/Smtp/Stream/ProcessStream.php</b> on line <b>41</b>



Looks like you have disabled function https://www.php.net/manual/en/function.proc-open.php
Please contact your hosting provider support for details.
I guess they are in paranoid mode and forbid all functions with "proc" inside the name.
You can check it via admin->system->settings->system->click on phpInfo() button at the heading. In the newly opened tab try to find "disable_functions" directive inside Core section.
if proc function in the list you can try deal with hosting provider. If they are reject your wish, you should to choose another mail transport, not smtp.
Actually the best approach to use inner server mailer (mail).

Also you can try to disable security_mod for your domain in the cPanel



“No one is useless in this world who lightens the burdens of another.”
― Charles Dickens

Offline Yormas1995

  • Newbie
  • *
  • Posts: 5
  • Karma: +0/-0
    • View Profile
Re: When creating an account the page remains blank
« Reply #6 on: April 05, 2024, 09:52:20 AM »
Hello, I still haven't solved it.
I contacted hosting support and they told me the following:

Please note that for security reasons, the following features are disabled by default in the cPanel control panel for all shared hosting accounts:
'disable_functions = show_source, system, shell_exec, passthru, exec, popen, proc_open'

So in this case what could I do. I still have the same problem that when they create the account the page remains blank.
I require your great help team. and thank you for what you have told me.
If anyone knows what I can do to fix this problem. I appreciate

Offline Basara

  • Administrator
  • Hero Member
  • *****
  • Posts: 5791
  • Karma: +274/-2
    • View Profile
Re: When creating an account the page remains blank
« Reply #7 on: April 08, 2024, 02:32:13 AM »
Hello, I still haven't solved it.
I contacted hosting support and they told me the following:

Please note that for security reasons, the following features are disabled by default in the cPanel control panel for all shared hosting accounts:
'disable_functions = show_source, system, shell_exec, passthru, exec, popen, proc_open'

So in this case what could I do. I still have the same problem that when they create the account the page remains blank.
I require your great help team. and thank you for what you have told me.
If anyone knows what I can do to fix this problem. I appreciate

Hello. switch to the native PHP Mail feature (Mail Protocol: Inner Mailer) https://abantecart.atlassian.net/wiki/spaces/AD/pages/7372837/Mail+Settings

 

Powered by SMFPacks Social Login Mod