Author Topic: Forbidden ! You don't have permission to access /store/index.php on this server.  (Read 34050 times)

Offline Odin

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
    • View Profile
Ive been trying to set my store up for 5 days now. when I access certain areas of the admin panel , I get the message "Forbidden ! You don't have permission to access /store/index.php on this server."
 and  "Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request".
 .I thaught perhaps it was something to do with my ssl or the ip of my server.
 also-
 When I try to view edit the .htaccess file or store/index php they are blank. I have tried changing permissions to 755 and that does'nt help either.
the address  with error is- { secure htt /domainname.website/store/index.php?rt=extension/extensions/edit&store_id=0&s=admin123&token=}

It seems my router IP is denied maybe ? security configuration for ssl wrong?
 I use a shared server but have a- domain ssl,  my cpanel ssl -is my server's shared ssl
Please, can anyone help with this ?

Offline Basara

  • Administrator
  • Hero Member
  • *****
  • Posts: 4796
  • Karma: +249/-2
    • View Profile

Offline bsmith40

  • Newbie
  • *
  • Posts: 25
  • Karma: +2/-0
    • View Profile
Hi,

I have a new install and have not been able to get into admin. if I go to admin folder or admin/index.php I get permission denied and 404 error also.   

I renamed htaccess file but then get redirected to store front instead of admin.

I don't see any help on the diisscusion link provided.  You have any success?

Offline bsmith40

  • Newbie
  • *
  • Posts: 25
  • Karma: +2/-0
    • View Profile
Also tried to install through softaculous but get error

My host provider also looked at install instructions but could not get it to work either.

Offline Basara

  • Administrator
  • Hero Member
  • *****
  • Posts: 4796
  • Karma: +249/-2
    • View Profile
Hi,

I have a new install and have not been able to get into admin. if I go to admin folder or admin/index.php I get permission denied and 404 error also.   

I renamed htaccess file but then get redirected to store front instead of admin.

I don't see any help on the diisscusion link provided.  You have any success?

Hello.
To access admin go to mydomain.com/index.php?s=secure_admin_word
You can always find secure_admin_word in your configuration file on your server.

/system/config.php

Look for define('ADMIN_PATH', 'xxxxxxx');

Offline bsmith40

  • Newbie
  • *
  • Posts: 25
  • Karma: +2/-0
    • View Profile
Thanks,

Finally was able to open admin with new install,

Mabye you can help me with this.

When I try to make changes in admin to some areas like in banner manager I get "Forbiden, permission denied and 404 not found error. Can't get it to pick up image changes.

Offline bsmith40

  • Newbie
  • *
  • Posts: 25
  • Karma: +2/-0
    • View Profile
Ok This is my third install

All loaded in but I can not edit half of the areas in design in admin

I get Forbidden and no permissions and 404 error.  Ive set my perssions to 777 on all files/folders required in install instructions

All day long for three days just trying to get a working install

PLEASE HELP

Offline bsmith40

  • Newbie
  • *
  • Posts: 25
  • Karma: +2/-0
    • View Profile
Can't edit from admin : menu, categories, image banners, manufacturers, etc  Get the same error

Somethings will edit some not.


Offline dls2004

  • Newbie
  • *
  • Posts: 15
  • Karma: +7/-1
    • View Profile
This message is thrown by abantecart when attempt access media in the following areas:

1.  Media tabpage in Product Summary page (error thrown 4 times)
2.  Edit and existing Category in Edit Category page
3.  Edit an Existing Manufacturer in Edit Manufacturer Page (four errors thrown)
4.  In Banner Manager try edit an existing banner
5. Settings > All settings (one error thrown)

Clearly there is a problem with access to media (pictures/video/audio) post upgrading from 1.1.9 to 1.2.0 and from this forum  also with a clean installs of 1.2.0.

And so far all responses from developers of abantecart is to change file permissions on certain folders and files to which does not fix the problem.

Once user's have tried this fix and it doesn't work, the abantecart forums go silent on a resolution to this problem.

It seems to me that version 1.2.0 is clearly broken and does not work correctly and that the developers of abantecart have decided the problem is just too difficult to resolve so have stopped responding to request for help to fix this bug.

This leaves me with only one real solution, to wipe out abantecart and select another e-commerce solution that has more reliable end user support.

Abantecart what an unstable piece of crap software!....I have wasted way too much time trying to fix issues with this broken crapware!





Offline abolabo

  • core-developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 1867
  • Karma: +285/-11
  • web for all, all for web!
    • View Profile
    • AbanteCart
all problems in Abantecart permissions are of two kinds.
1. Problems with the file system (means read access for files or directories in which they are located). Perhaps you should look in the error.log in the Control Panel of your hosting provider to determine the cause.
2. Rights of access to controllers that are managed in the admin area ( see menu system->users->user groups (for groups except Administrators)
“No one is useless in this world who lightens the burdens of another.”
― Charles Dickens

Offline windriven

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-1
    • View Profile
I'm with dls2004.  I'm getting the same error s/he got despite following the cryptic and useless responses offered by the moderators.  If the moderators can't manage more than 11 words, I can't be bothered to try to work through the software.  There are plenty of other options.  Toodles.

Offline webdevmerc

  • Full Member
  • ***
  • Posts: 172
  • Karma: +32/-1
    • View Profile
I'm with dls2004.  I'm getting the same error s/he got despite following the cryptic and useless responses offered by the moderators.  If the moderators can't manage more than 11 words, I can't be bothered to try to work through the software.  There are plenty of other options.  Toodles.


/rant

Whenever I see these messages, it sorta pisses me off.  So and so can't get something to work, they have played with the software for 1-2 hours....or 5 days...oh boo hoo...honestly, a lot of folks try to help, but it seems most of the complainers/whiners are new folks that aren't willing to invest much or ANY time themselves to learn the app or really much of anything.  If you want a store with limited functionality and a slavemaster, just start an Amazon or eBay store and live under someone else's rules.  Yes, feel free to try another app.  I don't think telling anyone here that really makes them care anymore that you are leaving.

I've spent probably a year off and on learning this app, I try to search and read all the forum messages before posting for help.  This is also FREE software...When bugs happen and you are running an e-commerce site, spend the time to learn it so you can fix most major issues yourself...because, YES, this is FREE software and things WILL break at times.

I have tried Drupal with Ubercart and that is a much more of a pain in the ass honestly with a much worst interface and tons of problems and hoops to jump through.  Paid solutions, from what I've seen are either insanely expensive or even more limited.

Maybe the devs simply get tired of the same simple questions being asked without people reading the docs, or knowing a thing about computers.

At the end of the day, it's your time or website, you call it what you will.  If your site crashers, people here will and have tried to help, but at the end of the day, you are losing money so it's in your best interests to literally spend hours learning all the little nuances to fix something if needed or just pay someone else to do it.  Maybe I come from a unix background so most of my problems aren't really a big deal and I get through it, but ultimately, if you don't know what you're doing and have a limited computer background, then I personally don't think this or most any carts are for you.  Hire the help.

The moderators are also probably volunteers and aren't being "paid" to help you.  Since Abantecart is open-source, the devs aren't also making a killing I don't think.

There ARE other options, good luck with whatever you choose (Magento?  Isn't that 18k to start?).

/end rant


Offline eCommerce Core

  • Administrator
  • Hero Member
  • *****
  • Posts: 1602
  • Karma: +93/-1
    • View Profile
Thank you webdevmerc for your comments.
“If you’re in the luckiest one per cent of humanity, you owe it to the rest of humanity to think about the other 99 per cent.”
― Warren Buffett

Offline abantecart

  • Administrator
  • Hero Member
  • *****
  • Posts: 4282
  • Karma: +283/-10
    • View Profile
    • Ideal Open Source Ecommerce Solution
I'm with dls2004.  I'm getting the same error s/he got despite following the cryptic and useless responses offered by the moderators.  If the moderators can't manage more than 11 words, I can't be bothered to try to work through the software.  There are plenty of other options.  Toodles.
Let's try to resolve this issue. Can you pm access to your admin?
Please  rate your experience or leave your review
We need your help to build better free open source ecommerce platform for everyone. See how you can help

Offline magnia

  • Newbie
  • *
  • Posts: 2
  • Karma: +1/-0
    • View Profile
I am installing pretty much the same problem, and so far all attempts to resolve it (by the recommended solutions, i.e. setting all the relevant folders to permission 777 have not worked).

I can see no errors in my cPanel log which would cause this, and nothing in the actual AbanteCart cart eror log.

Basically, here is what happens...

1) when I click on Catalogue->Products->Media and try to add images, what is described in the User Guide is not present/happening. i.e. There is no option to "Add Resource" no way to upload images when clicking the + icon.



Furthermore, like other users have reported a get a bunch of pink error windows pop up (one for each of the media options it seems) once I click Media option, saying "Error 500, permission denied when accessing /index.php (in main installation folder).

Everything else seems to work fine, however I have noticed, that when I do a refresh on the Media page, this seems to CRASH the webserver completely, i.e. domains won't load. Which suggests maybe a serious bug in the software or some incompatibility with some/all Cpanel setups.

Just for reference, I am running:

AbanteCart Version 1.2.2 (no extra extensions install, fresh install) I install it in a sub-directory (different to that suggestion) if that makes any difference?

I would appreciate any help, as this is a very good piece of software, but after a week or more now trying to solve the problem I'm about to cut my losses and try something else as not being able to upload images and the fact it seems to crash my server, is a deal breaker. Pity.





 

Powered by SMFPacks Social Login Mod