Please help us to make AbanteCart Ideal Open Source Ecommerce Solution for everyone.

Support AbanteCart eCommerce

Author Topic: (Sub and first) category malfunction normal product appears on the bottom  (Read 4629 times)

Offline timieh

  • Newbie
  • *
  • Posts: 11
  • Karma: +1/-0
    • View Profile
Hey guys,

On my website Im having a issue.

When i go to a catagory like "reperatiekit"
The items and layout is working normal.

But when i go to "reperatiekiet>subcategory"
The items seems normal but on the bottom there is 1 product expanded..  ??? (see attachmend)

« Last Edit: September 29, 2015, 02:48:33 PM by timieh »

Offline abantecart

  • Administrator
  • Hero Member
  • *****
  • Posts: 4279
  • Karma: +283/-10
    • View Profile
    • Ideal Open Source Ecommerce Solution
Re: Sub category malfunction normal product appears on the bottom
« Reply #1 on: September 24, 2015, 09:41:20 PM »
Did you edit any HTML (.tpl) files?
Please  rate your experience or leave your review
We need your help to build better free open source ecommerce platform for everyone. See how you can help

Offline timieh

  • Newbie
  • *
  • Posts: 11
  • Karma: +1/-0
    • View Profile
Re: Sub category malfunction normal product appears on the bottom
« Reply #2 on: September 28, 2015, 04:13:08 AM »
No  :-\

What tpl file should i try to replace with the demo/installation file?

Offline timieh

  • Newbie
  • *
  • Posts: 11
  • Karma: +1/-0
    • View Profile
Re: Sub category malfunction normal product appears on the bottom
« Reply #3 on: September 29, 2015, 02:02:51 PM »
Anyone have any idea?


« Last Edit: September 29, 2015, 02:47:58 PM by timieh »

Offline timieh

  • Newbie
  • *
  • Posts: 11
  • Karma: +1/-0
    • View Profile
Re: Sub category malfunction normal product appears on the bottom
« Reply #4 on: September 29, 2015, 02:48:16 PM »
Update:
When I disable the product shown its gone. Maby something wrong in import/export ?
Some products got it others don't..... ?


Update: Its also hapening in only the first category

Offline webdevmerc

  • Full Member
  • ***
  • Posts: 172
  • Karma: +32/-1
    • View Profile
Re: Sub category malfunction normal product appears on the bottom
« Reply #5 on: September 29, 2015, 07:16:17 PM »
Update:
When I disable the product shown its gone. Maby something wrong in import/export ?
Some products got it others don't..... ?


Update: Its also hapening in only the first category


I have ran into this before...and you disabling the product shown removes the issue confirms what I think is causing it...

The problem is that there are probably some html code or formatting (like <div> or non matching open/close html formating codes) causing it to format the end of the page funny.  To fix this, you can probably go to that product, delete all the description and start from scratch or clean it up.

That should fix it.

Offline timieh

  • Newbie
  • *
  • Posts: 11
  • Karma: +1/-0
    • View Profile
Update: Removed all the description of the product, but still keeps messing up the underside of the page. Only this is fixed when I disabled the product.... ???

Offline Basara

  • Administrator
  • Hero Member
  • *****
  • Posts: 4755
  • Karma: +246/-2
    • View Profile
Please post Url

Offline timieh

  • Newbie
  • *
  • Posts: 11
  • Karma: +1/-0
    • View Profile
I also tried some things with the problem. (Basara maby we can have live contact ?)
-----------------------------------------------------------------------------------------------------------------------
www(.)motorkampeerwinkel(.)nl/navigatie

Here you see a little malfunction only " Bekijk Schrijf Review     Navigatie" & "Winkelwagen
€600.00"

------------------------------------------------------------------------------------------------------------------------
When i Enable "MSR Service Kit Whisperlite" & "MSR Service Kit XGK/XGK EX" I got the big malfunction (The whisperlite product is completely shown on page) as shown @:
www(.)motorkampeerwinkel(.)nl/branders-en-benodigdheden?sort=sort_order-ASC

I got the little malfunction (As mentioned above) from "MSR Service Kit XGK/XGK EX" when I only enalbe the "MSR Service Kit XGK/XGK EX"
« Last Edit: October 01, 2015, 09:04:03 AM by timieh »

Offline Basara

  • Administrator
  • Hero Member
  • *****
  • Posts: 4755
  • Karma: +246/-2
    • View Profile
Re: Sub category malfunction normal product appears on the bottom
« Reply #9 on: October 01, 2015, 09:06:07 AM »

I have ran into this before...and you disabling the product shown removes the issue confirms what I think is causing it...

The problem is that there are probably some html code or formatting (like <div> or non matching open/close html formating codes) causing it to format the end of the page funny.  To fix this, you can probably go to that product, delete all the description and start from scratch or clean it up.

That should fix it.

I agree with webdevmerc looks like you have problem with html in some of the products descriptions.
http://www.motorkampeerwinkel.nl/branders-en-benodigdheden?sort=sort_order-ASC
and
http://www.motorkampeerwinkel.nl/branders-en-benodigdheden?product_id=362

Offline timieh

  • Newbie
  • *
  • Posts: 11
  • Karma: +1/-0
    • View Profile
Re: (Sub and first) category malfunction normal product appears on the bottom
« Reply #10 on: October 01, 2015, 09:11:12 AM »
Hmm will try to sort this out.  (keep you guys posted)

Only the weird thing is it when disable www(.)motorkampeerwinkel(.)nl/branders-en-benodigdheden?product_id=361 the product what is showing as a complet productpage on the layout is also gone. the product that is disabled is only behaving the "little malfunction"

Offline Basara

  • Administrator
  • Hero Member
  • *****
  • Posts: 4755
  • Karma: +246/-2
    • View Profile
Re: (Sub and first) category malfunction normal product appears on the bottom
« Reply #11 on: October 01, 2015, 09:16:07 AM »
Also good point to clear AbanteCart cache and make sure your files are same with originals https://github.com/abantecart/abantecart-src/tree/master/public_html
in some cases like not completed upgrade or files edit/upload with FTP may broke them

Offline webdevmerc

  • Full Member
  • ***
  • Posts: 172
  • Karma: +32/-1
    • View Profile
Re: (Sub and first) category malfunction normal product appears on the bottom
« Reply #12 on: October 01, 2015, 01:02:17 PM »
Hmm will try to sort this out.  (keep you guys posted)

Only the weird thing is it when disable www(.)motorkampeerwinkel(.)nl/branders-en-benodigdheden?product_id=361 the product what is showing as a complet productpage on the layout is also gone. the product that is disabled is only behaving the "little malfunction"

There may be a lot of formatting issues or multi-line code from multiple items causing this.  Sometimes, it's very hard to find out exactly which item it is so you have to play around with disabling different ones or blocks to clean it up (it may not be the last item).

I imported over 800 items and ran into probably 50 of these since the data I had was altered a bit (I had to delete the bottom section of the description) so a lot of code problems overall.

I then used a unix script to search for the number (count of things like <div> </div>, etc) to make sure they matched.  After cleaning it up, the problem went away.

Takes a lot time and data cleaning is a bitch to deal with...especially if you have hundreds or thousands of items to do.

 

Powered by SMFPacks Social Login Mod