Author Topic: extention I bought won't upload to v1.1.0  (Read 4327 times)

Offline Craig

  • Newbie
  • *
  • Posts: 28
  • Karma: +3/-0
    • View Profile
extention I bought won't upload to v1.1.0
« on: October 18, 2012, 06:33:03 PM »
hi, trying to upload an extention i bought but i'm getting this message ... Error: Probably package is broken. Structure of package error. i contacted algozone who sent me this reply .... We apologize for inconvenience. There is currently an issue with installer module in AbanteCart v 1.1. They are releasing update in couple of days.

just wondering how far away the update will be. Thanks guys.

Offline abantecart

  • Administrator
  • Hero Member
  • *****
  • Posts: 4279
  • Karma: +283/-10
    • View Profile
    • Ideal Open Source Ecommerce Solution
Re: extention I bought won't upload to v1.1.0
« Reply #1 on: October 18, 2012, 09:26:29 PM »
We will have an update tomorrow. I really hope. We are running final testing and all looks good.

About installing manually. It is very easy. Just download your extension, open archive and upload 1 directory.

See this manual:
http://www.abantecart.com/ecommerce-documentation/61-admin-user-manual/extensions-menu/extension-store#FTPinstall

New version will have more options to install the extensions.
We are all about making this easy :)
Please  rate your experience or leave your review
We need your help to build better free open source ecommerce platform for everyone. See how you can help

Offline Craig

  • Newbie
  • *
  • Posts: 28
  • Karma: +3/-0
    • View Profile
Re: extention I bought won't upload to v1.1.0
« Reply #2 on: October 20, 2012, 05:00:59 AM »
hi, just did the manual upgrade on the 1 file you mentioned, public_html/admin/controller/pages/tool/package_installer.php, tried to do the v1.1.1 update after that and got this message...     Fatal error: Call to undefined function versionCompare() in /home/www/metaldetector.co.nz/admin/controller/pages/tool/package_installer.php on line 804

any ideas on this one. Cheers

Offline abantecart

  • Administrator
  • Hero Member
  • *****
  • Posts: 4279
  • Karma: +283/-10
    • View Profile
    • Ideal Open Source Ecommerce Solution
Re: extention I bought won't upload to v1.1.0
« Reply #3 on: October 20, 2012, 10:53:38 AM »
I am sorry, but I think utils.php also required.

Try to copy this file. from core/helper/utils.php to your location.

As instructed, you can also, just copy all files and directories over your AbanteCart installation directory. This will be faster.

Reason for this inconvenience is mainly due to small bug in installation package that prevents easy upgrade.
Please  rate your experience or leave your review
We need your help to build better free open source ecommerce platform for everyone. See how you can help

 

Powered by SMFPacks Social Login Mod