Please help us to make AbanteCart Ideal Open Source Ecommerce Solution for everyone.

Support AbanteCart eCommerce

Author Topic: Site mail not working after move to new web host (SOLVED).  (Read 5862 times)

Offline Siri M.

  • Newbie
  • *
  • Posts: 41
  • Karma: +7/-0
    • View Profile
Site mail not working after move to new web host (SOLVED).
« on: November 10, 2015, 09:35:18 PM »
Hi
I just spent a half an hour with InMotion tech support on chat. The problem is that Abantecart mail isn't working on their servers. I tried my site (1.2.3) and also did a fresh install of AbanteCart cart 1.2.4. Both have the same problem. Tried both mail() and SMTP, different ports, etc. The tech support tested and tried themselves and finally said "I honestly don't know why its not working, it could be a server issue with incorrect php version but we are just not getting errors to show it."

 My localhost mail is working fine with everything else. She said this is PHP version is 5.3.

Sometimes, depending on settings, there are errors in the log, such as these:
2015-11-11 2:13:13 - warning: AbanteCart core v.1.2.3 fsockopen(): php_network_getaddresses: getaddrinfo failed: Name or service not known in <b>/home/botani22/public_html/core/lib/mail.php</b> on line <b>234</b>
2015-11-11 2:13:13 - warning: AbanteCart core v.1.2.3 fsockopen(): unable to connect to biz183.inmotionhosting.com:587 (php_network_getaddresses: getaddrinfo failed: Name or service not known) in <b>/home/botani22/public_html/core/lib/mail.php</b> on line <b>234</b>
2015-11-11 2:13:13 - Error: php_network_getaddresses: getaddrinfo failed: Name or service not known (0)

Or if I change to SMTP setting with "securebiz183inmotionhosting.com" I get this:
2015-11-10 19:51:43 - Error: php_network_getaddresses: getaddrinfo failed: Name or service not known (0)
2015-11-10 20:02:08 - Error: EHLO not accepted from server!
2015-11-10 20:02:08 - Error: AUTH LOGIN not accepted from server!
2015-11-10 20:02:08 - Error: Username not accepted from server!
2015-11-10 20:02:08 - Error: Password not accepted from server!
2015-11-10 20:02:08 - Error: MAIL FROM not accepted from server!
2015-11-10 20:02:08 - Error: RCPT TO not accepted from server!
2015-11-10 20:02:08 - Error: DATA not accepted from server!
2015-11-10 20:02:08 - Error: DATA not accepted from server!
2015-11-10 20:02:08 - Error: QUIT not accepted from server!

Anyway, this started after moving from Arvixe. At arvixe the mail worked fine with default mail setting.
As of now there is no contact mail, no sales confirmation mails, nothing.

Any ideas on this? Any work arounds?

Thanks much
« Last Edit: November 11, 2015, 02:17:08 AM by Siri M. »

Offline webdevmerc

  • Full Member
  • ***
  • Posts: 172
  • Karma: +32/-1
    • View Profile
Re: Site mail not working after move to new web host.
« Reply #1 on: November 10, 2015, 11:15:15 PM »
Looking at this error:
Sometimes, depending on settings, there are errors in the log, such as these:
2015-11-11 2:13:13 - warning: AbanteCart core v.1.2.3 fsockopen(): php_network_getaddresses: getaddrinfo failed: Name or service not known in <b>/home/botani22/public_html/core/lib/mail.php</b> on line <b>234</b>
2015-11-11 2:13:13 - warning: AbanteCart core v.1.2.3 fsockopen(): unable to connect to biz183.inmotionhosting.com:587 (php_network_getaddresses: getaddrinfo failed: Name or service not known) in <b>/home/botani22/public_html/core/lib/mail.php</b> on line <b>234</b>
2015-11-11 2:13:13 - Error: php_network_getaddresses: getaddrinfo failed: Name or service not known (0)


My guess is that:
biz183.inmotionhosting.com is not accepting connections to port 587...

No connect means can't email out.  It's probably how mail is defaulted in Abantecart, but maybe it can't authenticate to the mail server at biz183.inmotionhosting.com so is rejecting it.

That, or it can't resolve the IP address of biz183...

Sucks and scary to move a site.  I am going to decide if I want to move myself in a year.




Offline Siri M.

  • Newbie
  • *
  • Posts: 41
  • Karma: +7/-0
    • View Profile
Re: Site mail not working after move to new web host.
« Reply #3 on: November 11, 2015, 02:16:45 AM »
It was finally figured out. With this particular host you need to use SMTP setting and use "localhost" as your SMTP Host any case anyone has the same problems.

Offline maulikvrl2010

  • Newbie
  • *
  • Posts: 19
  • Karma: +2/-0
    • View Profile
Re: Site mail not working after move to new web host.
« Reply #4 on: August 25, 2023, 03:22:35 AM »
It was finally figured out. With this particular host you need to use SMTP setting and use "localhost" as your SMTP Host any case anyone has the same problems.
"Could you please explains more where expertly have to change"

Offline llegrand

  • Hero Member
  • *****
  • Posts: 1785
  • Karma: +516/-7
    • View Profile
Re: Site mail not working after move to new web host (SOLVED).
« Reply #5 on: August 25, 2023, 12:25:44 PM »
Just a note:

The info in this post is 8 years old.   There have been many updates to the cart version in that time.  The most current version of AbanteCart is 1.3.4

If you are having issues, suggest you seek more current information. 

 

Powered by SMFPacks Social Login Mod