Author Topic: database error when upgrading from 1.2.2 to 1.2.3  (Read 2749 times)

Offline helperbee

  • Jr. Member
  • **
  • Posts: 78
  • Karma: +2/-0
    • View Profile
database error when upgrading from 1.2.2 to 1.2.3
« on: February 04, 2016, 02:26:26 AM »
Hi,
On a test system, I've attempted to upgrade from 1.2.2 to 1.2.3. I first tried the admin auto upgrade, but received this error:

2016-02-03 18:18:12 - database error: AbanteCart core v.1.2.2 Error:
SELECT dataset_id
FROM ab_datasets
WHERE dataset_name = 'install_upgrade_history'
AND dataset_key='admin' LIMIT 1 in <b>/home/xxxxx/public_html/test/core/database/amysqli.php</b> on line <b>105</b>

I did a backup and attempted manual upgrade. I had host check the permissions on directories and files. I confirmed PHP version.

Files copy fine. Run of upgrade.sql goes fine. The thing the documentation doesn't mention is the step after running the sql.
For me, I navigate to the AbanteCart dashboard, and it displays an install page:
  /install/index.php
I walk through the steps entering database name, etc. It is able to make the database connection, yet fails on step 4. Data Load.
Error message on screen is not helpful. (see attached).

I've reviewed documentation and exhausted all search paths.

Please help. 

Error Log says:
2016-02-03 18:18:12 - database error:  AbanteCart core v.1.2.2 Error: <br />SELECT dataset_id
                                FROM ab_datasets
                                WHERE dataset_name = 'install_upgrade_history'
                                    AND dataset_key='admin' LIMIT 1 in <b>/home/xxx/public_html/test/core/database/amysqli.php</b> on line <b>105</b>

2016-02-04 6:04:53 - database error:  AbanteCart core v.1.2 Error: Could not load database file ! in <b>/home/xxx/public_html/test/core/lib/db.php</b> on line <b>45</b>


Thank you in advance for any tips/solutions.




« Last Edit: February 04, 2016, 02:36:54 AM by helperbee »

Offline abolabo

  • core-developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 2004
  • Karma: +309/-12
  • web for all, all for web!
    • View Profile
    • AbanteCart
Re: database error when upgrading from 1.2.2 to 1.2.3
« Reply #1 on: February 04, 2016, 08:45:46 AM »
You should to check your system/config.php. contsnt DB_DRIVER value.
Then look into core/database and check is this driver file present there.
for ex. your db-driver is 'mysql' seek mysql.php file
“No one is useless in this world who lightens the burdens of another.”
― Charles Dickens

Offline helperbee

  • Jr. Member
  • **
  • Posts: 78
  • Karma: +2/-0
    • View Profile
Re: database error when upgrading from 1.2.2 to 1.2.3
« Reply #2 on: February 04, 2016, 06:19:26 PM »
You should to check your system/config.php. contsnt DB_DRIVER value.
Then look into core/database and check is this driver file present there.
for ex. your db-driver is 'mysql' seek mysql.php file
Thanks. Yes, the DB driver is present. Still no luck with admin auto update. I did get manual upgrade to work on another site thanks to  your tip, because it helped me discover that the config.php file was empty.


 

Powered by SMFPacks Social Login Mod