Shopping Cart Operations > General Support

email setting not working

<< < (3/4) > >>

AVS:
Even I am getting error when SMTP is set. Ordinary mail works well. Email received when new order is made. If SMTP enabled, email is not received and connection timeout error show in the Error log. I have tried all possible smtp settings including changing ports like 25, 2525, 465 etc... Also used ssl://mail.example.com, ssl://smtp.gmail.com   or just localhost....
 Nothing works. Coming into this forum, I found I am not alone facing this issue. Can someone throw light on this?
Thanks

starfish777:
I've been researching this issue as well. I am having the same problem. I want to use SMTP to have all correspondance email come to the gmail address and want the AbanteCart emails that are pushed from SALES--> SEND MAIL to show that they are from the gmail account as well. Here are a few of articles to shed some light on the issue.  BEWARE: Godaddy hosting has restrictions on using any other SMTP than their own, even though some support phone reps may not be aware of it.  I am trying to find a way to make this work and am still looking into it. Please also let me know if you have any luck with these:

h t t p s : //github.com/PHPMailer/PHPMailer/wiki/Troubleshooting

h t t p s : //noorsplugin.com/how-to-resolve-smtp-error-failed-to-connect-to-server-connection-refused-111-network-is-unreachable-101/

h t t p s : //tjkelly.com/blog/gmail-godaddy-email-forwarding/

Good luck!

AVS:
Nice links starfish777. But needed more precise fix for SMTP  to work in all situations including Email working through G Suite also.

Basara:

--- Quote from: AVS on November 10, 2017, 07:18:58 AM ---Even I am getting error when SMTP is set. Ordinary mail works well. Email received when new order is made. If SMTP enabled, email is not received and connection timeout error show in the Error log. I have tried all possible smtp settings including changing ports like 25, 2525, 465 etc... Also used ssl://mail.example.com, ssl://smtp.gmail.com   or just localhost....
 Nothing works. Coming into this forum, I found I am not alone facing this issue. Can someone throw light on this?
Thanks

--- End quote ---

Hello.
Can you provide an example of what 'ordinary email' work for you and the one not work. What is your AbanteCart version?
Any errors in the server's log?

AVS:

--- Quote from: Basara on November 13, 2017, 12:47:34 AM ---Hello.
Can you provide an example of what 'ordinary email' work for you and the one not work. What is your AbanteCart version?
Any errors in the server's log?

--- End quote ---
Hi,
I am using AbanteCart V1.2.11

Just now done some changes in Email settings, DNS Management settings in host server etc... I am using all email addresses  with my domain name, though Google's G Suite free edition, (formerly GoogleApps and I am one of those who has free edition registered several years back). I made some settings in the host that made it work.
 Now SMTP  for alert Mail settings works perfectly. Email perfectly arrives at inbox when someone orders product. Also customers receive order details sent from "mydomain.com". It might be useful to someone looking for solution for similar problem I had. The following is what I did.

1.Login in to account where the domain is hosted (not Google Admin console).
2.Locate the page for updating domain’s DNS records.
This page might be called something like DNS management, Name server management, or Advanced settings.
3. Now add SPF record in DNS management page.
To do so, click add SPF record in Create a TXT record tab, containing this text: v=spf1 include:_spf.google.com ~all
and wait for few hours to 48 hours to get this new DNS settings to get propagated in web throughout internet. New SPF record can take up to 48 hours to go into effect, but sometimes happens more quickly.
4. Now login to google email settings -->Forwarding POP/IMAP and check if POP is enabled and also IMAP is enabled. Not sure if it is absolutely necessary, but for me it worked.
5. In the Abantecart admin panel, in the Mail settings, SMTP HOST is set to: ssl://smtp.gmail.com ( for https domains otherwise just smtp.gmail.com)
 ( this is for custom domain name also. Note that, ssl://smtp.mydomain.com is throwing error. But '@mydomain' email address works through google gmail smtp itself as we are using G SUITE)
6. Port is set to:465
7. Ensure that email address in the store settings and Mail settings for alert is same. If not, sometimes google servers might conclude it as spoofing and filter it and never deliver emails. For some people it might work with different Email IDs  but the domain must be same as Abantecart installation and in both store settings and Mail alert settings. One can use xxxxx @ mydomain.com in store settings as well as Mail alert settings.

Thanks
 :)

Navigation

[0] Message Index

[#] Next page

[*] Previous page

Go to full version
Powered by SMFPacks Social Login Mod