Please help us to make AbanteCart Ideal Open Source Ecommerce Solution for everyone.

Support AbanteCart eCommerce

Author Topic: Shop logo not displaying in order notification email  (Read 7363 times)

Offline ronanmag

  • Newbie
  • *
  • Posts: 14
  • Karma: +0/-0
    • View Profile
Shop logo not displaying in order notification email
« on: January 17, 2013, 04:15:05 AM »
Hi,
I'm not seeing my shop logo when I place a test order and redirect the notification email to a client like Thunderbird or Seamonkey.
I just get a link at the top left of the mail.

It does work if I redirect to a gmail address and view it on webmail page.

Am I missing something or is it working as designed ?

Thanks,
Ronan

Offline abolabo

  • core-developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 1891
  • Karma: +290/-11
  • web for all, all for web!
    • View Profile
    • AbanteCart
Re: Shop logo not displaying in order notification email
« Reply #1 on: January 17, 2013, 04:55:52 AM »
whta view mode of your email client was set? i mean setting  something like this  "show letters as html (or plain text)"
“No one is useless in this world who lightens the burdens of another.”
― Charles Dickens

Offline ronanmag

  • Newbie
  • *
  • Posts: 14
  • Karma: +0/-0
    • View Profile
Re: Shop logo not displaying in order notification email
« Reply #2 on: January 17, 2013, 09:22:20 AM »
Default setting in Thunderbird client - view message body as "Original HTML"

I've got invoices etc,. from other cart software and it displays their shop logo no problem.




Offline ronanmag

  • Newbie
  • *
  • Posts: 14
  • Karma: +0/-0
    • View Profile
Re: Shop logo not displaying in order notification email
« Reply #3 on: January 17, 2013, 09:36:28 AM »
I did a fresh install of the cart to test if it was a problem with my logo or something.

The install is using the sample data and I registered an account and purchased an item.
The only change I made on  the backend was the email address to send orders to.

I'm still seeing the same issue, so I've attached a screenshots -
Displays as a link in email client
Displays AbanteCart logo in Gmail

« Last Edit: January 17, 2013, 09:40:43 AM by ronanmag »

Offline ronanmag

  • Newbie
  • *
  • Posts: 14
  • Karma: +0/-0
    • View Profile
Re: Shop logo not displaying in order notification email
« Reply #4 on: January 18, 2013, 04:09:17 AM »
Ok, so these seems to be a common issue......it's also a bug on Open Cart but they have a hack to fix it.

$template->data['logo'] = 'cid:' . md5(basename($this->config->get('config_logo'))) . '.jpg';

Is there a way to hardcode the logo gif in AbanteCart or what file should I be looking at to do it??

Thanks

Offline abolabo

  • core-developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 1891
  • Karma: +290/-11
  • web for all, all for web!
    • View Profile
    • AbanteCart
Re: Shop logo not displaying in order notification email
« Reply #5 on: January 18, 2013, 07:41:45 AM »
i added this changes into 1.1.3 but not see result. I tried different variants but unsuccessfully. :( i give up.

Please check this commit if you have a time
https://github.com/abantecart/abantecart-src/commit/5f115ee0f4c5e53b31bf4a9b28d42fb419197082

and let me know.

Thanks.
“No one is useless in this world who lightens the burdens of another.”
― Charles Dickens

Offline ronanmag

  • Newbie
  • *
  • Posts: 14
  • Karma: +0/-0
    • View Profile
Re: Shop logo not displaying in order notification email
« Reply #6 on: January 29, 2013, 01:20:13 AM »
I installed 1.1.3 and I'm now getting the logo as an attachment

Offline abolabo

  • core-developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 1891
  • Karma: +290/-11
  • web for all, all for web!
    • View Profile
    • AbanteCart
Re: Shop logo not displaying in order notification email
« Reply #7 on: January 29, 2013, 08:04:50 AM »
I installed 1.1.3 and I'm now getting the logo as an attachment
me too. but thunderbird don't want to show it inside message text. I have no idea why. All img src writes as cid:uniquie_attachment_name.
“No one is useless in this world who lightens the burdens of another.”
― Charles Dickens

Offline Nimitz1061

  • Full Member
  • ***
  • Posts: 190
  • Karma: +21/-0
  • No matter where you go, there you are...
    • View Profile
Re: Shop logo not displaying in order notification email
« Reply #8 on: January 30, 2013, 02:49:18 AM »
I'm not seeing any attention being paid here as to whether Thunderbird is set to allow image display in any of the tests being performed.

Also, keep in mind that some security tools will prevent image display in mail - and I haven't seen any discussion of that..

David

Offline abolabo

  • core-developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 1891
  • Karma: +290/-11
  • web for all, all for web!
    • View Profile
    • AbanteCart
Re: Shop logo not displaying in order notification email
« Reply #9 on: January 30, 2013, 06:28:07 AM »
I'm not seeing any attention being paid here as to whether Thunderbird is set to allow image display in any of the tests being performed.

Also, keep in mind that some security tools will prevent image display in mail - and I haven't seen any discussion of that..

David

Thanks, David.
But i don't use any security tools.  i works on ubuntu linux os.
i think something wrong with format, but still can't to find where is bug.
“No one is useless in this world who lightens the burdens of another.”
― Charles Dickens

Offline ronanmag

  • Newbie
  • *
  • Posts: 14
  • Karma: +0/-0
    • View Profile
Re: Shop logo not displaying in order notification email
« Reply #10 on: January 31, 2013, 05:12:26 AM »
I have TB set to :
 View Message Body : As Original HTML

I also tried installing an add on called - Show All Body Parts 1.2

Enable the View | Message Body As | All Body Parts message display mode, which causes all parts of the message, even those that normally would not be displayed, to be visible in the message viewing area (if Thunderbird knows how to display them) and listed in the attachments pane.

It didn't help......


Offline ronanmag

  • Newbie
  • *
  • Posts: 14
  • Karma: +0/-0
    • View Profile
Re: Shop logo not displaying in order notification email
« Reply #11 on: January 31, 2013, 05:17:44 AM »
Here's part of a thread on the OC forum that appears to fix the issue.

I've had the same problem with my image logo not showing up in order confirmation emails when viewed on Thunderbird, Seamonkey, and my iPad - they seem to show up okay on my Webmail, though.

I don't know if this will help you, but this is what worked for me.

Open catalog\model\checkout\order.php

Line 233 -

Code: Select all
    $template->data['logo'] = 'cid:' . md5(basename($this->config->get('config_logo')));


Add '.jpg' to the end, as follows -

Code: Select all
    $template->data['logo'] = 'cid:' . md5(basename($this->config->get('config_logo'))) . '.jpg';


Do the same on line 432 -

Code: Select all
    $mail->addAttachment(DIR_IMAGE . $this->config->get('config_logo'), md5(basename($this->config->get('config_logo'))));


Change it to -

Code: Select all
    $mail->addAttachment(DIR_IMAGE . $this->config->get('config_logo'), md5(basename($this->config->get('config_logo'))) . '.jpg');


I didn't think it would be as simple as that but now the logo shows up just fine in Seamonkey and my iPad. I'm no expert (I'm a complete OC newb), but I imagine this'll only work if your logo is jpg. If it's gif or png you'll probably want to change the jpg to whatever extension you're using.

I only figured it out because I compared the OC admin newsletter email with the order confirmation email and noticed that the ".jpg" was missing from the end of the "cid" number on the order confirmation email. Hard-coding it in like I have probably isn't the correct way to fix it, but it works so I'm a happy bunny.

I hope this works for you.
« Last Edit: January 31, 2013, 05:34:59 AM by abolabo »

Offline abolabo

  • core-developer
  • Administrator
  • Hero Member
  • *****
  • Posts: 1891
  • Karma: +290/-11
  • web for all, all for web!
    • View Profile
    • AbanteCart
Re: Shop logo not displaying in order notification email
« Reply #12 on: January 31, 2013, 05:33:39 AM »
yes.
i saw it.
we already use cid: md5($logo_filename);  too.

“No one is useless in this world who lightens the burdens of another.”
― Charles Dickens

 

Powered by SMFPacks Social Login Mod